1. TripMX's Avatar
    Hello everyone, I'm in need of help and advice on the possibilities of successfully getting my device right.

    THE CAUSE: While trying to completely eradicate an app using iFile, I searched for the app name and pulled up 3 files...the .deb, .ipa, and a folder with the app's name on it with a few numbers in the title. I noticed that the folder was in the directory of /WebData or /WebKits.....I had forgotten exactly, but I deleted it because I thought it was a part the app. I felt a little suspicious about that folder.

    THE PROBLEM: There was a delay and then an error message after trying to delete that folder in particular...it couldn't get deleted completely. Now, my Springboard has missing icons/apps including my entire dock and first page. I can no longer search on the "left side history" for the "disappeared" apps. When I try, it says "Unsupported URL"; it only works for the apps that did not disappear.

    So basically, my mainstream native iPad stock apps (Settings, Safari, YouTube, Mail, etc.) are now inaccessible and so are all of my Cydia apps, however mobilesubstrate, activator, multiflow, etc. tweaks are still fully functional. With iFile inaccessible, I SSH into my device and find that all of my "apple apps" are still in var/mobile/Applications, as they should be.

    I've read in a few places that you can delete certain Cache, Icon, Springboard, etc. files so that the device can re-create them. I tried deleting a couple of files with little to no luck.......does anybody know what I could delete in order for the device to re-create all of my missing icons?

    Thanks in advance!!
    Last edited by TripMX; 2012-11-11 at 03:41 PM.
    2012-11-11 03:35 PM
  2. DC_Dave's Avatar
    Hi, you might like to check your iFile trash can incase your deleted files are in there. It is at
    2012-11-11 05:26 PM
  3. TripMX's Avatar
    OK, after a while of trial and error, I decided to the distance and go for iOS 5.1.1, however, along the way, I ran into a multitude of problems, but eventually got what I wanted.

    Dev-Team was right, the iPad2 (A5 chip device) can be downgraded even from iOS 6.0.1 as long as you have 4.x SHSH blobs. It can be tricky though!!

    STEP #1 - GET SHSH blob
    ISSUE: [Running Windows XP] Ran into problems with Tiny Umbrella (latest version) only showing the blobs for 6.0.1 and giving me a "hopeful" message in the log. Since the alert popped up saying that the Cydia server became "unreliable", I unchecked it. I then tried iFaith, but that program completely rejected my device. I was then convinced that I lost my SHSH blobs somehow with the initial mishap, so I ran the latest redsn0w and noticed that my SHSH blobs were still there, but I couldn't GRAB 'em. Frustrated, I try Tiny Umbrella again and this time, I re-check the Cydia server option and run the TSS server for a minute. I then turned off the TSS server and pressed the button to Save All SHSH Blobs...and magically, they all appear!! Oh the relief, because had it failed again, I would have restored in iTunes to 6.0.1 and lose my blobs forever. After that, I restored to iOS 6.0.1 in iTunes WITH backup data.

    STEP #2 - GET latest redsn0w (I used version 0.9.15b3 because 0.9.14xx doesn't support iPad 2)
    ISSUE: I ran the RESTORE process (had the correct 4.3.3 IPSW and 5.1.1 IPSW files)...also I had checked in PREFERENCES the checkbox with the "Use DFU method when possible" option. Next, the process....everything went smoothly until after the kernel operation; I got an "invalid kernel" error, and it ABORTED instantly, so I exited redsn0w and tried again and got a "could not start" error, so I tried it again and the same thing happened. I then read that it's best NOT to start WITH backup data, so I went to Settings and used the Erase All Data option. I tried the process in redsn0w again, and I got past the kernel!!.......the dubbed "hacked 4.3.3 IPSW" (official 4.3.3 IPSW) was successfully installed on my device, but when the kernel upload switched to add 5.1.1, I got the "could not start" error again (Note after this, my firmware is going through a recovery loop). Frustrated, I tried going into iTunes and holding "SHIFT" (Windows) to Restore my device using the 5.1.1 IPSW file....got the infamous 3194 error. So, I try ONE MORE TIME in redsn0w...and the same new problem happened. After the error, redsn0w asked if I wanted to assume that my device is running 5.1.1...I agreed and used my 5.1.1 SHSH blob to "continue" the restore beyond the error. SUCCESS!!! It worked and completed the installation of 5.1.1 even though I doubted it'd work!!

    STEP #3 - Enjoy the up and downgrade from iPad 2 WiFi (4.3.3) to iPad 2 WiFi (6.0.1) to iPad 2 WiFi (5.1.1)

    I wanted an untethered jailbreak on iOS 5.x because alot of my apps required 5.x updates and it was simply time to update. During this process, I had to upgrade to iOS 6.0.1, so I got a glimpse of the awesomeness. iOS 6 is sleek and looks really neat, especially in the AppStore, although it is a bit more minimalistic. This is from a guy coming from being on iOS 4 for a long time. The rumored untethered jailbreak for iOS 6.0.1 is coming soon from what I hear (maybe in a month or two from now). I will gladly stay on iOS 5 until Cydia apps catch up...I can downgrade anytime anyways. xD
    2012-11-13 04:01 AM