1. NewD's Avatar
    This has also been achieved without having to make decisions on what tweaks to run to help mitigate the constant resprings. We have been running a bunch of tweaks, pushing our phones to try and force a respring and still nothing. This is definitely the way to go I think.
    Yep.. turns out it was never a RAM issue at all with UIWebKit. It was a CPU overage that's been causing our resprings... which is still technically a bug in UIWebKit that Apple needs to fix in my opinion.. WKWebView's secret to success is that it uses only 15% CPU (according to Bench tests I saw) where UI-WK (in its current buggy state) uses upwards of 83% just for itself.. CPU overage... Respring city.. Interesting.... who knew....

    If Cydgets can get the needed overhaul to utilize WKWebView - June can put all the cool blur, etc features back in EVO.
    Last edited by NewD; 2014-12-17 at 06:32 PM.
    2014-12-17 04:19 PM
  2. June'sIphone's Avatar
    Can someone send me test cases for GroovyLock? Would be easier to convince Saurik if I had data to show him.

    Sauriks response to WKWebView

    "Note that if Cydget uses WKWebView, then the Cycript code would have to be run in the background process and not SpringBoard, which would make a lot of what it does more frustrating. It also is not entirely clear how to make it "safe"."

    My test on safari vs cydget.





    Shows Safari to be around 30% faster than cydget.

    WKWebView is a new implementation in iOS8 to allow hybrid apps to run at the same performance equivalent to Safari so it makes since why it would be better imo.

    Interesting enough if you run Dromaeo: JavaScript Performance Testing it crashes cydget so I am not able to get a test. Maybe it wouldn't crash groovylock? Would be nice if the testers did these tests.

    Javascript tests
    Dromaeo: JavaScript Performance Testing
    https://www.webkit.org/perf/sunspider/sunspider.html
    Last edited by June'sIphone; 2014-12-17 at 11:43 PM.
    2014-12-17 11:38 PM
  3. June'sIphone's Avatar
    Yep.. turns out it was never a RAM issue at all with UIWebKit. It was a CPU overage that's been causing our resprings... which is still technically a bug in UIWebKit that Apple needs to fix in my opinion.. WKWebView's secret to success is that it uses only 15% CPU (according to Bench tests I saw) where UI-WK (in its current buggy state) uses upwards of 83% just for itself.. CPU overage... Respring city.. Interesting.... who knew....

    If Cydgets can get the needed overhaul to utilize WKWebView - June can put all the cool blur, etc features back in EVO.
    Can I see these bench tests? I didn't remove any features from Evo if anything I added a lot more. I just removed styling. By removing heavy fonts, body animations, and blurred menu backgrounds fixed my issues.
    2014-12-17 11:59 PM
  4. NewD's Avatar
    Can I see these bench tests? I didn't remove any features from Evo if anything I added a lot more. I just removed styling. By removing heavy fonts, body animations, and blurred menu backgrounds fixed my issues.
    Ill grab the webshots I saw June.. Hang on..
    2014-12-18 12:27 AM
  5. NewD's Avatar
    2014-12-18 12:36 AM
  6. glacius7's Avatar
    i hope you could forward this to iOS8.
    2014-12-18 05:39 AM
  7. June'sIphone's Avatar
    i hope you could forward this to iOS8.
    I am currently doing this.

    From post #1313

    "Majority of everything has been fixed, with new features added. The only thing needing attention is memory management. It seems to be running stable atm, but in extreme instances it will cause a respring. I have fixed most of these issues, by cutting down on the "pretty stuff" blurred backgrounds, fade in/out animations etc. Although I really liked them the OS just cannot handle it. I would like to say it is an issue with WebKit, but take that as a grain of salt as I have seen no WebKit bugs issued.

    I have a few people testing now and have taken the rest of the month off for Christmas and to get LockBuilder working. I would say it is stable enough for release now, but the extra testing is much needed. I do plan on rewriting a couple features so it will still take some more time. There is a lot of "movable parts" to go through, but it should work fine on all 5s, 6, and 6+.

    As for eta maybe by the end of this week so far I've put in about 40hrs in the update I figure 40-60 more and it will be good to ship.

    Most of the previous themes will work on the new devices, but this is where it gets tricky. All themes now rely on LockBuilder Evo. I talked with Macciti and there is no way to connect them to a new package.

    A new package is needed as app icons and some core features do not work like they did on iOS7. What I have decided to do is update LockBuilder Evo to 3.0. It will still work fine for iOS7 devices. For iOS8 I will release an addon for LockBuilder Evo.

    This will require you to have both installed LockBuilder Evo and the addon cydget LockBuilder Evo iOS8. By doing this it will give you access to all the themes that were previously available since you have LockBuilder Evo installed.

    Hope that wasn't confusing. Just wanted to let everyone know I am hard at work on it."
    2014-12-18 05:52 AM
  8. June'sIphone's Avatar
    Uploading themes just got a little bit easier.

    2014-12-18 02:14 PM
  9. rmax67's Avatar
    Any timeline for LockBuilder Evo iOS8 yet.
    2014-12-21 03:02 AM
  10. NeilJClements's Avatar
    Why do I get this? I'm using an iPhone 6 Plus on 8.1.2
    The theme displays beautifully and works a treat. I just get this message when I hit home to open the phone.
    LockBuilder Evo "The Evolution has begun"-imageuploadedbymodmyi1419220796.650118.jpg
    Obviously I've downloaded AND enabled LB Evo Cydget or it wouldn't be displaying the lockscreen, so the message isn't helpful.

    Edit: The "Vision" theme sends me into safe mode. This is the first time my 6+ has ever been into safe mode and I have virtually no tweaks installed.
    The Redline theme works great, with exception to the message I detailed above.

    I am happy to provide anything you need to fix it, however, based on our history I appreciate this may not be welcome. I installed this app as I wanted to update my themes to stop the endless emails requesting me to modify them and, being honest, it's a superb app for LS theming. I am therefore happy to do anything to stop the 'index' message and the frequent safe modes if you would like?

    I have only WB, HideMe8, CCQuickPro and Classic Dock installed. If you need any other info I'm happy to provide it.
    Last edited by NeilJClements; 2014-12-22 at 05:16 AM.
    2014-12-22 05:02 AM
  11. Poolman1's Avatar
    Why do I get this? I'm using an iPhone 6 Plus on 8.1.2
    The theme displays beautifully and works a treat. I just get this message when I hit home to open the phone.
    LockBuilder Evo "The Evolution has begun"-imageuploadedbymodmyi1419220796.650118.jpg
    Obviously I've downloaded AND enabled LB Evo Cydget or it wouldn't be displaying the lockscreen, so the message isn't helpful.

    Edit: The "Vision" theme sends me into safe mode. This is the first time my 6+ has ever been into safe mode and I have virtually no tweaks installed.
    The Redline theme works great, with exception to the message I detailed above.

    I am happy to provide anything you need to fix it, however, based on our history I appreciate this may not be welcome. I installed this app as I wanted to update my themes to stop the endless emails requesting me to modify them. I am therefore happy to do anything to stop the 'index' message and the frequent safe modes if you would like?

    I have only WB, HideMe8, CCQuickPro and Classic Dock installed. If you need any other info I'm happy to provide it.
    Did you install the iOS 8 addon from Cydia?
    2014-12-22 05:17 AM
  12. NeilJClements's Avatar
    These are what I've got installed:
    LockBuilder Evo "The Evolution has begun"-imageuploadedbymodmyi1419222144.480155.jpg
    Is there an additional tweak I need?
    2014-12-22 05:22 AM
  13. Poolman1's Avatar
    These are what I've got installed:
    LockBuilder Evo "The Evolution has begun"-imageuploadedbymodmyi1419222144.480155.jpg
    Is there an additional tweak I need?
    How do you have it setup in the Cydget settings? This is how I have mine:
    If you don't put the iOS 8 addon on top it will do that.
    2014-12-22 05:33 AM
  14. NeilJClements's Avatar
    Brilliant! Thank you, that has sorted it.
    I looked at that and thought I had it right, but clearly I didn't.
    It's also stopped the 'safe mode' for the other themes.
    Thank you for your help. Very much appreciated and I can now press on and modify my themes.
    2014-12-22 05:49 AM
  15. Poolman1's Avatar
    Brilliant! Thank you, that has sorted it.
    I looked at that and thought I had it right, but clearly I didn't.
    It's also stopped the 'safe mode' for the other themes.
    Thank you for your help. Very much appreciated and I can now press on and modify my themes.
    You're very welcome, glad I could help.👊
    2014-12-22 05:51 AM
  16. June'sIphone's Avatar
    You're very welcome, glad I could help.��
    You only need one checked bud. It won't hurt to have both checked, but only iOS8 is needed.

    New thread btw.
    http://modmyi.com/forums/iphone-5-ne...-evo-ios8.html
    2014-12-22 06:29 AM
  17. devlon's Avatar
    hey -- i downloaded the LBEvo Theme RW, the red one with diagonals on it, but the individual icons aren't showing up for me. they're just blank spaces, with empty boxes. When I tap on them, it brings up a dialog box saying "Index.html". Any ideas what'sa going on? I'm on 6+, iOS 8.2.
    2014-12-29 04:21 AM
  18. June'sIphone's Avatar
    hey -- i downloaded the LBEvo Theme RW, the red one with diagonals on it, but the individual icons aren't showing up for me. they're just blank spaces, with empty boxes. When I tap on them, it brings up a dialog box saying "Index.html". Any ideas what'sa going on? I'm on 6+, iOS 8.2.
    http://modmyi.com/forums/iphone-5-ne...vo-ios8-7.html
    Please either email issues to [email protected] or use the thread above. Half of that question is already answered there.
    2014-12-29 05:03 AM
  19. ellersbee's Avatar
    Scrolling through and saw this for first time just now. One word.....Hot! Need more like this June!
    2014-12-31 09:41 PM
  20. ripmeast's Avatar
    I'm attempting to use the Weather Rude Description widget from June's 6th pack but keep getting a message about Options.plist only working with iWidget.

    Also, suddenly, I can't reach the lock screen menus by swiping. For whatever reason, the entire screen moves as one.

    I'm on a 5s running 8.1.2


    Sent from my iPhone using Tapatalk
    2015-01-14 05:58 AM
1,354 ... 175765666768
LINK TO POST COPIED TO CLIPBOARD