User Tag List

  1. s1p35's Avatar
    Just recently – 2 days past – my camera app stopped working. As of this post, its not even turning on. Before, it merely showed a black screen with the main shutter button not responding.

    This is for all camera related apps – not just the stock Apple one.

    Before this occurred, there was no trauma either software-wise nor hardware-wise so its quite strange. Because I’m on 7.0.4, I can’t restore this iphone.

    What I’ve done is:

    1) Reset all settings through Settings App
    2) Use iLEX R.A.T to reset to stock iOS w/o losing jailbreak
    3) Used SemiRestore7 to “semi-restore” the iPhone.

    None of these options worked. I’m including a video on YouTube of the direct issue occurring whilst opening the Camera App as well as the list of Cydia Apps installed on my iPhone. Hopefully this will be enough to troubleshoot mine (and others’) issues in regards to this strange flaw.




    UPDATE: In SAFE MODE I'm able to access the front camera (STOCK APP) but the back camera is still a no go. It just freezes and stalls. No response and I have to force quit the app.
    Last edited by s1p35; 2014-04-27 at 06:13 PM. Reason: update
    2014-04-27 03:44 PM
  2. Bo Troxell's Avatar
    You have a ton of tweaks, also some from pirate repos. I would start by eliminating them.
    I'd use iLex again, maybe install one tweak at a time and perhaps help find the culprit that way. My bet it's a tweak/pirate repo.
    smaller sig.png
    2014-04-27 08:32 PM
  3. s1p35's Avatar
    Thanks for your input but its not a valid suggestion. If I semi restored the iPhone with both iLEX as well as SemiRestore7 to no avail - and both of them remove ALL but the default apps - then removing each individual tweak/ extension/ add-on won't help.
    2014-04-28 03:26 AM
  4. Simon's Avatar
    Well, it's one of two things. Either it's software related and the level of restoring ilex and semi-restore provide is not deep enough to remove the issue, in which case only a full restore and loss of jailbreak will fix it. Or something has gone wrong with your camera hardware wise (it does happen).
    Personally I would say it's a hardware issue from what you have described and tried.
    2014-04-28 03:32 AM
  5. s1p35's Avatar
    I'm not able to put up a video in SafeMode - since it will not record - but what occurs is that the camera app does indeed open. I am able to switch to the front camera and take pictures but reverting back to the rear camera causes the app to freeze.

    As I've mentioned, there was/ is no significant trauma to either hardware or software - in my most recent usage - so although your initial point is valid, the second point is not logical.

    I'm querying this issue - instead of upgrading and restoring - because I am interested to see if this particular issue can be resolved peacefully - without losing jailbreak.
    2014-04-28 03:38 AM
  6. Simon's Avatar
    Trauma isn't needed for a hardware error to occur.
    2014-04-28 03:41 AM
  7. s1p35's Avatar
    It is a possibility but can be considered only when I do a complete restore and rule out the other parameters.

    Any methods to troubleshoot?
    2014-04-28 03:45 AM
  8. Simon's Avatar
    From what you have tried already I don't know of many other options you have to troubleshoot it further without restoring. Maybe using icleaner pro and disabling tweaks to see if any one of them could be the issue, but probably not necessary since you have wiped all tweaks both times you tried ilex and semi-restore. Maybe after a ilex or semirestore restore look into the file system with something like ifunbox and see if any dylibs are getting left behind in Library/MobileSubstrate/DynamicLibraries. If there are still some there then not everything is getting wiped and you can start narrowing down suspects from what you see that is still there.
    2014-04-28 03:52 AM
  9. s1p35's Avatar
    That's quite helpful - I'll try it tonight and post the findings.
    2014-04-28 03:56 AM
  10. s1p35's Avatar
    There were a few leftover files from MyWi but once they were deleted, the camera still did not work.

    As of now, I'm going to take the issue as hardware based. I'll attempt to get it replaced tomorrow or the next day and will post the outcome as well.
    2014-04-28 06:08 PM
  11. Simon's Avatar
    Ya, my money is still on it being hardware based. Interesting to know some mywi things get left behind after a ilex/semirestore.
    2014-04-28 06:44 PM
LINK TO POST COPIED TO CLIPBOARD