1. waynestu's Avatar
    You're not using UniAW7.1. 7.1 wouldn't have the if (XMLTEST == true) line in it.. Redownload from page one of this thread.. And add the groovyAPI.do line.. then all should be fine.


    Thank you so much for your patience


    Sent from my iPhone using Tapatalk
    2015-02-27 07:09 PM
  2. jasonmilford's Avatar
    From post 1: (Try & let me know).

    "Seems there is an issue with LockHTML3/4, so for temporary fix, LockHTML3/4 users must delete widget.plist, widget.html and config_iwidget.js or just rename them or backup on pc".

    Also, set it back to "auto" in the Config.js,
    That fixed it, sorry didn't realize that was in post 1.

    Thanks
    2015-02-27 10:33 PM
  3. Boots's Avatar
    ok startin to notice a few things off
    its pouring rain here and i have cloudy, gently breeze, its also night time & i got no twilight & its set to true, i also noticed that if i dont put a color code in the second-lights ring it still pick up my day/night colors and shows
    UniAW7-imageuploadedbymodmyi1425085266.729591.jpg
    2015-02-28 02:02 AM
  4. Pibe77's Avatar
    ok startin to notice a few things off
    its pouring rain here and i have cloudy, gently breeze, its also night time & i got no twilight & its set to true, i also noticed that if i dont put a color code in the second-lights ring it still pick up my day/night colors and shows
    UniAW7-imageuploadedbymodmyi1425085266.729591.jpg
    BTW...Very nice setupUniAW7


    Inviato dal mio iPhone utilizzando Tapatalk
    2015-02-28 02:14 AM
  5. NewD's Avatar
    Is anyone else having major phone heating up issues with 7.1 running in GL+ and GB+ with just clouds and balloons sun and moon on - the simple stuff?

    With or without Insomnia turned on.. Lots of heat up issues with 7.1 for me.. Go back to 7.0 and no heating issues of any kind. Ian, could the change from
    3d to translate x in css/js have anything to do with this?

    iPhone 6 - 8.1.2 Taig JB..
    2015-02-28 03:37 AM
  6. <Ian Nicoll/>'s Avatar
    Is anyone else having major phone heating up issues with 7.1 running in GL+ and GB+ with just clouds and balloons sun and moon on - the simple stuff?

    With or without Insomnia turned on.. Lots of heat up issues with 7.1 for me.. Go back to 7.0 and no heating issues of any kind. Ian, could the change from
    3d to translate x in css/js have anything to do with this?

    iPhone 6 - 8.1.2 Taig JB..
    No idea, lets wait for confirming reports.



    ok startin to notice a few things off
    its pouring rain here and i have cloudy, gently breeze, its also night time & i got no twilight & its set to true, i also noticed that if i dont put a color code in the second-lights ring it still pick up my day/night colors and shows
    Can't do anything about the weather.
    Twilight works, it only shows from one hour before sunset time till sunset time.
    The lightRing is also working as it should, leave it blank & it will use day/night colors, input a color & it will use that, if you want no color you switch it off with var ShowSecondsLightRing = false;
    Last edited by <Ian Nicoll/>; 2015-02-28 at 03:59 AM.
    2015-02-28 03:53 AM
  7. <Ian Nicoll/>'s Avatar
    Is anyone else having major phone heating up issues with 7.1 running in GL+ and GB+ with just clouds and balloons sun and moon on - the simple stuff?

    With or without Insomnia turned on.. Lots of heat up issues with 7.1 for me.. Go back to 7.0 and no heating issues of any kind. Ian, could the change from
    3d to translate x in css/js have anything to do with this?

    iPhone 6 - 8.1.2 Taig JB..
    ONLY FOR GRANT
    Can you can test with these css files, I changed it back to translate3d, (same as UniAW7 now).
    Attached Files
    Last edited by <Ian Nicoll/>; 2015-02-28 at 04:25 AM.
    2015-02-28 04:17 AM
  8. Pibe77's Avatar
    if i set in Config.js

    var superLiteMode = true

    and

    var noAnimationsOnStartup = false

    i notice that: always i get no animation on startup...even after clicking on clock to enable animation....

    animation on/off work fine if i set
    var superLiteMode = false

    ....maybe it's right....

    Edit
    ip 6 ios 8.1 with Convergance



    Inviato dal mio iPhone utilizzando Tapatalk
    2015-02-28 04:26 AM
  9. <Ian Nicoll/>'s Avatar
    if i set in Config.js

    var superLiteMode = true and var noAnimationsOnStartup = false i notice that: always i get no animation on startup...even after clicking on clock to enable animation.... animation on/off work fine if i set var superLiteMode = false
    Maybe it's right?
    ip 6 ios 8.1 with Convergance
    It's correct, in the main.js file I have pre-selected some settings, which will override the ones in the Config.js. I will add a small note to the settings in the Config.js file so you know they are no longer working when SuperLiteMode is active.

    This is in main.js file: (all these switches will not function in Config.js when using SuperLiteMode).
    Also, for SuperLiteMode, all weather animations are set to a minimal setting.
    Code:
    if (superLiteMode == true) {
        ShowSecondsLightRing = false;
        No_Forecast_On_Start = true;
        Second_Hand_Sweep = false;
        SecDisplay = false;
        noAnimationsOnStartup = true;
        realMoon = false;
        Show_Birds = false;
        ShowAstronaut = false;
    }
    Last edited by <Ian Nicoll/>; 2015-02-28 at 04:44 AM.
    2015-02-28 04:37 AM
  10. Pibe77's Avatar
    It's correct, in the main.js file I have pre-selected some settings, which will override the ones in the Config.js. I will add a small note to the settings in the Config.js file so you know they are no longer working when SuperLiteMode is active.

    This is in main.js file:
    Code:
    if (superLiteMode == true) {
        ShowSecondsLightRing = false;
        No_Forecast_On_Start = true;
        Second_Hand_Sweep = false;
        SecDisplay = false;
        noAnimationsOnStartup = true;
        realMoon = false;
        Show_Birds = false;
        ShowAstronaut = false;
    }
    Thanks for quick replay UniAW7


    Inviato dal mio iPhone utilizzando Tapatalk
    2015-02-28 04:44 AM
  11. chevymusclecar's Avatar
    Thank you very much Ian and David!
    Runs and looks great!
    ...Just one thing is var ampm = true/false changing from 12hr and 24hr for you?
    2015-02-28 05:20 AM
  12. <Ian Nicoll/>'s Avatar
    Thank you very much Ian and David!
    Runs and looks great!
    ...Just one thing is var ampm = true/false changing from 12hr and 24hr for you?
    Hi bud, are you using WW? If so you change it in WW settings. The switch in the Config.js file only works when using gps or locale.
    But I'm sure you know this already, rough night? LOL
    Last edited by <Ian Nicoll/>; 2015-02-28 at 05:28 AM.
    2015-02-28 05:24 AM
  13. NewD's Avatar
    ONLY FOR GRANT
    Can you can test with these css files, I changed it back to translate3d, (same as UniAW7 now).
    Will do tomorrow, bro. Late here! But thanks!!
    2015-02-28 05:28 AM
  14. chevymusclecar's Avatar
    Agh your right brother never mind lol! Thanks for setting me straight! I love this version it's very smooth bravo!
    2015-02-28 05:29 AM
  15. <Ian Nicoll/>'s Avatar
    I just found a major issue, so be aware till it's addressed.

    Situation:
    You have the widget set up to start without animations (var noAnimationsOnStartup = true and you have already tapped the clock to start the animations.
    So at this point you have animations now running & UniAW logo showing on the clock. All good so far.
    But...
    When your weather automatically updates the UniAW logo changes to the condition icon (like animations are off) but animations are still running, so naturally you will tap the clock & the icon will change to the logo & you will get the "Animations on" text, BUT the animations were already on! so now you have double animations running - NOT GOOD.

    It's very hard to see this, I just noticed it because I have an action set-up to manually refresh the weather, & when I pressed the clock I saw the sun get a lot brighter (because there were now 2 suns).

    To fix this you can just tap the bottom half of the clock 2 times but this is not ideal if you have a small refresh time (mine is set to 90 minutes as I refresh manually when needed) or make sure the animations are off when you don't use your phone.
    Or set var noAnimationsOnStartup = false; AND var superLiteMode = false; till we fix this.

    Sorry

    I will try to find the issue but I know this is more like Dacal's department.
    Last edited by <Ian Nicoll/>; 2015-02-28 at 06:25 AM.
    2015-02-28 06:19 AM
  16. NewD's Avatar
    That issue could certainly cause my phone heat up issue - don't you think? Double animations running?
    2015-02-28 06:42 AM
  17. Simon's Avatar
    Double rainbow all the way! What does it mean? Lol
    2015-02-28 06:46 AM
  18. <Ian Nicoll/>'s Avatar
    That issue could certainly cause my phone heat up issue - don't you think? Double animations running?
    Yes, but it won't give you double animations unless of that unique situation:
    1. var noAnimationsOnStartup = true;

    2. You have pressed the clock to activate the animations. (UniAW logo now showing)

    3. Your weather automatically updates. Now on screen you still see animations but logo has changed to weather icon (like animations off but they are still running), no double animations at this point.

    4. You tap the weather icon on the clock, you then get "Animations On" message, but they were already running so now they are double.

    5. You leave it like this for a long time! HOT

    I can actually get triple or quadruple animations

    So basically if you have var noAnimationsOnStartup = true; and at some point you see animations running with weather icon showing - beware, when you tap the clock once you will have double animations running, tap it 2 more times and it's back to normal.

    It's very confusing I don't know where to start looking for this issue LOL.

    HELLO, DAVID, ARE YOU THERE? LOL
    Last edited by <Ian Nicoll/>; 2015-02-28 at 07:25 AM.
    2015-02-28 07:13 AM
  19. <Ian Nicoll/>'s Avatar
    Double rainbow all the way! What does it mean? Lol

    What do you mean "What does it mean?" What does what mean?
    2015-02-28 07:18 AM
  20. <Ian Nicoll/>'s Avatar
    Link Updated again.

    I managed to fix the double animations issue

    Actually the fix was easy peasy, just the figuring it out was the hard part.
    Last edited by <Ian Nicoll/>; 2015-02-28 at 01:29 PM.
    2015-02-28 09:39 AM
LINK TO POST COPIED TO CLIPBOARD