User Tag List

  1. signori's Avatar
    In the "animations.js" file, quite near the bottom, look for this:

    Code:
    // BIRDS FROM IAN NICOLL
    
    function createBirds() {
    	if (navigator.userAgent.indexOf('OS 8') == -1) {
    		if (where == "day") {
    			if (Show_Birds == true) {
    					var image = document.createElement("img");
    					image.id = "Birds";	
    					image.src = "Images/Weather/birds/Birds.gif";
    					document.getElementById("birdsContainer").appendChild(image);
    			}
    			if (V_Formation_Birds == true) {
    					var image = document.createElement("img");
    					image.id = "V_Birds";	
    					image.src = "Images/Weather/birds/V_Birds.gif";
    					document.getElementById("birdsContainer").appendChild(image);
    			}
    		}
    	}
    }


    Now comment out these to lines with "//" as below:

    Code:
    // BIRDS FROM IAN NICOLL
    
    function createBirds() {
    //	if (navigator.userAgent.indexOf('OS 8') == -1) {
    		if (where == "day") {
    			if (Show_Birds == true) {
    					var image = document.createElement("img");
    					image.id = "Birds";	
    					image.src = "Images/Weather/birds/Birds.gif";
    					document.getElementById("birdsContainer").appendChild(image);
    			}
    			if (V_Formation_Birds == true) {
    					var image = document.createElement("img");
    					image.id = "V_Birds";	
    					image.src = "Images/Weather/birds/V_Birds.gif";
    					document.getElementById("birdsContainer").appendChild(image);
    			}
    		}
    //	}
    }


    Let us know if they are working again (assuming you are now on iOS 8.1.1) if they are still not working just reverse what you did to disable them again.
    Hey Ian. I can say that since I updated to 8.1.1, I can run one of Marty's 6.4 themes on the lockscreen a lot better. Even the birds flap there wings like before. When I run RC7 as an iwidget animations only at the same time it is better. But When I unlock my phone it will respring sometimes. But I never tried enabling the birds yet. So you can probably run the RC7 by itself and it will run a lot better. There will still be resprings but not as many as 8.1.
    2014-11-30 05:28 PM
  2. intramorph's Avatar
    Ran in to a bug of sorts. When running UNIAW7 with GroovyLock on I6 iOS 8.1. I should probably mention that I have weather info disabled and all the backgrounds disabled. Just running weatherwalls with all the weather animations. When I wake up the phone it all works perfectly. But if I let it fall asleep again before unlocking it, the animations stop dead in their tracks right where they are. And won't move at all untill I unlock the phone. I should probably also mention that I'm also running SubtleLock8 the latest beta, Forecast, Priority Hub and LockGlyph
    I'd like to try to figure out which tweak if any is causing the conflict or if it's UNIAW7....
    2014-11-30 05:47 PM
  3. signori's Avatar
    I was running RC7 as an iwidget animations only. The birds just float across the screen doing nothing. But my phone did a lot more resprings. I am also running one of Marty's 6.4 themes on the Lockscreen at the same time. Sorry I will try not to talk about resprings anymore.
    2014-11-30 05:58 PM
  4. TiLT1oNE's Avatar
    Set us as new phone. It's best practice to always do it this way when jailbreaking. Don't ask my why, I don't know, it's just the general advice given from people "in the know", which is not me, I just follow their advice.
    Thanks Ian, and after the JB process I can use my ios 8.1 itunes backup? Or is it better, when we go a fw higher, to not use an itunes backup and set as "new phone". Is that itunes backup only good to restore, when we use the same fw?
    2014-11-30 11:00 PM
  5. King_O_Hill's Avatar
    I don't use iTunes backup ever, but that's just me. Anything I need is in the cloud, and I just reinstall from scratch.

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0
    2014-11-30 11:13 PM
  6. <Ian Nicoll/>'s Avatar
    I don't use iTunes backup ever, but that's just me. Anything I need is in the cloud, and I just reinstall from scratch.
    Thats what I do too, I never backup either, but I never use the cloud either, just reinstall what I want with iTunes & sync contacts, music etc from iTunes. Don't know the reason, I just want to be sure I get no crap (hidden files or whatever) from old JB.
    Last edited by <Ian Nicoll/>; 2014-12-01 at 05:45 AM.
    2014-12-01 04:23 AM
  7. Splatty79's Avatar
    Just a heads up, I have updated to 8.1.1 and my random resprings have stopped using Uniaw widgets/sbhtml. Happy!
    2014-12-01 04:26 AM
  8. bliken's Avatar
    Just a heads up, I have updated to 8.1.1 and my random resprings have stopped using Uniaw widgets/sbhtml. Happy!

    Are you using any animations on your LS?
    2014-12-01 04:29 AM
  9. Splatty79's Avatar
    Are you using any animations on your LS?
    yep full animations and passcode/id
    iPhone 6
    2014-12-01 04:49 AM
  10. NewD's Avatar
    yep full animations and passcode/id
    iPhone 6
    I'm not getting any resprings on 8.1 iPhone 6 and running UniAW7 on SB and LS. Maybe one respring every 36 hours or so. But no complaints here..
    2014-12-01 06:07 AM
  11. cocco26's Avatar
    let me tell you guys what i notice after update to 8.1.1 2 days ago i all goes well jb is stable but what i notice now is that 8.1.1 is worst then 8.1 meaning that i got resprings yesterday using uniaw7 and dacal animate LS now after all those resprings i try to figure what cause that as on 8.1 never had that problem back on 8.1 now what i discover is that 8.1.1 is exactly as ios7 webkit suck with the password on i set password off and i am using virtual home and ghess what my phone wont respring and the uniaw7 works great this worked for me not sure for others that have i6 and 8.1.1
    2014-12-01 09:29 AM
  12. Kazuyoshi's Avatar
    I think apple is not at the end with improving their webkit bugs unfortunately


    -----------------------------------------------------------
    WebKit

    Available for: iPhone 4s and later, iPod touch (5th generation) and later, iPad 2 and later

    Impact: Visiting a maliciously crafted website may lead to an unexpected application termination or arbitrary code execution

    Description: Multiple memory corruption issues existed in WebKit. These issues were addressed through improved memory handling.
    -----------------------------------------------------------
    Matux is past ... Kazuyoshi is back (thx Simon )

    Dropbox
    : exxOS -- Shine --
    2014-12-01 09:33 AM
  13. cocco26's Avatar
    I think apple is not at the end with improving their webkit bugs unfortunately


    -----------------------------------------------------------
    WebKit

    Available for: iPhone 4s and later, iPod touch (5th generation) and later, iPad 2 and later

    Impact: Visiting a maliciously crafted website may lead to an unexpected application termination or arbitrary code execution

    Description: Multiple memory corruption issues existed in WebKit. These issues were addressed through improved memory handling.
    -----------------------------------------------------------
    yea but the strange thing is that on 8.1 never had such issue with pass on and animations
    2014-12-01 09:39 AM
  14. thewaytozion's Avatar
    Sorry for asking (again - I did not checked all the past posts-too many)

    I am using widget weather 2 beta and it is running smoothly with ww base lockscreen.

    I also downloaded UniAw7 RC7 and using the option widgetweather. No weather will be loaded to LS or SBHTML.
    If I switch to gps within Config.js weather will be loaded again. Is this a fault on my side or is it a known issue on UniAw's side ?

    Thanks
    2014-12-01 10:10 AM
  15. Kazuyoshi's Avatar
    Sorry for asking (again - I did not checked all the past posts-too many)

    I am using widget weather 2 beta and it is running smoothly with ww base lockscreen.

    I also downloaded UniAw7 RC7 and using the option widgetweather. No weather will be loaded to LS or SBHTML.
    If I switch to gps within Config.js weather will be loaded again. Is this a fault on my side or is it a known issue on UniAw's side ?

    Thanks
    Hey Eric, this is the problem I described here and in WW2.0 for my i6+ device. I5s same widget/widgets are working on WW2.0
    Matux is past ... Kazuyoshi is back (thx Simon )

    Dropbox
    : exxOS -- Shine --
    2014-12-01 10:26 AM
  16. thewaytozion's Avatar
    Ian, David,

    Are you working on it right now (or are you busy with ww2 release)? No hurry- I just want to know it and with that I can assess whether it makes sense to fix it for my LS or whether I should wait because you will release an update soon?

    Cheers
    2014-12-01 10:34 AM
  17. King_O_Hill's Avatar
    I believe that it's only affecting the 2 of you guys atm. Strange issue, and I'm baffled as to why? Maybe you guys can post your .xml files so we can see what's going on.

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0
    2014-12-01 12:10 PM
  18. Kazuyoshi's Avatar
    Here you are

    *pm sent*
    Last edited by Kazuyoshi; 2014-12-01 at 01:01 PM.
    Matux is past ... Kazuyoshi is back (thx Simon )

    Dropbox
    : exxOS -- Shine --
    2014-12-01 12:52 PM
  19. thewaytozion's Avatar
    You received a message
    2014-12-01 12:59 PM
  20. NewD's Avatar
    yea but the strange thing is that on 8.1 never had such issue with pass on and animations
    You're the first I've heard report this, Cocco. Other iPhone 6 users, like MamaJaay report no instability with passcode lock on and 8.1.1. Do you only experience it when running UniAW7 on LS?
    2014-12-01 01:08 PM
12,555 ... 3070787980818290130180580 ...
LINK TO POST COPIED TO CLIPBOARD