1. kelcel's Avatar
    ok i do have winter board and LockHTML4 installed so tell me where did you put the Weather Elements in your phone
    etc var / mobile / library ?? get it ? thanks



    It is the Weather Elements Theme. I just replaced the original wallpapers with a few of my own. You can download LockHTML in Cydia (it's ios 9 (compatible). Then just follow the instruction from the first post in this thread on setting up this theme and you are good to go! It's worth mentioning too that I do not have Winterboard installed on my phone (possibly part of the issue, I don't know) instead I have Anemone installed, and I placed the weather elements theme in Anemone's theme folder. However, I noticed that I do not need to have the theme selected in Anemone for it to work. It simply needs to be turned on in LockHTML4.
    2015-10-28 11:30 PM
  2. 1hihum's Avatar
    It should be var/stash/themes
    2015-10-28 11:49 PM
  3. Zed63's Avatar
    hi guys,

    Since 9.02 the script in the lockbackground.html:


    <script>
    var width = window.innerWidth;
    if(width == 375){
    viewport = document.querySelector("meta[name=viewport]");
    viewport.setAttribute('content', 'width=device-width, initial-scale=1.18, maximum-scale=1.18, user-scalable=0');
    }
    else if(width == 414 ){
    viewport = document.querySelector("meta[name=viewport]");
    viewport.setAttribute('content', 'width=device-width, initial-scale=1.3, maximum-scale=1.3, user-scalable=0');
    }
    else{}
    </script>
    for the automatically upscaling (ip 6, ip6+) does'nt work anymore. Don't know why. so you you have to adjust every single value. A lot of work. I have done this für the ip6, but not for the 6+. Im sorry.

    U cantry the new LockBackground attached in this post.

    CU
    Zed
    Attached Files
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz
    2015-10-29 12:18 AM
  4. Zed63's Avatar
    ähem, forgot something: The animations doesn't work correctly to - same Problem as the main theme.

    I'm using the them with lockhtml3, 'cause the notifications will not correctly shown in the lockscreen using lockhtml4

    CU
    Zed
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz
    2015-10-29 12:21 AM
  5. 1hihum's Avatar
    That did the trick! Thank you Sir!!! How do you edit that? Are you on ios 9? I should mention that the animations worked great for me last night. It rained off and on in the area (and I played around with the locations a bit to test) and the rain worked every time without a hitch. But even after the adjustment (using your file) it appears that the animations are still not sized correctly (perhaps another file that needs to be updated?)
    Last edited by 1hihum; 2015-10-29 at 12:50 AM.
    2015-10-29 12:45 AM
  6. Zed63's Avatar
    yes, i'm on 9.02. The Theme works as usual after reediting the lockbackground.html using XCode (Mac). it took a few hours to adjust the values for every text line and the table on the right forecast-Screen.
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz
    2015-10-29 12:49 AM
  7. Zed63's Avatar
    sorry again: the animations must be edited in the css-files for every single animation i'don't use them, so i won't edit them.

    CU
    Zed
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz
    2015-10-29 01:02 AM
  8. 1hihum's Avatar
    Sorry, I'm a bit confused. What exactly are you editing to make it work? Is it the CSS file, or the html? And what was it that you changed? Thanks again for the help Zed!
    2015-10-29 01:11 AM
  9. kelcel's Avatar
    yes, i'm on 9.02. The Theme works as usual after reediting the lockbackground.html using XCode (Mac). it took a few hours to adjust the values for every text line and the table on the right forecast-Screen.

    Wonder if you can help iPhone 6 9.0.2 using LockHTLM4 did all that was said in the frist post all i get is this any ideas thanksWeather Elements HD 6 Version late 2014-img_1342.png
    2015-10-29 02:48 AM
  10. kelcel's Avatar
    Sure - i know this set. Someone designed it a few years ago. It would be very nice to have the original artwork-files to delete the slice at the bottom.

    CU
    Zed
    Hi i have that File from years ago but not sure hoe to post it here would love to get it back on my iPhone 6 9.0.2 let me know how to post it ok thanksWeather Elements HD 6 Version late 2014-tstorm12.pngWeather Elements HD 6 Version late 2014-tstorm3.pngWeather Elements HD 6 Version late 2014-tstorm1.pngWeather Elements HD 6 Version late 2014-tstorm1_night.pngWeather Elements HD 6 Version late 2014-sunny.png
    2015-10-29 05:57 AM
  11. Zed63's Avatar
    Sorry, I'm a bit confused. What exactly are you editing to make it work? Is it the CSS file, or the html? And what was it that you changed?
    Sorry bro ...

    Since 9.02 is out - the script in the lockbackground.html i've posted above does'nt work anymore. the script was needed for upscaling the the size of the png and the descriptions for the ip 6 & ip6+.

    So it Looks like this:



    this is the size for the ip5 / 5s

    I changed every single value in the lockbackground.html i've posted last night. Now the theme wokrs correctly again:



    I didn't change anything in the css-files in the Folder "animations". Too much work.

    I talked with the guy who create the upscaling-script. He has no idea whats wrong with the script under 9.02

    did someone tried it with anemone?

    Got me?

    Wonder if you can help iPhone 6 9.0.2 using LockHTLM4 did all that was said in the frist post all i get is this
    try again with deleting the old symlinks first. Then copy the follwowing files:

    /var/mobile/Library/WebClips/WeatherElements.webclip/Storage/Databases.db (file)
    /var/mobile/Library/WebClips/WeatherElements.webclip/Storage/file_0 (folder)

    navigate to /var/mobile/Library/Caches choose "Create Link" to create a sym link - Now the database should be ready to read the weather conditions.

    if it's not working the permissions in the filesystem must be changed. look in post #1 for my description.

    Good luck.

    Zed
    Last edited by Zed63; 2015-10-29 at 07:27 PM.
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz
    2015-10-29 09:53 AM
  12. 1hihum's Avatar
    Wonder if you can help iPhone 6 9.0.2 using LockHTLM4 did all that was said in the frist post all i get is this any ideas thanksWeather Elements HD 6 Version late 2014-img_1342.png
    Wonder if you can help iPhone 6 9.0.2 using LockHTLM4 did all that was said in the frist post all i get is this any ideas thanksWeather Elements HD 6 Version late 2014-img_1342.png
    so you've got the base wallpaper to show up, but nothing else? Are the boxes populating when you open the icon (units, time, language etc) or are they blank? what location are you using? Does it tell you that your selections have been saved when you hit the save button?
    2015-10-29 10:12 AM
  13. 1hihum's Avatar
    Sorry bro ...

    Since 9.02 is out - the script in the lockbackground.html i've posted above does'nt work anymore. the script was needed for upscaling the the size of the png and the descriptions for the ip 6 & ip6+.

    So it Looks like this:



    this is the size for the ip5 / 5s

    I changed every single value in the lockbackground.html i've posted last night. Now the theme wokrs correctly again:



    I didn't change anything in the css-files in the Folder "animations". Too much work.

    I talked with the guy who create the upscaling-script. He has no idea whats wrong with the script under 9.02

    did someone tried it with anemone?

    Got me?



    try again with deleting the old symlinks first. Then copy the follwowing files:

    /var/mobile/Library/WebClips/WeatherElements.webclip/Storage/Databases.db (file)
    /var/mobile/Library/WebClips/WeatherElements.webclip/Storage/file_0 (folder)

    navigate to /var/mobile/Library/Caches choose "Create Link" to create a sym link - Now the database should be ready to read the weather conditions.

    if it's not working the permissions in the filesystem must be changed. look in post #1 for my description.

    Good luck.

    Zed
    Are you saying that is how yours looks even after using the file you posted earlier today? Because mine looks like this now. I would update the animation scripts myself if I had a clue what I was doing.

    Weather Elements HD 6 Version late 2014-img_0014.png
    2015-10-29 10:26 AM
  14. Zed63's Avatar
    yes. the second screenshot is the new look with my modified html-file. What's the Problem? What is wrong or missing? Don't worry about the missing Location - i've hide it via the db.html.

    I'll have a look into the css-file later today. But it seems so that is necessary to change every single animation.
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz
    2015-10-29 11:32 AM
  15. kelcel's Avatar
    so you've got the base wallpaper to show up, but nothing else? Are the boxes populating when you open the icon (units, time, language etc) or are they blank? what location are you using? Does it tell you that your selections have been saved when you hit the save button?
    No the boxes are blank i have changed all the permissions but i have changed the db file in ifile the location is CAXX0483 and one other thing the helm file is blank when i open it both the new one not the origanal thanks
    2015-10-29 03:07 PM
  16. kelcel's Avatar
    Weather Elements HD 6 Version late 2014-img_1344.png
    so you've got the base wallpaper to show up, but nothing else? Are the boxes populating when you open the icon (units, time, language etc) or are they blank? what location are you using? Does it tell you that your selections have been saved when you hit the save button?
    Got it missed one permission !! Nice thanks
    2015-10-29 03:51 PM
  17. Zed63's Avatar
    Congratulations Weather Elements HD 6 Version late 2014 the moon over the big apple seems to be an egg? Weather Elements HD 6 Version late 2014

    Ok. That's exactly the problem with the icon set NY. I'm not able to resize the images for the iPhone 6/6+
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz
    2015-10-29 06:40 PM
  18. 1hihum's Avatar
    Weather Elements HD 6 Version late 2014-img_1344.png

    Got it missed one permission !! Nice thanks
    Nice! Would you care to share the "city" wallpapers? I'd love to add them to mine.

    Zed, I thought you were saying that your i6 still looked like the first pic even after the updated file. If there is any way that I can help, please let me know! I'd love to help out. I know it's tough when you are the only one working on something.
    2015-10-29 07:19 PM
  19. Zed63's Avatar
    hi,

    here comes the city-walls: new york theme.

    the pics must be resized at 640 x 1136 instead of 640 x 960 (the size of the iPhone 5).

    the animations under 9.02 are tricky. for example here is the cloud.css in animations/cloud/private/includes

    PHP Code:
    #CloudContainer {
        
    background-colortransparent;
        
    positionabsolute;
        
    top0px;
        
    width320px;
        
    height480px;
        
    z-index0;
        
    overflowhidden;
        
    opacity1.0
    }
    #CloudContainer > div {
        
    positionabsolute;
        
    width250px;
        
    height176x;
        -
    webkit-animation-iteration-countinfiniteinfinite;
        -
    webkit-animation-directionnormalhorizontal ;
        -
    webkit-animation-timing-function: linearease-in;
    }
    #CloudContainer > div > img {
         
    positionabsolute;
         
    width250px;
         
    height176px;
         -
    webkit-animation-iteration-countinfinite;
         -
    webkit-animation-directionalternate;
         -
    webkit-animation-timing-function: ease-in-out;
         -
    webkit-transform-origin50% -100%;
    }
    @-
    webkit-keyframes fade {
        
    0%     { opacity1; }
        
    95%  { opacity1; }
        
    100% { opacity0; }
    }
    @-
    webkit-keyframes float {
        
    0%     { -webkit-transformtranslate(-220px0px); }
        
    100% { -webkit-transformtranslate(640px40px); }
    }
    @-
    webkit-keyframes clockwiseSpin {
        
    0%     { -webkit-transformrotate(-2deg); }
        
    100% { -webkit-transformrotate(2deg); }
    }
    @-
    webkit-keyframes counterclockwiseSpinAndFlip {
        
    0%     { -webkit-transformscale(-11rotate(2deg); }
        
    100% { -webkit-transformscale(-11rotate(-2deg); }

    i think the 3 values in "CloudContainer" must be changed for the iPhone 6 / 6+. and in each animation folder: 22 (!!) Something for a rainy weekend

    CU
    Zed
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz
    2015-10-29 07:40 PM
  20. kelcel's Avatar
    Weather Elements HD 6 Version late 2014-img_1348.png


    Happy Days i got this to work on my iPhone 6 9.0.2 but i know it was talked about here can anyone tell me how to get rid of the bottom slit under the Temp. please and thanks !!
    2015-10-30 12:05 AM
176 ... 56789
LINK TO POST COPIED TO CLIPBOARD