1. metalickaah's Avatar
    I have the same usual problem, iphone is always in headphone mode, tried the solutions suggested like plugin & out several times, hard reset etc. none worked.

    showed the phone to a iphone mechanic, he also tried, changed the headphone jack socket etc.

    he told me than that the problem could be with the IC chip on motherboard and he can not touch it as it's beyond him.

    Right now i'm using my earphones to talk.

    please suggest remedy
    2009-02-01 01:08 PM
  2. calingasan's Avatar
    its not the motherboard. iphone mechanic was just saying that coz he doesnt know the problem. if you restore it, it will get fix but we dont really want a whole restore do we. try playing around with its audio capabilities like the ipod app or changing the settings of your sound and playing around with it. this happens to my iphone when i use it for my car with the headphone jack. when ipod is playing and i pull the plug out without pausing it first iphone sometimes get confuse thus keeping it on headphone mode. iphone can detect if there is a headphone attached to it or not, sometimes the it screws up and fails to do that. this is just a software issue because hardware dont just fail by itself(unless you dropped your iphone or something). if you can handle a full restore, then do so. If cant just play around with it for a few days and it will eventually detect that your headphone is not plugged in and fix itself.

    Hope this helps dude.
    2009-02-01 01:46 PM
  3. gQstatus05's Avatar
    If what calingasan said fixes your problem tell the iPhone tech he just got owned!
    Android user suffering from iPhone withdraw.
    2009-02-01 02:48 PM
  4. metalickaah's Avatar
    I hard reset. restored, erased data from setting options (format) which took an hour, jaiilbroked it again (quickpwn) then restored it from my prev backup, but the problem remains same. still "ringer (headphones)" mode.

    but yes, yesterday the keypad unlock sound came which inspired me to do all of the above.

    today too, i could hear the key pressing tones, unlock sound for few seconds, but gone again. this normally happens in the devices when there is a loose connection

    Now since i've restored the phone right from the scratch, there's not much i can do softwarewise.

    The iphone tech said there cud be something wrong with IC/mainboard etc. He said so cause it was beyond him and was not risking to touch it. he changed the headphone socket too.

    Thier repair of iphone are superficial, opening, cleaning, changing parts etc.

    I'm stuck very bad, can't use, can't sell a 4 gb ipod (previously iphone)
    2009-02-10 10:55 AM
  5. Chubbawokee's Avatar
    has the iphone ever been wet?
    2009-02-10 12:54 PM
  6. metalickaah's Avatar
    no, noting unusual, neither wet nor jerk
    2009-02-11 12:15 PM
  7. Chubbawokee's Avatar
    i've seen something on this before... where the person resolved the issue by purposely restoring with an earlier firmware to get an error and then restored with the current version. i don't know why it would work but you might want to give it a try.
    2009-02-11 03:07 PM
  8. danvicente's Avatar
    this has happened to me but never that severe.. I fixed the problem by plugging in (the belkin adapter for the recessed iPhone jack) and pulled it out. It didnt work the first time when I just put in headphones, and I had to push in and pull out with a slight bit of force. If it doesnt fix ur problem then I am sorry, seems like you may have to send it out for repair, or (judging on how much the repair would cost) wait for the new iPhone!
    17" MacBook Pro
    iPhone 3GS 16G 3.1 Jailbroken//AT&T
    follow me on [email protected]
    2009-02-11 03:15 PM
  9. metalickaah's Avatar
    sometimes, out of a sudden, the unlock makes sound, & increasing the vol shows "Ringer" only, instead of

    "Ringer (headphone)".

    But just as soon as i either try to call/play ipod or other such thing which requires sound from speaker, it

    again goes in to "Ringer (headphone)" mode.

    will try what CHUBAWOKEE said, how can i install earlier firmware.
    this time while resetting i updated to the latest one 2.2.1

    i, firstly went to settings & did "erase all data & settings", & then jailbroke it again, i don't think i can do

    something more effecive software-wise, can i?

    So i just don't understand it's a hardware or software problem.

    As i explained earlier, i've tried all other suggested stuff like, cleaning with earbud, blowing air into socket,

    pluging in-out again & again etc.

    i desperately need a help, cos u can understand that now i'm left with only with an ipod touchof 4GB, can not talk on it like a normal phone, always need the headphone or bluetooth.

    Can't sell it oof either as an iphone & nobody wud take a 4gb ipod
    Last edited by metalickaah; 2009-02-15 at 07:11 AM.
    2009-02-15 07:08 AM