User Tag List

  1. rubayed's Avatar
    I'm using a jailbroken unlocked iPhone 2g which has been pwned and currently on 2.2.1, but suddenly the screen stopped responding, when i press t he power button it does lit up but i cannot slide to unlock it. So i restored it completely and then pwned it all over again and it was working fine for few days but once again it stopped responding,i tried quickpwn and it fixed it again but after working for a while now it stops responding suddenly, so i'm thinking if its a hardware problem then why does it work intermittently after i use quickpwn, but if its s software issue,why is it happening suddenly? It works sometimes after i use quickpwn but then it stops again,I'm tired of quickpwn, what is the main problem? I've searched everywhere, and came across a lot of screen complains but no one seems to have similar problem to mine,hence i m posting it, in a hope to get a more definitive and specific answer from u all on what needs to be done to get it working as its really annoying to have a perfectly responsive iphone going dead suddenly. Pls help.
    2009-03-09 09:53 PM
  2. cpjr's Avatar
    The ONLY way to really tell if its a software issue, is to restore your phone and LEAVE it stock for awhile...and see if it still happens.
    2009-03-09 11:12 PM
  3. rubayed's Avatar
    Thank u cpjr! I have restored it as u had suggested and the screen this time surprisingly still doesnt work,its stuck at a state where a iTunes and a plug sign shows and iTunes says,"The sim card inserted in this iPhone does not appear to be supported" i guess it seems like its a hardware issue. Obviously i wont get any service from the apple store in Montreal since its a 2g jailbroken phone, so what do i do with it to get it fixed? The screen visibly seems perfectly fine, no scratch nothing. I will be waiting for someone from modmyi to help me out pls.
    2009-03-10 01:35 AM
  4. cpjr's Avatar
    Oh, actually....that screen only means its not activated. Can you slide it to the "emergency call only" screen?

    It is very possible that the digitizer (which is what gives it a touch function) is going bad. I have never seen software make it do that....UNLESS, the phone is actually locking up, which could be software related.

    If your using Pwnage, maybe try making a new custom firmware....load ONLY it so your unlocked and activated. Then work that way for a couple days. Basically, try to stay at a minimum with the installs to test it out.
    2009-03-10 01:40 AM
  5. rubayed's Avatar
    Yeah i'm stuck at the not activated stage and cannot slide it to the, "emergency call only" screen. Since the screen isnt working, is there any point pwning it? Is there any ways, i can get it fixed?
    2009-03-10 02:08 AM
  6. cpjr's Avatar
    Well, if it is in fact the digitizer (hardware), you can check on Apple's website to see if its still under the 12 month warranty, if it is...they will replace it.

    And, yeah your unlocked...but just restore it (which you already did)....per Apple's OWN warranty agreement, warranty is NOT dependent on activation.

    If its not under warranty, on a have to buy the entire screen assembly....the part is bout $150.
    2009-03-10 02:21 AM
  7. rubayed's Avatar
    Well,,its been almost 2 years since i bought this iPhone of the ebay, so clearly i don't fall under the category of having 12 month warranty anymore. Beside i live in Canada and 2g iPhone was never sold here legally, so the moment i take it to apple store, they will know its not a legally contracted canadian activated iPhone, even if its restored. I hve no problem paying $150 if it can be fixed but the question is, do i fall under any kind of warranty, which will let apple people in Montreal fix the phone for me AND will they fix it knowing its a 2g iPhone in Canada, even if i m willing to pay for it? Please tell me what to do. thanks!

    I'm just bumping it,, just in case it got lost among all other queries, please give me some advice on what can be done by reading my other post above...i'm running out of ideas..
    Last edited by rubayed; 2009-03-10 at 07:17 PM. Reason: Automerged Doublepost
    2009-03-10 07:17 PM
  8. kdr8's Avatar
    I have 2g-4GB 1st generation model 0000-s from 2007 and wary odd problem with 2.2.1 & 2.2.0 firmwares.
    Restoring with iTunes go fine without the problems and after that constantly reboots than I put him in DFU mode and restore him on 2.1.0. , and start to work fine with some bugs but its ok. What’s really bothers me he was working only ones with 2.2.1 after I restore him from 1.1.4 to 2.2.1 for 3 or 4 days after that he start to reboots himself constantly . I was dumping CPU buffers to see what’s gone wrong with restoring process but didn’t find anything. Is any1 having idea why he accepted only 2.1.0 firmware?
    2009-05-02 01:25 PM
  9. User2522's Avatar
    I have an iPhone 2g 4gb too. My problem is that only part of the upper half of the screen is unresponsive. Anyone have an idea on how to fix it.
    2010-03-10 08:16 PM
  10. Brendon800's Avatar
    Digitizer. I have the exact same problem, bottom of the screen is the only part that is responsive. It was my wifes phone, so I just bought her a new 3G, then bought myself a 3GS, so this one's just sitting here as a decoration 'till I can afford a new digitizer.
    2010-03-11 01:15 AM
  11. cpjr's Avatar
    This is an old thread.

    Yes its the digitizer but on a 2g iphone you have to replace the entire screen assembly and its a fairly pricey part.
    2010-03-11 01:17 AM
  12. badababa's Avatar
    Hi CPJR,
    I am also having the same problem as RUBAYED. will you please tell me more about this degitizer. where can I get this. how to install it?
    2010-03-22 04:15 PM