1. Robcoffee's Avatar
    I picked up an iPhone 3g 16gb cheap off ebay sold as faulty, showing a white screen when powered up - I thought it might be a bit of a project to see if I could get it working.

    Having received it today, overall outer condition is good, no bumps scrapes or cracks. The gause over the speaker to the left of the dock is missing, or at least not visible. Looking in the headphone jack the paper is white but if I look really hard there could be a thin line of pink on the edge of it.

    Plugged it into the computer with iTunes running, nothing happens. Plugged it into the wall charger and left it for a while, nothing. Left it about 40 minutes in the wall charger, then connected it to the computer. I managed to get it into DFU mode, which pulled up the serial no. Tried to restore to 2.2, it got as far as Waiting for iPhone and just sits there. Also the display never shows anything at all throughout this process, does not seem to even light up.

    So far all I can conclude is the battery does not seem to hold charge - I can't get DFU again after getting bored with Waiting For iPhone unless I plug it into the wall charger for another 40 odd minutes. EDIT - I have now concluded the battery is OK and I was just always having problems getting it into DFU with no guidance from the display. I set it off restoring to 2.2.1 last night, it unpacks the firmware, prepares the device, reboots the device (you can hear Windows notify the USB disconnect and then reconnect)and then says Waiting for iPhone - and stays there for as long as the iPhone is connected to the USB. While it is connected it is shown in the usb device tree so it is not shutting off which I orginally thought it was. LCD is obviously stuffed as it is not lighting up at all.

    So does this sound like a total pup? I know cpjr and one1 are the experts on this but rather then pm them I thought a thread might help anyone with a iphone in a similar situation. The lcd is not a huge issue to replace, but what concerns me is this inability to stay charged, is it just the battery or something more serious? I don't really want to get hold of a battery and lcd if it's a hopeless cause, but as I can get it into DFU mode at least some portion of it is still running.

    For what it's worth the serial no. brings up Apple limited Warranty until February 2010, I don't know if its worth trying to get it replaced / repaired by Apple - anyone with experience on this in the UK?

    Any advice will be greatfully received.
    Last edited by Robcoffee; 2009-05-15 at 10:50 AM.
    iPhone 5s 64gb iOS 7
    rMBP 15" 16gb 500gb
    @c0ff33a and @PhoneMainiac
    2009-05-14 11:55 PM
  2. Robcoffee's Avatar
    I'm going to double post on this, I hope nobody minds but I would like to update the situation some 20 days on...

    I found out the home button was stuffed, mainly I found this out because the the glass/digitiser was not even glued around the home button, I tried to pull off the screen protector and the glass came up with it! trying to decide what restore mode you are in with no image on the lcd is pretty hard - I worked out eventually that when you are in recovery mode iTunes gives the device serial number - when you get DFU mode then there is no serial number listed.

    So the home button flex had a split in it, so I ordered a new home button, pretty easy to fit if you have the glass already loose - but if your glass is fixed pretty much no chance. Now I could get DFU mode, but still any firmware came up with error 9 - but only when I got bored of leaving it "Waiting for iPhone" and pulled the cable out from my computer.

    I'd tried restoring pretty much daily for around 15 days, with no joy and had pretty much decided the mobo was stuffed. Then 5 days ago a restore to 2.0 firware took - it produced error 1603 but it went further then it had been before. I managed to use the quickpwn trick of running it and then holding home/power for 15 seconds and then letting go and holding power for 2 seconds then opening iTunes - and it was recognised by iTunes. Still no display but the digitiser worked if I slid to unlock in the correct place.

    So I ordered and fitted a new lcd, which finally gave me something visual to look at (I still think it is weird that the lcd was faulty, but sometimes would show a fully white screen when I hooked it upto the computer - I would have thought it would show nothing if it was bust) and I set about restoring. Still error 9 prevailed, but around 1 in twenty DFU restores would take and it would restore up - activate with my sim, and run full 3g - nice.

    Then the issues, MIC doesn't work, quickpwned it after syching apps etc which caused it to get stuck in endless reboot - took far too many restores to get it back, quickpwned again, synched - and - it kept rebooting in the middle of synching - out of 30 apps it just rebooted while installing 3 times, while synching music it rebooted a few times. Using it as an iphone it would be running fine then you would do something, it freezes and then reboots.

    Weird thing, if I restore and jailbreak but synch nothing - it works fine for as long as I want - i can browse the web with it, download stuff from CYDIA no issue - but as soon as I synch itunes apps and music from the computer the random reboot starts.

    I'm starting to wonder if there is some bad ram in there somewhere, I wonder if there is anything like memtest you can use to test ram on computers>
    iPhone 5s 64gb iOS 7
    rMBP 15" 16gb 500gb
    @c0ff33a and @PhoneMainiac
    2009-06-05 11:04 PM
  3. cpjr's Avatar
    Not "bad ram"......most likely water damage, meaning something on the board is fried.....and unless you have the proper tools and knowhow to probe all the micro-smds and caps then you wont track it down.
    2009-06-05 11:08 PM
  4. Robcoffee's Avatar
    The mobo does look grubby, and it has been pulled from the case before - the do not remove sticker had been chewed up. I pulled the mobo out and fitted it into a 8gb 3g I had that worked perfect to troubleshoot cables etc, it restores first time no problem in that case, but every now and again the reboot occurs without warning - could be opening a app or synching with itunes.

    The weird thing is for so long it was effectively dead when I was trying to restore it, and slowly over the last five days it has improved daily. Almost like it's self healing, so maybe in a few weeks it'll be running 100% if I keep on restoring it. After completing a DFU restore it auto synchs with iTunes as Skynet ;-)
    iPhone 5s 64gb iOS 7
    rMBP 15" 16gb 500gb
    @c0ff33a and @PhoneMainiac
    2009-06-06 12:32 AM