1. rsahar's Avatar
    Alright you guys - I could really use some insight on this one.

    I have been repairing digitizers for months now with no problems.
    Lately however - after I remove the digitizer off the plastic frame the speaker seems to go bad. It becomes VERY FAINT.

    The flex ribbon is in place, I replaced 3 speakers in the last phone I worked on. And nothing, still very faint sound. Something is getting bent out of shape, or getting damaged while removing the old digitizer and I cannot figure it out.

    Anyone see this before?
    2009-06-28 07:05 PM
  2. cpjr's Avatar
    Its either the speaker is gettng damaged, or the digitizer you are ordering. The mesh over the speaker hole being an aftermarket part could be muffling it.
    2009-06-28 07:42 PM
  3. rsahar's Avatar
    No, the digitizers are fine, they operate perfectly. The speaker mesh isn't getting in the way either. And the speaker itself isnt getting damaged becauseI put 3 brand new speakers in the phone and they all operate very faintly.

    any other suggestions?
    2009-06-28 07:44 PM
  4. cpjr's Avatar
    The only other thing it could be is flex cable #3. Thats the only other part that even has anything to do with the speaker.
    2009-06-28 07:47 PM
  5. 601itguy's Avatar
    I am experiencing that problem also. Aside from the ribbon cable being a complete pain to put back in place I see no reason why the earpiece will not work.
    2009-08-07 01:19 AM
  6. timoxa's Avatar
    I'm having a same issue, my proximity sensors not working and the earpiece(not the jack and not the bottom speaker). It happened after ive replaced the digitizer. I didnt mess anything up. Also my touchscreen is very slugging sometimes. anyone figured this out?
    2010-02-16 07:54 AM
  7. DoctriPhone's Avatar
    Not sure what is going on but this happened to me the first time today. Might be the heatgun.. Did you ever get this figured out?
    2010-05-11 04:08 AM
LINK TO POST COPIED TO CLIPBOARD