1. JERECHO's Avatar
    I have a iphone 3g that was jailbroken using pwntool on a macbook pro. I have 3.0 firmware on the phone. It was working great for about 2 weeks and then I got the npebea recovery cartoon. Normally this is no big deal because I just restore the phone to factory settings and then re-jailbreak. Now I can't restore on any of my computers (mac or pc)
    With the windows computers running vista it will get to the point where it extracts the firmware and says its getting ready for restore and then gives me an error 28, the phone cannot be restored. This after I have manually put the phone in DFU mode. On a computer running xp and itunes 7.7 it will get to the part where it says waiting for iphone but wont go any father (i left it on all night to be sure). I have tried everything from ibricker to iliberty and nothing will take it out of recovery mode. Does anyone have any ideas?
    2009-07-16 05:13 AM
  2. Bo Troxell's Avatar
    You want iTunes 8.2 for the 3.0 firmware. I have heard that sometimes people have a tough time jailbreaking with vista. put it back in DFU restore in iTunes 8.2 and setup as a new phone, fresh. Then try the jailbreak over, mac this time.

    Mac pwnage tool
    Last edited by Bo Troxell; 2009-07-16 at 05:39 AM. Reason: Automerged Doublepost
    2009-07-16 05:37 AM
  3. JERECHO's Avatar
    I cannot restore to a fresh new phone because itunes will not resore it. I just tried it again on my mac running itunes 8.2.1
    I put it in DFU mode, tell it to restore, my screen turns white, itunes says preparing to restore and then I get the error 28. itunes cannot restore this phone. Do you have any other ideas?
    2009-07-16 05:50 AM
  4. ugshotgun's Avatar
    Try using another USB port, you need to have a powered USB. I would recommend using another operating system, like XP Home or Pro. Never had a mac, so not sure what the problem would be there. But one thing I do know, based on experience, anytime I had the errors you're having, I either had it on one of my front USB ports, or moved it to another USB and bammo, problem solved.

    Note 4 and iPhone 6 Plus: The best of both worlds!
    2009-07-16 05:41 PM
  5. JERECHO's Avatar
    Thank you for the responce but I am going insane. I have 5 computers in my house. 4 running windows and the mac book pro. I have tried different ports, different cables, different opperating systems, different versions of itunes, different versions of firmware and nothing will work. I have been jailbreaking phones for over 2 years. I know all the tricks and normally I know what to do in this problem but nothing will work. I have a 2g phone that I am using until I fix my 3g so if I have to completely wipe out my phone it is a option. Is there a way to totally erase the hard drive of the phone and start over not using itunes since itunes will not work or am I completly screwed?
    2009-07-17 05:38 AM
  6. Bo Troxell's Avatar
    Yes, put it in DFU mode restore as new.
    2009-07-17 05:42 AM
  7. Robcoffee's Avatar
    Keep trying, forget the latest iTunes stick with the earlier versions of iTunes and firmwares from 2.0 to 2.2.1. You have what I affectionately call a "frozen" iphone, the main processor is locked up and I can't find any quick way to solve it, for no good reason if I keep trying eventually it will restore (I have a couple of 3g's and a 2g that have a tendancy for this naughty sort of behaviour). Make sure you are doing a DFU restore (black screen on the iphone when itunes detects it) and if it says waiting for iPhone for longer then 5 minutes start again - repeat until it either works or you sell it on ebay for parts.
    iPhone 5s 64gb iOS 7
    rMBP 15" 16gb 500gb
    @c0ff33a and @PhoneMainiac
    2009-07-18 01:17 AM
  8. JERECHO's Avatar
    Thank you for your responce. I have tried I don't know how many times already but if you believe that this will eventually work I will keep trying. I have tried with firmware 2.2.1 a million times with itunes version running xp. should I try a different itunes version or do you think this is ok? Im also going to get firmware version 2.0 and try that. If I get it to work I'll post my results. Thanks again.
    2009-07-18 02:49 AM
  9. Poseidon79's Avatar
    Any error in the 20's is seriously bad news! I've had a coulpe friends in that situation and after HOURS of work it never restored. Good luck.
    2009-07-18 02:53 AM
  10. JERECHO's Avatar
    I have tried to restore about 40 times and the same resulst everytime. It gets to the part where it says waiting for iphone and it just sits at that step forever. Can anyone think of what might be wrong or what is broken so I can get a replacement part.
    2009-07-18 06:44 AM
  11. tiguy99's Avatar
    I used to use iLiberty to kick my iPhone out of recovery mode last year before winpwn or pwnage came out.

    It still works if I have a phone stuck this way (which I haven't in a while)

    Try iLiberty 2.4 or 3.0. It should help
    2009-07-20 08:26 PM
  12. Poseidon79's Avatar
    iLiberty doesn't work on anything after 1.1.4. You need a replacement phone.
    2009-07-20 09:00 PM
  13. JERECHO's Avatar
    How do you know a replacement phone is needed. Is this fact or opinion? If fact will you post where you are getting your information. And yes, iliberty will recognize my phone but just flashes that it is in DFU mode and it will not do anything.
    2009-07-21 01:45 AM
  14. tiguy99's Avatar
    I just reread your original post and realized my response is full of FAIL lol. For the guy who says iLiberty doesn't work needs to put his head in the sand.

    We don't need to use the app to unlock or jailbreak the iPhone. We just need it to do DFU or recovery modes. Hell it'll break you outta recovery mode under normal circumstances
    2009-07-21 04:15 AM
  15. JERECHO's Avatar
    I have tried iliberty and it wont do anything. All of the options in the program are greyed out and I can't select anything. All it does it flash DFU at the bottom of the screen. Am I doing something wrong? My itunes will recognize the iphone it just cant restore it (error 28)
    2009-07-21 06:26 AM
  16. bftiedt's Avatar
    try "rock your phone" i had a 2g witha bad com board that was stuck in recovery mode and it kicked it out
    2009-07-21 07:07 AM
  17. JERECHO's Avatar
    Tried rock your phone but all it does it reboot the iphone over and over again.
    2009-07-21 03:45 PM
  18. iGuy's Avatar
    Not sure if I can help but what OSX have you got on your MBP?
    2009-07-21 04:02 PM
  19. JERECHO's Avatar
    Don't know for sure. But I purchased It last December new
    2009-07-21 04:08 PM
  20. iGuy's Avatar
    I bet it's on 10.5.6 hence why your phone isn't recognised when in DFU mode (this OS had a "bug" that was fixed in 10.5.7).

    Update to 10.5.7, make sure iTunes is updated to 8.2.1 and hopefully all will be well.

    Let us know if this is the case.
    2009-07-21 04:16 PM
35 12