1. Violentheart's Avatar
    this is my first post and im at my wits end. I got a 1st gen iphone 3 days ago for 20$ and it had a few probs. the guy told me that it had been dropped in water and after that the screen went wonky. well the screen was kinda white with multicolored stripes. the digitizer apparently worked because i was able to accidentally get to phone mode and after punching the "keys" i played mary had a little lamb somehow. anyway since this was my first experience with an iphone much less a broken one i tried to restore it but no luck. the next day i woke early and started the teardown process based on some sites directions (ifixya or something) got it open with my thin spackle knife, 2 dental picks (both got their tips broken off) and lots of sweat. eventually i got it torn down, kinda bent the case but not too bad, and layed out the parts for a while. I got the gumption to get it back together and outta blind dumb luck managed to get all the cables in and all but one screw in (it took off and i couldnt find it)

    and lo and behold the screen wasnt all stripey and white anymore. it popped up with a thing about accessory not compatible and airplane mode and the slider for emergency calls.
    so i goofed around with it, put my gophone sim in it and it didnt recognize it, bummer. so i proceded to try to restore. no go after it did its thing it went back to itunes detected a iphone in recovery mode bla bla.

    after research i discovered DFU mode and managed to get it to do it and all that but still i was missing something, that and beer didnt help.

    so after many attempts, 4 different machines (G3 clamshell, G4 quicksilver, XP machine and the vista machine at best buy) no restore.

    the sales guy at best buy spent 2 hours goofing with it and even tried to restore 1.1.4 to it ( i believe it was that one) and no go. got a error 1601. i had to go and now im at home trying to get some results.

    Now my questions are:

    1. is there a thing as a stuck home button problem that would get it stuck in restore mode?
    2.am i missing something in this DFU mode restore process that is making it not stick?
    3. should i tear it down again to see if home button ribbon cable is torn?
    4 what other things should i check out if i tear it down again that could be making it be a bastard?

    what am i missing?
    2009-07-22 06:13 AM