1. c.e.p's Avatar
    hey,
    so i soldered the battery with an OEM replacement from ebay...

    once i finished soldering i plugged in the phone to the power and it turned on and everything..i unplugged it to check that the battery was working and it was!

    and so i left it charging overnight and i checked the battery status in the morning and it didnt increase at all??

    the battery indicator showed that it was charging too...

    i dont know whats going on? could i have damaged the battery whilst soldering? or could i have not soldered properly???

    BTW i have an iphone 2g with 3.0 Firmware.
    2009-08-29 01:01 PM
  2. sursture's Avatar
    0 - the "charge meter" is not 100% trustworthy
    1 - a new battery requires some jogging before reaching max capacity
    2 - just make sure to let it deplete completely - thereafter, and ONLY thereafter
    3 - charge to 100% (or as much max at that point is)
    4 - redo the cycle 2-3 times and you should be good.
    Do hope that helps



    _________________________________________________

    **uoʇʇnq sʞuɐɥʇ ǝɥʇ ʇıɥ puɐ puıʞ ǝq noʎ pǝdןǝɥ sɐɥ ǝuoǝɯos ɟı**
    _________________________________________________



    2009-08-29 09:38 PM
  3. c.e.p's Avatar
    yeah ive done that but the problem is that the battery wont charge??
    i drained the battery until it wouldnt turn on anymore and i go and charge it, and nothing happens??
    the phone recognizes that it's plugged in, but it wont charge the battery?
    so it just turns off again when unplug the phone..

    i'm not sure what could be wrong?
    2009-08-30 04:22 AM
  4. c.e.p's Avatar
    so ive drained the battery and now it wont turn on because the battery wont charge!!
    2009-09-02 08:31 AM
  5. bobkooney's Avatar
    I just did the same thing on 3.0 firmware. Replaced the battery. Install went fine, battery meter said 78% initially so I let it discharge completely on the new battery to do my first charge and the phone shows the charging status but will not charge! It shows the charging status indefinitely and the phone will not turn on anymore since the battery appears to not be accepting the charge!
    2009-09-22 05:41 PM
  6. dubster34's Avatar
    Has anyone had any joy yet ?

    I'm in exactly the same position. I've installed the battery, and now it shows that it's charging but never gets any more full.

    Anyone got any ideas ??

    Thanks.

    Scott
    2009-10-01 08:36 PM
  7. Jeandaniel's Avatar
    have someone figure this out? I've got the same problem on my 2G 16GB.

    Help..?
    2009-11-17 09:47 PM
  8. IUiPodRepair's Avatar
    My best guess is that there is an issue with the battery installation.
    2009-11-17 11:14 PM
  9. Jeandaniel's Avatar
    Allright, thanks.

    I will try to install an new OEM.
    2009-11-18 08:09 AM
  10. kenmai9's Avatar
    You probably pulled one of the pads off. The silver square that you solder the wires onto. I did that to my gf's iphone and the exact same thing happened. Sorry, but your communications board is done. :/ (That is, if you made the same mistake..)
    2009-11-19 05:49 AM
  11. Jeandaniel's Avatar
    Now I have try'd to install an new OEM battery but still it wont charge.
    I also have tryed another motherboard and another battery on an new digitizer but still it wont charge.. My Iphone is pwnd (jailb..) can this have anything to say? I have now try'd mute 4 times (up, down, up, down) and the home and powet button for 6-10sec.. Hope this will work..?
    2009-11-22 07:31 PM
LINK TO POST COPIED TO CLIPBOARD