1. Superhorse's Avatar

    I have a Strange problem with my iPhone that I hope somebody can help me with.

    The other day a random message came up on my jailbroken iPhone saying "Restore needed, iphone cannot make or receive cals. Restore from itunes." which I thought was weird as I was literally just holding my phone in my hand at the time. It then brough up the connect to itunes screen as if the sim needed activating. I assumed that a simple restore would solve the problem but when restoring it seemed to take forever. Eventually after several hours it came up with error 1002. Everytime I trieed to restore I got this error and my iphone ws now stuck in the recovery mode screen. I decided try and jailbreak using blackra1n as a longshot to try and get back into the phone and to my surprise it worked and I could get onto my phone. At first it seemed to be back to normal but then the original error message came up "Restore needed, iphone cannot make or receive cals. Restore from itunes." Although it didn't send me back to the activation screen this time, so i went into the settings and noticed that WIFI, BLUETOOTH, and PHONE NETWORK ALL DIDN'T WORK!!! I went into the about section of the settings to see what version of the baseband was running and there was no version listed, it just says modem firmware then a blank box next to it.

    I'm pretty sure that If I could get the baseband working again then my phone would be back to normal but every time I try to restore I get an error. Can anyone think of a way to get my phone working again because without any kind of connectivity it is pretty useless! Any help would be appreciated.

    Sorry for the long message but I didn't want to miss anything out.

    I have found a way to get into my iphone using the USB connection since SSH is imposible since I have no wifi. Is there any way that I can add files onto my phone to fix the baseband.

    I have searched for other threads but they all seem to be for firmware 1.x.x. Has anyone done this recently for formware 3.x.x???
    Last edited by Superhorse; 2009-12-14 at 06:00 PM. Reason: Automerged Doublepost
    2009-12-14 06:00 PM
  2. Poseidon79's Avatar
    Have you tried to put the phone in DFU mode first.. then restore?
    2009-12-14 06:18 PM
  3. vov4ik_il's Avatar
    Same here (http://modmyi.com/forums/3g-s-downgr...ee-heeelp.html).. Nothing helped. I have a 32GB black Brick with Apple logo on it.
    2009-12-14 07:23 PM
  4. Superhorse's Avatar
    Have you tried to put the phone in DFU mode first.. then restore?
    Yes I've tried that many times as well as lots of other things. I have come to the conclusion that the baseband chip has failed so I have sold it online as my upgrade is soon. If anyone has the same issue and doesn't mind taking it to an apple store to get it repaired apparently it will only cost 30 to 40. I just wasted too much time on it in the end and gave up.

    Good luckanyone else with this problem.
    2009-12-21 03:24 PM