User Tag List

  1. Effenpig!'s Avatar
    I've been having occaisional issues with my home button. Sometimes I get no response at all for several button presses. It seems kind of like a hard press sometimes works but not always. Is there a way to tell if this is a hardware issue?
    2010-02-02 06:42 AM
  2. Melech518's Avatar
    Definitely a hardware issue. Do you have a 1st Gen, 3G, or 3GS? There are a few things you can try depending on which generation iDevice you are experiencing this issue on.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME
    2010-02-02 07:24 AM
  3. Effenpig!'s Avatar
    3g

    Should probably have mentioned the phone got slightly wet several weeks ago and the camera stopped working at that time
    Last edited by Effenpig!; 2010-02-02 at 07:35 AM. Reason: Automerged Doublepost
    2010-02-02 07:35 AM
  4. Melech518's Avatar
    I knew it was water damaged already You most likely need to replace the dock connector assembly. You need to open the phone and make sure you get all of the water out of the phone and stop the corrosion now before it gets worse.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME
    2010-02-02 04:21 PM
  5. Effenpig!'s Avatar
    The water damage happened about two months ago. That's how I got the phone for free from my friend. What should I look for when buying the parts I need?

    Also, the volume up doesn't work all the time but volume down does
    Last edited by Effenpig!; 2010-02-02 at 10:39 PM. Reason: Automerged Doublepost
    2010-02-02 10:39 PM
  6. Melech518's Avatar
    You just need this:
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME
    2010-02-03 01:56 AM
  7. Effenpig!'s Avatar
    Is this a difficult process to replace ? I have repaired phones before, never anything like the iPhone though. WhAt is the name of the part?
    2010-02-03 02:41 AM
  8. Melech518's Avatar
    It is very easy. Remove the display, then the main board. Then you can replace the "complete dock assembly" you can find it on eBay
    2010-02-03 02:48 AM
  9. Effenpig!'s Avatar
    Edit: I found the oem part.

    Can you recommend a particular tool kit or will any one be fine. Any tips/trip ups to look out for
    2010-02-03 02:49 AM
  10. Melech518's Avatar
    Go to the guides section and check out the hardware guides I have made. The battery repair guide for 3G should basically tell you what to do with the exception of replacing the battery. There are only 3 screws holding in the dock connector assembly after you remove the main board. Believe it or not, this is an extremely easy repair
    2010-02-03 03:27 AM
  11. Effenpig!'s Avatar
    Do you think the camera not working is related to this part I need tp replace or a seperate issue? If not related how hard is it to replace the camera. Not having a camera isn't too bad except when I accidentally hit the photo button when I'm in an app cause it seems to get stuck since I can't take a photo and I have to turn the phone off and then back on. Sheesh, that was one long sentence.
    2010-02-03 06:06 AM
  12. Melech518's Avatar
    Camera is separate. You most likely killed it with the water damage.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME
    2010-02-03 06:38 AM
  13. ajtoce's Avatar
    i have the same issue with my home button, but my water damage sensors are still white. its a 3gs (now i know lol!)
    2010-02-03 11:45 PM
  14. Melech518's Avatar
    Check to see if you still have the 2 prongs coming off of the home button flex cable? You may have broken one of them when opening the phone.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME
    2010-02-03 11:47 PM
  15. ajtoce's Avatar
    both prongs are intact
    2010-02-04 12:10 AM
  16. Melech518's Avatar
    When you press hard does the home button work? or does it not work at all?
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME
    2010-02-04 12:14 AM
  17. ajtoce's Avatar
    its really random, sometimes it works every other push and sometimes i can push it a bunch of times, even push really hard, and it wont work.
    2010-02-04 12:18 AM
  18. Melech518's Avatar
    Have you attempted a restore to fix the problem? If both water damage indicators are intact and the phone is under warranty you can always get a replacement.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME
    2010-02-04 12:21 AM
  19. Hackin' Fool's Avatar
    I have a problem with my first gen iPod touch 16 gig. The home button registers a double tap for each push. I have to push it very gently about half way in for it to recognize a single tap. I haven't dropped it in water, but Texas is very dusty and I think I may have gotten some debris under the button. I haven't taken it apart yet. Any ideas?
    2010-02-04 02:37 AM
  20. ajtoce's Avatar
    Have you attempted a restore to fix the problem? If both water damage indicators are intact and the phone is under warranty you can always get a replacement.
    well I've opened it up so technically its not under warranty. also, the nearest repair shop is over 50 miles away so its not worth my gas to drive over there. i have tried a restore and that didn't work, I can't figure out what the problem is.
    2010-02-04 02:59 AM
21 12
LINK TO POST COPIED TO CLIPBOARD