1. wide_load's Avatar
    hi, i posted this at the end of another topic but i think its a separate issue and there are also a few updates.

    I replaced the battery and now it wont charge at all even after putting the original back in so i assumed that i had missed a connector or something but it all looks fine and i'm sure i haven't done anything stupid.

    When i plug the power adapter in it goes straight to the battery full icon, when using USB it takes a few seconds then goes to it despite the level being 11%. the same charger charges my friends ipod just fine. so far i have tried restoring the firmware and scowering the board for signs of me being thick.

    does anyone have any ideas, anything at all would be good by this point i have spent 6 hours trying to get the thing to work today.

    if anyone knows anything about how the charging circuit works that would also be useful as i have no idea.

    The new thing is that after leaving it on charge all day i got a small shock off the chrome rim, leading me to think that something is not grounding properly, or is grounding when it shouldn't.

    thanks in advance

    Jacek

    any comments or help at all would be appreciated.

    okay i seem to have fixed it

    for anyone else having this problem, there is a small copper pin on the motherboard under the do not remove sticker i guess it provides ground for the mobo, anyway mine was bent in slightly. simply bend it out a bit reassemble and problem solved, new battery charges up fine 23% and climbing as i write this.
    Last edited by wide_load; 2010-03-10 at 04:54 PM. Reason: Automerged Doublepost
    2010-03-10 04:54 PM
  2. bazai's Avatar
    I'm having the same problem after replacing the new battery on my 3GS. I'm going to try your solution. Hopefully, that will fix it.

    Thanks for sharing.
    2011-03-21 06:43 PM
  3. harmon's Avatar
    thanks for that tip, i knew that ground served a purpose just didnt know what.
    2011-03-21 09:41 PM
LINK TO POST COPIED TO CLIPBOARD