1. abrrymnvette's Avatar
    Phone: iphone 3g 8gb stock-not JB

    A portion of the screen stopped working. The area is the bottom row of icons area. But the docked icons (ipod, mail, phone, safari) still work. She's claiming she has to press multiple times for things to work sometimes. She said it's slowly been getting worse and just a couple days ago is when the bottom row stopped working.


    ****I searched and all I found was "do a factory restore" ****
    2010-04-23 10:10 PM
  2. Cid6.7's Avatar
    Try a restore 1st but Im thinkin new digitizer for sure..
    2010-04-24 09:19 PM
  3. WTFDANG <3's Avatar
    Yeah you need a new digitizer, restoring it doesnt mean its going to fix the physical aspects of the phone.

    <3
    2010-04-26 07:27 PM
  4. cpjr's Avatar
    Yeah you need a new digitizer, restoring it doesnt mean its going to fix the physical aspects of the phone.

    <3
    Actually software can/and has been known to...cause issues with the touch functionality on the phone, obviously since its the software that controls that.

    However, if a restore doesnt fix the issue it is obviously a hardware/digitizer problem.
    2010-04-26 08:28 PM
  5. z3r01's Avatar
    9 bucks on ebay , thats nothing i just ordered a 3GS screen for 9 and a camera for the 3GS
    2010-04-26 08:44 PM
  6. Micara57's Avatar
    Yeah, trying a restore would always be best, also make sure the phone doesnt have any moisture on it, as that often causes issues with the digitizer.

    Otherwise you need a new digitizer, they're pretty simple to install and numerous guides on YouTube.

    Helped? Click the THANKS button.
    It's only impossible if you quit.
    2010-04-27 01:00 AM
  7. iamubiquitous's Avatar
    But actually, mine seems to be working again...does this indicate hardware malf? bad connection or something....these posts are same prob too:
    http://modmyi.com/forums/hardware/71...tizer-not.html
    http://modmyi.com/forums/hardware/70...sometimes.html
    http://modmyi.com/forums/hardware/70...ne-screen.html
    Rules one and two ALWAYS in effect.
    2010-05-23 09:41 PM
  8. abrrymnvette's Avatar
    Put the new digitizer in from Ebay. Didn't work immediately so I took it back apart and reseated the ribbon cable into the motherboard. Put it back together and booted it up. After about 2 min the screen started working again like new. Even responded faster. Now if I could only get it to stop dropping 50% of the calls, I'd be in heaven. Guess the only cure for that is Verizon though. Thanks for the help guys.
    2010-05-24 02:28 PM
LINK TO POST COPIED TO CLIPBOARD