1. mikerlx's Avatar
    I thought my ear speaker was broken as I could not play youtube videos or movies with sound. The phone does ring out loud and speakerphone works well. So, I cut off a headphone plug and plugged into the jack and I have sound. I found on goggle all the remedies but don't work. Has anyone had this happen? How to fix?
    2010-05-19 08:20 AM
  2. jamesham123's Avatar
    Would there maybe be a small bit of medal foil etc lodged in the jack socket? Happened to me a while back.
    2010-05-19 03:20 PM
  3. mikerlx's Avatar
    I solved the problem by cutting the tip off the metal plug from a broken pair of headphones. I used an tx torque to push the plug tip until it snapped in place.permanent fix.
    2010-05-20 01:26 AM
  4. JEZTRAVEL's Avatar
    I solved the problem by cutting the tip off the metal plug from a broken pair of headphones. I used an tx torque to push the plug tip until it snapped in place.permanent fix.
    I am sorry but I don't understand... Did you jam a headphone jack into the socket? How does that cure the problem? I thought that would make the iphone "think" that the headphones were in use and therefore stop the spaeakers working? Can you explain???
    2010-05-24 04:45 AM
  5. mikerlx's Avatar
    No, I cut the tip off the headphone plug and carefully pushed into bottom of Jack once snaps in ur phones back to normal. I just posted a utube video on permanetly fix stuck in headphone mode.

    No the flex cable is defective and needs replacing my method is a permanent hack cuz it will never go out of headphone mode otherwise.
    Last edited by mikerlx; 2010-05-24 at 05:14 AM. Reason: Automerged Doublepost
    2010-05-24 05:14 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.