1. juanmtb's Avatar
    Hi fellow iphone guru's,

    Please read carefully as I will explain in details what I have already done.

    I have an iPhone 3G 8GB that will not power up on it's own. But it does power up when plugged into USB and automatically turn off when unplugged.

    I repair iPhones (or at least try to LOL) so this is what I did, with no success.

    1) Changed the whole back housing, audio jack, volume / mute switch
    2) Changed the screen / digitizer

    As you can see I do have some skills and this is not my first repair.

    So I assembled everything properly and the phone will only work when plugged in.

    Next, i tried to reset / restore the phone but would end up with error : This iPhone could not be restored ( Error 23 )
    I suspect getting this error because during the restore process, it's starts in DFU but after verifying iPhone firmware it goes into battery mode and fails. Stays lite because it's still plugged in.

    I don't suspect it being the battery as I have swapped the board and everything loads up fine with the other board, That tells me I have no problems in the way I remounted it.

    Something is wrong with the board but I can't locate it. Anyone ? Pictures can help too ...

    I appreciate you guys helping out...

    P.S: Trying to press HOME / POWER will not help me in this case. I have tried it.
    2010-05-31 04:48 PM
  2. juanmtb's Avatar
    Any one ? It's been a week I have posted this ... Still no answer...

    ERROR 23 - Am i out of luck ? After trying to restore a firmware on the phone, it lagged and i unplugged it. Now the baseband is kaput ? I'm not covered uner warranty and i'm afraid to bring it to the Apple store since I bought the phone second hand.

    Can I do anything about this one ?
    2010-06-07 11:28 PM
  3. goonerm3's Avatar
    What firmware are you trying to restore with? If its not the latest one I suggest you do. If you're worried about sim unlock, make sure you use a custom 3.1.3 ispw that keeps the baseband unlockable.
    2010-06-08 04:22 AM
  4. tag8402's Avatar
    I'm having the exact same problem.

    I replaced the housing and when I reassembled the phone it would do exactly what yours is doing.

    If it's plugged in the phone will function properly but as soon as you unplug it, it'll shut off.

    I have a mophie juicepack case and if I leave that on it the phone will be just fine. I can't figure it out.

    if you find an answer, let me know! i'm still looking.
    2010-06-12 05:44 AM
  5. ihaz3g's Avatar
    what firmware are yall on?
    2010-06-15 07:48 AM
  6. asma123's Avatar
    problem is gonna be your board unfortunately. you can try bypassing connection from the battery to the board.
    2010-06-17 06:29 AM
  7. dabp's Avatar
    Just had that same issue - changed the battery and dock connector, now everything is fine
    2010-12-07 10:23 AM
  8. Nopstnz8's Avatar
    Yeah I was going to say. This sounds like a battery problem because the only reason it boots when plugged in, is because it's using the outlet as the power supply. If you remove that, the battery is the power supply, and if the phone dies, there is no power from the battery.
    2010-12-08 09:54 AM