1. wolk72's Avatar
    It happened to me recently i just want to know why did my phone went to the restore mode after i removed back cover? I had 4.0 on iphone 4
    2010-12-27 12:42 AM
  2. Cowboy's Avatar
    Did you mess with anything else?
    2010-12-27 01:57 AM
  3. wolk72's Avatar
    I dont remember but i think I took off upper black shield, you know the one that protects all ribbons on top( lcd, digitizer, facing camera, power button and all that stuff). After that i took apart like 10 more iphones and all of them were fine ;/
    2010-12-27 03:23 AM
  4. Cowboy's Avatar
    Could of damaged a ribbon.
    2010-12-27 03:28 AM
  5. wolk72's Avatar
    Which one? but the phone works perfectly fine lol
    2010-12-27 03:32 AM
  6. Cowboy's Avatar
    Hmm idk you could of just slightly unplugged something for a second I don't know there are to many scenarios. Good thing is that u got it working
    2010-12-27 03:35 AM
  7. wolk72's Avatar
    maybe, but i dont think anything would happen if you unplugged something, like on 3g/3gs u can take it apart with power on lol
    2010-12-27 03:41 AM
  8. Cowboy's Avatar
    Not always a screen replacement alot of the times puts them in a restore mode.
    2010-12-27 03:42 AM
  9. iWieduwilt's Avatar
    maybe, but i dont think anything would happen if you unplugged something, like on 3g/3gs u can take it apart with power on lol
    Personally I would never break open the phone with the power on.

    It's not hard to damage the ribbons on a 3G/3GS but I've never taken apart my i4 so I wouldn't know the layout of it much.

    But, if it went into restore mode after taking off the back cover, then go back and see if any connectors aren't correctly plugged in, and if they are then just do a restore.
    2010-12-27 08:58 AM
LINK TO POST COPIED TO CLIPBOARD