1. markd.'s Avatar
    I currently just got the 4 and last night I went to erase all my data on my 3GS that's for sale. it is jailbroken/unlocked on 4.2.1 ipad baseband. I thought that in order to erase all of my data I had to restore it with the 4.2.1 firmware and re-jailbreak it. well I guess this wasn't the case. I guess I'm stuck in some kind of loop but I keep getting errors..I think their 1xxxsomething and 3xxxsomething. I can find out exactly if it makes a difference. does anybody have any idea what I should do? I tried putting the phone in dfu mode and then resorting but still no luck.

    second question is I still have to get personal data off of 2 other jailbroken/unlocked iPhones. what should I do so this doesn't happen again?

    thank you so much and I appreciate any help at all.
    2011-03-24 01:43 AM
  2. Simon's Avatar
    If 1015 is the error you are getting you can check my sig for help with that. Do you know what SHSH you have?
    2011-03-24 03:10 AM
  3. markd.'s Avatar
    i have 3.1.2, 3.1.3, 4.0, 4.01, 4.1 and 4.1.2. i found a solution online that got it to atleast work for the next owner. but id like to have it on 4.2.1 for him atleast. i got it to 4.0 following the directions below. i am wondering now, is there a way to get it back up to 4.2.1? thank so much for the help!

    I found a solution…. by accident! (for mac osx) My iphone 3gs on 4.2.1 with baseband 06.15.00 I got stuck in a loop after performing the above method (using redsn0w to update the baseband – old bootroom) and then trying to sync with itunes – stupid i know but Cydia and safari were not working and I’m quite new to this…. It was stuck on an endless loop between the apple screen and the connect to itunes screen. I could not get it into dfu mode or find the correct info…. Eventually I managed to get the 3gs in dfu mode…(for those who are as new to this as me – hold both buttons for ten seconds or so and then release the top button when the screen goes black – you can see that it is still on around the edges if you look carefully. You MUST do this whilst the iphone is connected but not with itunes running!) I then fired up redsn0w and used the 4.2.1 ipsw file…. then select pwned DFU mode and let redsn0w work its magic…. redsn0w will then tell you that it is done but the screen will still be black. Fire up itunes (my mac came up with 2 iphones- just eject one) and then it’s time to restore (making sure that you hold down the alt/option key on your mac as you click restore) You must then select and use the 4.0 ipws file (download this before starting and put it on your desktop) itunes will run its restore but then come up with an error code 1015….DON’T PANIC! What you must then do is disconnect your iphone, then close itunes and then put it in dfu mode again. Your iphone will show the same ‘connect to itunes’ screen – ignore this. Download and then fire up Tinyumbrella. Use it to disconnect…. your iphone will show the same screen as it does when updating with itunes… and then…. Magic…. It will work! Connect the iphone to itunes to activate it! It will now be on 4.0 with the ipad baseband
    2011-03-24 03:56 AM