User Tag List

  1. jmedillin's Avatar
    I replaced the charge port on an iphone 4 because the charge port was corroded. Installed new charge port and the charger is working and docking properly, however the microphone would not work. I can make calls while on speaker, but otherwise they cannot hear me. Pulled the charge connector out of another phone and tested and the phone works like it is supposed to. So i thought I must have got a defective dock connector (included microphone.) When the new dock connector came in I have the same results, microphone is not working. Any thoughts on this would be deeply appreciated. (note: i did use a static strap when handling the dock connector)
    2011-05-02 09:56 PM
  2. Stray's Avatar
    Did you try a restore? Sometimes that is needed.
    2011-05-02 10:37 PM
  3. jmedillin's Avatar
    I will try that and let you know. Thanks.
    2011-05-02 10:48 PM
  4. Stray's Avatar
    No problem. Hope it works out.
    2011-05-02 10:52 PM
  5. jmedillin's Avatar
    Well I did a restore and the microphone still does not work. Anyone have any ideas. They are sending me a new part, but I am not sure that is the solution...
    2011-05-03 01:21 AM
  6. Emicron's Avatar
    It sounds like you may have just gotten a defective unit.
    2011-05-03 07:29 AM
  7. randyg734's Avatar
    I have this same problem , no body just couldn't hear me one day ,but I can hear them , any help? I was thinking of ordering new doconector my self , with more parts what ever it takes to fix ,need help please
    2011-05-12 06:25 AM
  8. jmedillin's Avatar
    Ok so after getting 2 bad parts in I finally have fixed it. Installed my third dock connector and this time it worked. May be looking for a new supplier for this part. Any suggestions?
    2011-05-17 09:33 PM
LINK TO POST COPIED TO CLIPBOARD