1. sacrin007's Avatar
    So I changed a screen on an iPhone 4, as I was putting it back together I tore the Headphone Jack Power Volume ribbon. And even worse, I can't turn the phone on at all, not via battery or wall socket. What could I have done or where can I start to try to fix?
    2011-08-04 01:53 PM
  2. harmon's Avatar
    replace the flex you broke anyways...is very well the problem
    2011-08-04 02:11 PM
  3. sacrin007's Avatar
    I will, but that will take a while to get. Could that really be the cause for it not turning on at all?
    2011-08-04 02:13 PM
  4. delutedsoul's Avatar
    yes...
    2011-08-05 05:57 AM
  5. iYeow's Avatar
    yes...
    We appreciate you helping members on hardware issues , good job .
    2011-08-05 06:22 AM
  6. delutedsoul's Avatar
    well i try...i hope i help someone at least once or twice i know what its like to be looking for answers and not be able to find any
    Last edited by delutedsoul; 2011-08-05 at 07:15 AM.
    2011-08-05 06:52 AM
  7. sacrin007's Avatar
    Thanks thus far... I am overseas, so I will be waiting 3 weeks or so for the ribbon to arrive from China. Sucks to not have my phone for that long... no other suggestions for in the mean time at all???
    2011-08-05 09:00 AM
  8. delutedsoul's Avatar
    I would double check all connections on the phone. Make sure everything is good and tight. It's a simple step but it's important
    2011-08-05 04:19 PM
  9. sacrin007's Avatar
    I would double check all connections on the phone. Make sure everything is good and tight. It's a simple step but it's important
    Can you believe that actually worked? Undid and re-made all the connections and it worked! Minus the volume and vibrate buttons obviously - flex should be here in 2-3 weeks.

    Just noticed it wont ring or vibrate either, though there is sound when I put on music. Do I need a cydia app or something until I get my sound/silent buttons fixed?

    Installed Volume Buttons Disable, SBVolume, and MyVolume SBsettings from Cydia to get a volume control and silent button. I have system sound again but no vibrate. I think I will splurge on a $3 vibrate motor just in case it doesn't fix itself with the flex cable.
    Last edited by sacrin007; 2011-08-06 at 05:24 PM.
    2011-08-06 04:34 PM
  10. delutedsoul's Avatar
    It's such a simple step that you wouldn't think it would work. But it often helps....as far as the vibrator is concerned make sure the connectors and the connector pads are cleaned with ipa. Grease from your fingers can keep them from making a complete connection.
    2011-08-06 06:52 PM
  11. MasterfalcoJimmy's Avatar
    hey when you get the new flex installed and if it does not vibrate on silent toggle back and for from silent and my start working that happen to mine is like something needs to snap in the right place
    2011-08-07 07:31 AM
  12. sacrin007's Avatar
    So this is crazy - not sure if it is related or not. I can't write text messages! And not I can't send them... I can't even write a text message. I go to "messages" and the write button is unclickable. I try to select send text message from a contact, and it loads a blank screen with no text boxes. Anyone ever seen this before? Restore time?

    Edit: SBvolume was the culprit. Deleted it and installed SBsettings volume widget instead. Maybe this will help someone, somewhere, some day....
    Last edited by sacrin007; 2011-08-08 at 11:28 AM.
    2011-08-08 08:28 AM
  13. tomtom's Avatar
    the vibrator is on the headphone flex as well, so that's normal that it isn't working. try also to clean the vibrator ports on the new flex and on the vibrator when you change them again, because i allready had alot of issues with the vibrator and cleaning solved them all

    the text message problem is really strange... but i guess its not hardware related... it more seems to be some software error?!
    iPhone 4 16GB 4.2.1 / iPhone 3GS 32GB 4.0.1 / iPhone 3G 8GB 3.1.3 / iPhone 2G 16GB 1.1.4

    MacBook Air 11'6" / Hackintosh i7 Snow Leopard
    2011-08-12 01:44 PM
  14. unklbyl's Avatar
    ok, listen up.
    when you replaced the screw to the right of the camera assembly, there is a (VERY) small ring on the underside of the motherboard. if you tightened that screw too much, you broke the solder, and there is no connection to the motherboard there. this can and does keep parts of the digitizer from feeling your touch, and believe it or not, sometimes the shadow of your finger can actually activate a field. wierd, but true.
    this can be fixed with crazy glue, but you have to do it right so there is still a connection.
    I am in Germany overseas. where are you, and can i help you?
    i can help you if you want it.
    3 weeks for a ribbon assy does suck.
    unklbyl
    2011-09-07 10:58 PM
LINK TO POST COPIED TO CLIPBOARD