1. ipman4g's Avatar
    Hi i recently repaired my screen on my iphone4 now its having signal issues and its not connecting to the network. This all started after replacing the screen.
    2011-08-07 03:25 AM
  2. Cowboy's Avatar
    Did you make sure you connected the lower antenna and its on securely?
    2011-08-07 04:20 AM
  3. Mes's Avatar
    What about the small gold-colored ground pin on/near dock connector that touches the silver rim surrounding the screen?

    Oops.. I'm bad. That was for a 3G/3GS. Don't know the iPhone 4.
    2011-08-07 04:25 AM
  4. Cowboy's Avatar
    What about the small gold-colored ground pin on/near dock connector that touches the silver rim surrounding the screen?

    Oops.. I'm bad. That was for a 3G/3GS. Don't know the iPhone 4.
    The iPhone 4 one is on top of the logic board towards the very top screw in the top middle of the phone but my guess is that it's more than likely the antenna wire that runs along the dock to the lower part of the logic board by the battery isn't connected well
    2011-08-07 04:29 AM
  5. ipman4g's Avatar
    thanks for the advice guys ill try this when i get the phone monday from my buddie ill take pics if what you guys said doesnt fix the phone
    2011-08-07 04:54 AM
  6. Cowboy's Avatar
    SOunds good i subscribed to the thread so i will get emailed when you post an update
    2011-08-07 04:58 AM
  7. ipman4g's Avatar
    thanks cowboy i appreciate that
    2011-08-07 05:03 AM
  8. Cowboy's Avatar
    np
    2011-08-07 05:05 AM
  9. MasterfalcoJimmy's Avatar
    or it could be that he put the wrong screw in the wrong place i think one of the screw is suppose to touch the metal frame for signal
    2011-08-07 07:20 AM
  10. ipman4g's Avatar
    ok i got the phone i guess when they replaceed screen they didnt put it on right cause the front a is a little wobbley anything i should look for before i open this

    also wifi works fine
    Last edited by ipman4g; 2011-08-07 at 08:21 PM.
    2011-08-07 08:17 PM
  11. Cowboy's Avatar
    I would make sure all screws are in the right place the antenna is connected and the prong on the top of the logic board is their
    2011-08-07 08:25 PM
  12. ipman4g's Avatar
    woiuld this issuse affect the phone from reading the sim card it keep saying no sim card installed (jailbreaked it for use with tmobile maybe i cut sim wrong ?
    2011-08-07 09:12 PM
  13. Cowboy's Avatar
    possibly
    2011-08-07 09:28 PM
  14. ipman4g's Avatar
    any guides on how to take it apart specificly and is the iphone 4 compatible with the sim from the monthly 4g pre pay plan from tmobile ?
    2011-08-07 09:34 PM
  15. Cowboy's Avatar
    Yes and their is a take apart guide in the guide section or on the front page made by me
    2011-08-07 09:39 PM
  16. ipman4g's Avatar
    thanks cowbow do you know were i can find the print out for cutting the tmobile sim ?
    2011-08-07 09:42 PM
  17. Cowboy's Avatar
    Umm not sure honestly Google lol
    2011-08-07 10:09 PM
  18. ipman4g's Avatar
    thinking its probably missing a screw cause i can almost take the front screen off without taking any screws out lol
    2011-08-07 10:39 PM
  19. Cowboy's Avatar
    bounds like your mission a bunch then
    2011-08-07 10:44 PM
  20. ipman4g's Avatar
    waiting on my camera to charge before i take it apart but i just noticed there light comming out the sides and around the rim of the screen while its on when i take it apart i know make sure its off should i completely dissemble it ?
    2011-08-07 11:57 PM
26 12
LINK TO POST COPIED TO CLIPBOARD