1. Nopstnz8's Avatar
    Hey guys... About two months ago I got water inside my dock connector while installing an Invisible Shield. I was quickly able to salvage my phone since I immediately opened it up and dried out what had gotten wet, in this case, really only the dock connector. I took that out of the phone and left the phone powered off for a day to dry everything out. Since then I've been using my phone, but every time I connect it to my iPod adapter in the car, I get the accessory not supported message, which I just dismiss and go about my business since it doesn't affect anything. My main problem is cell reception. I am getting 3g connectivity, but have noticed ever since the water incident, I am getting much worse reception, like one bar on 3g in a lot of places, and even getting forced to edge every now and then. Also, even when I have like 2-5 bars, I've noticed anything that uses data is much slower than before. Like Facebook or Cydia take twice as long to load. I've replaced the dock connector assembly twice, and both replacements gave much worse reception to the point where I couldn't even call people from inside the building. I ended up switching back to the OEM dock, which has given me the best results, but still is lagging and has the accessory not supported message. I tried with all the assemblies reseating them until I got proper signal, but the OEM one won't get any better than it is now no matter what I do.

    Anyways, the replacements I used that ended up being worse were from Gadget Fix on Ebay, who has always sold high quality parts, as well as SW-Box. What I'm mainly looking for is a high quality replacement that will get my phone back to normal. Someone has to sell one because I don't see how people can use their phones after this part gets damaged otherwise?

    Any help would be appreciated. Thanks.
    2011-08-27 05:50 AM
  2. Falcon70's Avatar
    I've had this problem also from two vendors and eventually got some GS docks from Brad at Emicron. (Google it.) The previous vendors' docks were very poor quality. A few things to keep in mind... (1) make sure antenna connector is seated properly and (2) make sure that the gold "prong" on the bottom right of the dock antenna flex and the gold "prong" on the mobo are making contact with the bezel. All three connections need to work in sync to deliver a strong signal.
    2011-08-27 12:01 PM
  3. Nopstnz8's Avatar
    Alright, I'll give him a try. Thanks.
    2011-08-27 10:08 PM
  4. Nopstnz8's Avatar
    Ok purchased it. Will let you know how it turns out.
    2011-08-27 11:57 PM
LINK TO POST COPIED TO CLIPBOARD