1. bumpcity76's Avatar
    My wife's 8GB iPhone 3G has a possessed home button. It has mostly quit working, but at times seems like it 'queues up' all of the previous home button presses and just unloads them several minutes later. I tried a factory restore and followed that up with a restore from backup, but it still isn't working properly. i cleaned the contacts on the motherboard and tried a spare home button, to no avail. The funny thing is, I can easily put it into DFU mode, so I know the home button is functional. Any thoughts?

    Thanks much,
    Kris
    2011-09-28 03:16 PM
  2. Mes's Avatar
    If the Home button acts erratically after a fresh restore, a hardware problem exists. From what you've done, the problem appears to be more serious than intermittent contact. I would carefully check the cable, pins and contact points and replace the whole assembly encasing the home button.
    2011-09-28 04:26 PM
  3. 805 93003's Avatar
    This is not a Home Button Flex problem, you have proven the Home Button itself works fine. You swapped Home Buttons and this did not fix. You entered DFU showing Home Button works. This is not a Software problem, you Restored Firmware resulting in no change. This is Logic Board problem or Dock Connector with Flex Cable #4 problem.
    Last edited by 805 93003; 2011-09-28 at 06:31 PM.
    2011-09-28 06:28 PM
  4. bumpcity76's Avatar
    Interestingly enough, the problem was fixed by jailbreaking the phone. My wife was never interested in jailbreaking her phone, but I decided to do it to try Activator as a workaround. I used redsn0w, installed Cydia, and rebooted. Magically, the home button works again. Imagine that...
    2011-09-29 04:16 AM
  5. Mes's Avatar
    Hey thanks !! Jailbreaking doesn't harm the phone, it helps
    2011-09-29 04:40 AM
  6. bumpcity76's Avatar
    Yep, I'm certainly no opponent of jailbreaking. My wife just had no interest and I didn't feel like having to support her device. She's not too tech savvy.
    2011-09-29 04:46 AM
LINK TO POST COPIED TO CLIPBOARD