1. Goof's Avatar
    So recently I updated my iPhone 3GS, it was made is '09 according to the serial, to iOS 5.0.1. I didn't like it so I used a custom firmware made with Pwnagetool to downgrade my iPhone to iOS 4.3.3 (it has 6.15.00 baseband). After the downgrade, my phone just got stuck in a DFU mode loop, I managed to pop it out of DFU mode using redsn0w's "Just Boot" feature, so I just assumed that my iPhone was forever in a tethered mode. I was able to live with it.

    By the way, I did try to restore it with no luck, I kept getting the 1600s errors, so I just gave up.

    Then the other day, I went to sleep and I forgot to set my phone to charge, and the battery died, when I woke up, my phone was in DFU mode like I assumed it would be, but now whenever I tried to kick it out using the "Just Boot" feature in redsn0w, it would just put it on a white screen and after about 2 minutes of a white screen it would just go back into DFU mode, I've tried all of the recovery fixes and stuff but they didn't work.

    After a while of playing around, I read that to fix it you just need to take apart the iPhone and separate the Logic Board and the Battery, and it should accept any restore I throw at it. So I did, I took it apart and re-assembled it, I tried a restore, but still with no luck the restore failed, but the "Just Boot" feature worked and my phone got started up and stuff, I can use it. I noticed though after a while the phone just reboots and get stuck back in DFU mode, and I have to take it apart and then boot it up again using the "Just Boot" feature, if I don't take it apart it will go back to the white screen.

    I'm assuming that it a hardware problem, I am just want to know what piece of the iPhone I need to replace.

    Thanks for any help.
    Arthur "Goof"
    [email protected]

    RIP Steve Jobs.
    2012-03-07 01:56 AM