User Tag List

  1. Niners14's Avatar
    Hi every one on modmyi I have a problem that requires a quick fix. I replaced the screen on a att iphone 4 and the screen response to touch but on the left side of the screen from top to bottom it doesn't respond to touch I can't slide the bottom bar before the passcode screen and the top bar to turn off phone. It hasn't been updated to ios7 yet could that be the problem? Every thing else works fine also the screen before passcode where it shows the time has a layer under the time with the wrong time and another time over it. Any tips on how to repair this issue I have tried 2 other screens in case it was a defective screen and all three screens do the same.
    2013-10-07 09:07 AM
  2. iRevival's Avatar
    Sounds like a bad digitizer or connection to me but since you've tried others it is probably the port on the board. Also, the fact you're getting a time glitch could be from a software issue. Try restoring to see if it solves the problems.
    Twitter: @irevivalrepairs | Instagram: @irevivalrepairs

    iPhone 4/4S Frame Swappers:
    Don't forget about that sim tray lever!
    iPhone 5 Frame Swappers:
    Don't forget about those screen clips!
    2013-10-14 08:04 AM
  3. Niners14's Avatar
    Turned out to be a background pic and the time was captured when the owner took a screen shot (I'm embarrassed now hahaha). Still on the screen a little to the right starting from the left is not recognizing touch but it started to come back little by little. I updated it to ios7 after getting the ok from the owner and still the same
    2013-10-14 08:49 AM
  4. Moneymikey's Avatar
    Try doing a hard reset. Hold both buttons down till it turns off and then turns back on.
    2013-10-25 02:31 AM
  5. Niners14's Avatar
    I tried that and nothing I believe some thing on the mother board was damaged when it was dropped

    Because it wasn't fully responsive before I replaced the screen
    2013-10-26 08:23 AM
  6. PURE XTC's Avatar
    hey guys, did a screen replacement twice. was very careful both times and the results were the same. the screen only has a slight flicker that can barely be seen and it wont show anything. both screens the same. i can't figure out what went wrong! Please help!
    2013-11-03 04:56 AM