1. mjpatera's Avatar
    I have an iPhone 4s, not sure of the iOS version. It's stuck in DFU mode and when I try to restore it keeps getting Error 21. I have tried on 3 different computers and it gets the same error. It think its a problem with power getting from the battery to the control board. The phone wont power up unless its plugged in, then it comes up with the cord plugged to iTunes screen. When I go to restore, everything acts normal, then when it gets to the part where it "prepares the phone" and restarts the phone, it loses connection and gets the error. I did notice that the serial # in iTunes shows n/a, but that may be normal when it's in DFU mode. The battery has already been replaced with a known good battery.

    My question is, is there a separate power board that is between the battery and main circuit board that can be replaced? If not does anyone have any other ideas or suggestions?

    Thanks in advance
    Mark
    2013-11-24 08:20 PM
  2. DC_Dave's Avatar
    Hi, I think if it wont say on onless its plugged in and you have already fitted a good battery, check for corrosion on your 30pin dock, if dirty, gently clean or replace would be your next easiest option.
    2013-11-25 02:05 PM
LINK TO POST COPIED TO CLIPBOARD