User Tag List

  1. drpixel404's Avatar
    Hi all...

    I have just used iLibertyX to jailbreak/unlock my iPhone. After the unlock did not work (my AT&T SIM was still in, but I could not make/receive calls, texts, use EDGE, etc.). So I tried to unlock again. Just a note, I am on firmware 1.1.4, and i have the 4.6 bootloader. So I figured I can restore my iPhone and try again. But iTunes won't let me restore. So I put it in DFU mode, and iTunes threw up an error "The iPhone 'iPhone' could not be restore. An unknown error occured (2005)." PLEASE HELP! I NEED MY PHONE FOR THE NEXT WEEK UNTIL THE NEW ONE IS RELEASED!

    UPDATE: Never mind; I plugged it into another Mac and did the restore from there... AND IT WORKED!
    Last edited by drpixel404; 2008-07-05 at 02:38 AM. Reason: Automerged Doublepost
    2008-07-05 02:38 AM
  2. ellokko1128's Avatar
    i have the same problem as stated above. but i do not have another mac where i can restore my phone...need help asap...also before the problem started i didnt even have service. AT&T....Help please HELP!!!!!!!!!!!!!!!!!!!!!!!
    2008-07-06 11:03 PM
  3. hoogoo's Avatar
    Simply change your cable from hub to main/main to hub. Solved!

    source: [ame=]Error 2005 - FIXED - iFans - iPad, iPhone, and iPod touch Fans forums[/ame]
    2011-01-16 08:18 AM
  4. xiamxu's Avatar
    Hey man how do you change cable from hub to main? Is that only for mac.
    Iam on windows 7, I updated my usb device to its latest version, I reinstalled itunes, restarted the computer and tried very one of my usb ports, still gives me 2005 error. Please help
    2011-11-06 04:55 PM
  5. Kova's Avatar
    Here is solution to:
    3194 - start and stop TU should solve this one
    1600 - this one could be related to firewalls as well, so close all
    2005 - this one could be ralted to USB port so switch USB port, its also related to hosts, TU should solve this one.
    11 - this one, was solved with new custom 5.01, and downloading all SHSH and steps 2 - 4

    All that I got while trying to do 4.3.3 to 5.01

    Step by step how to avoid all at once, maybe some steps are not needed but I'm sure it will work like this:

    1. I went to DFU mode run redsn0w then made Custom from 5.01 ! I got No_BB one.
    2. Host thing got confusing to me, should I put # or not, so I started latest TU (Tiny Umbrella) and checked Save ALL Available SHSH in Advanced, Started TSS Server and stoped it. I checked SHSHs and found 5.01 there, I selected it doesn't know if that is important or not.
    3. I started TU again, START TSS Server and close TU
    3. ireb r4 pwned DFU
    4. Itunes and restore with Shift.

    Worked, all errors avoided.
    2012-01-02 01:03 AM
  6. iChild's Avatar
    Hello, I still cannot get rid of error 2005. Does anyone know how to change USB from main to hub or hub to main?
    2012-01-13 06:36 PM
  7. markoobradovic1's Avatar
    iHave the saame problem! But I noticed that when I start TU it don't see my iPhone 4 on right way but see as invalide device... iCan not save my SHSHs for iPhone 4. iTry with redsnow. It see my iPhone and say that my phone is iPhone 4, fw 4.3.4 and can not save SHSH to cydia :/ do somebody have solution for my problem?
    2012-01-30 08:35 PM
  8. nick3232's Avatar
    wrong thread
    Last edited by nick3232; 2012-04-27 at 06:56 PM. Reason: wrong thread
    2012-04-27 06:50 PM
  9. ieatrusherz's Avatar
    im having this problem to i jailbroke with absinthe and with redsn0w accedently but now i cant boot my iphone its an iphone 4 running 5.1.1 and ive been at this trying to get it to work for like 5 hours now and dont know what to do can someone plzzzzzzzzzzzzzzzzzzz help me im so confused i dont know what to do i keep getting the 2005 error and tryed even usb port in my computer and have tu running while trying to update but its still not working someone plzz help me
    2012-06-01 02:00 AM
  10. u170who's Avatar
    Hi Everyone, i was stumped with this one until i read this post. I used redsn0w 9.14b2 to enter dfu mode without the use of a power button, then used sn0wbreeze v2.7.3 to create a custom ipsw, then tried to restore to the custom ipsw with itunes, but it error out of itunes saying it was unable to restore. After that, i couldn't do anything, so i tried to use redsn0w and tinyumbrella to repair, and go the 2005 error. I read this post, then changed the usb port, and press and held the power and home buttons for a few seconds until the pc made the finding a new device sound. Then, i restored to the original Ipsw with itunes (not the jailbroken version) FINALLY, i got it working. its not jailbroken but at least it works.
    2012-07-13 05:38 AM