1. cowjames's Avatar
    After I installed the installer fix 3.1 - I have been unable to open many apps including Five Dice, Lights Off, Super Pong.

    Also i can no longer ssh into my ipod.

    Has anyone else installed this and has any problems?

    I have a 16gb Ipod Touch (ziphone)

    Thanks.
    2008-05-19 11:40 AM
  2. cowjames's Avatar
    no one?!
    2008-05-20 11:25 PM
  3. zsuns's Avatar
    Not me, i installed it, and the only problem i have had was installer permissions...
    A Thanks is always nice =]
    2008-05-21 07:26 AM
  4. guarroman's Avatar
    cowjames, you are not alone
    I'm experiencing the same problems you have.

    Try vt-100, if you have this message:

    dyld: Library not loaded: libarmfp.dylib
    Reference from: /bin/sh
    Reason: image not found
    [Process completed]

    Then we have the same problem

    I did not know what was the cause, I was suspicios about:
    -installer 3.11 that crash during install
    -iSlsk
    -installer fix 3.1

    But now I think the problem is related to installer fix 3.1

    Please post something here if you find the solution

    I have another post with the same topic in spanish here:


    Problema con vt100, SSH, WinSCP y varias cosas más - iPod touch Fans forum

    So you have problems with

    - Lights off (I have installed this and doesn't work for me also)
    - Five dice
    - Super pong

    And we have in common:

    -SSH

    But the list of apps that doesn't work continues:

    - iPac3d
    - Yeti3d
    - Shoplist
    - vNotes
    - Pocketmoney
    - Geopedia
    - Vt-100 (error commented above)


    What have in common all these apps?????
    Last edited by guarroman; 2008-05-21 at 12:54 PM. Reason: Automerged Doublepost
    2008-05-21 12:54 PM
  5. cowjames's Avatar
    Hello,

    I did not have any of your apps so I installed Yeti3D and that did not work either.

    Im sure it is the fault of the Installer Fix.


    Try vt-100, if you have this message:

    dyld: Library not loaded: libarmfp.dylib
    Reference from: /bin/sh
    Reason: image not found
    [Process completed]
    Sorry i dont understand this! If its to do with ssh i use cuteftp and it says somthing about error #4?!

    Also i do not speak Spanish.

    Thanks.
    2008-05-21 02:12 PM
  6. guarroman's Avatar
    something more...

    http://hackint0sh.org/forum/showthre...=40327&page=12

    Here they explain how to do something


    1) Install PureFTPD
    2) Install BossPrefs
    3) Install BossPrefs PureFTP Control
    4) Set auto-lock to NEVER
    5) Open BossPrefs, enable wifi, enable PureFTP
    6) STAY IN THIS SCREEN!!!
    7) Open FTP application (FlashFXP for instance), login with iPhone ip adress (user=root, pass=alpine)
    8) Rename or remove /usr/lib/libarmfp.dylib
    9) Copy old libarmfp.dylib to /usr/lib

    ok for me until 8)
    but when I use the ftp client I only symbolic links to libraries that I don't see (among them the famous libarmfp.dylib)

    what I have done from 7) is
    8) rename symbolic link /usr/lib/libarmfp.dylib and copy inside that folder the library libarmfp.dylib that I have founf here:
    http://apps.iphonexe.com/24940.zip

    now vt-100 and ssh ara ok, and all the apps that fail before

    but I can't install the installer 3.11 yet

    finally I can ise SSH so...

    I have done this ( is expected what iclarified patch does):

    rm -R /var/mobile/Library/Caches/Installer
    rm -R /var/mobile/Library/Installer/Temp
    chmod -R 755 Installer.app
    chown -R root:admin Installer.app
    chmod 6755 /Applications/Installer.app/Installer


    And now installer is on 3.11
    Last edited by guarroman; 2008-05-21 at 02:52 PM. Reason: Automerged Doublepost
    2008-05-21 02:52 PM
  7. cowjames's Avatar
    Ok thanks,

    Im trying your guide but having a few problems.

    I could only find the shortcut folder for 'libarmfp.dylib' so i rename it like you said, but it didn't seem to change much.

    So then i went to put the downloaded file 'libarmfp.dylib' into that folder; And I was asked if i wanted to over rite the file? I wasn't sure so i didn't.

    Are these the right steps?

    Ive attatched two pictures to give you a better idea.

    Thanks in advance.

    (Also the link to the hackingtosh forum doesn't work)
    Last edited by cowjames; 2008-05-22 at 11:09 AM.
    2008-05-21 03:32 PM
  8. guarroman's Avatar
    Well, the fact is that I put the library in /usr/lib
    I didn't delete the libarmfp.dylib link, simply I renamed it to libarmfp.dylib2


    Last edited by guarroman; 2008-05-22 at 09:31 AM. Reason: Automerged Doublepost
    2008-05-22 09:18 AM
  9. cowjames's Avatar
    Thanks! Ive fixed it now... do you think this will have any future effect on how my ipod works with anyother apps?!

    Also can iun uninstal the apps we had to install to fix the problem?!

    Thanks again!
    Last edited by cowjames; 2008-05-22 at 11:36 AM.
    2008-05-22 11:33 AM
  10. guarroman's Avatar
    I don't know the effecta that this could have in the future....

    I'm not an expert and I don't know too well the structure of iphone files...
    But anyway, it works...

    I'm having problems now with only one app: Phonezap

    But the rest are working ok...

    You can uninstall pureftp, bossprefs... etc...
    2008-05-22 01:36 PM
  11. cowjames's Avatar
    Ok,
    I havnt experienced any problems with any apps yet.
    But why i instal anything and go back to the sprinboard i do now get a black screen for a second saying "setting language" that i never used to get. I think it came from after installing boss prefs (even though thats uninstalled now)
    2008-05-22 06:16 PM
  12. guarroman's Avatar
    Maybe the "setting language" screen is a feature of Installer 3.11, I'm not sure.
    2008-05-23 09:57 AM
  13. aniel1's Avatar
    after installing new installer, it is not refreshing the sources. any solutions pls.
    2008-05-23 10:24 AM
  14. niketkumar's Avatar
    me too having same problem , installer crashes on starting
    2008-05-23 07:16 PM
  15. cowjames's Avatar
    Hmm i didn't have any problem with installer afterwards - sorry.
    2008-05-24 12:48 PM
  16. littleboy683's Avatar
    dont install this it messes up your iphone or ipod theres a thread about it on ipodtouchfans.com. It messes up your wifi and your bsdsubsystem. You should also delte the source iclarified
    2008-05-24 04:58 PM
  17. Spliffaliciou's Avatar
    dont install this it messes up your iphone or ipod theres a thread about it on ipodtouchfans.com. It messes up your wifi and your bsdsubsystem. You should also delte the source iclarified
    can anyone confirm this?... I'm finally getting around to figuring out my installer issue... seems this could be it. Could use some support for the fix...
    anyone?
    2008-05-24 05:34 PM
  18. cowjames's Avatar
    Yeah dont instal it!
    Does anyone know if there is an 'official' fix for the problem this installer fix causes?!
    2008-05-26 01:17 PM
  19. aamodr's Avatar
    what is this 'setting language' business i keep getting everytime i install something?
    2008-06-04 02:25 AM
  20. cowjames's Avatar
    i also get that - i have no idea where its come from (little annoying) - but my ipods been working fine.
    2008-06-04 02:36 PM
21 12
LINK TO POST COPIED TO CLIPBOARD