1. Darkkaumi's Avatar
    This is a great tool but my problem is a bit different. I'm out of DISK space. When I load iTunes I cant add anything becasue its full, but I dont have any music or video on it. I just revirginized my phone and upgraded to 1.1.1. I dont know what files to delete and what files not. I thnk I need a tool like the one for 1.1.3 that cleans up after the soft upgrade but they dont have one for 1.1.1 Please help!

    2008-01-30 11:54 PM
  2. IreneNs's Avatar
    my problem is that i try to open installer and it did not show at the same moment it closed, i dont know how fix it and the problem starts when I uploaded the installer. i have iphone 1.1.2 and I never could install nothing. if somebody know how fix this problem please I really need help.

    Thank you
    2008-01-31 12:44 PM
  3. iPhone420's Avatar
    I used Installer App Fix when BossTool failed for me and I had to downgrade my phone and then reupgrade I found it while searching on google cause nothing on here had it.
    2008-02-02 04:41 AM
  4. Jeaz's Avatar
    I gave up and did a complete reset and now it's working properly again.
    2008-02-02 04:51 PM
  5. VJ1111's Avatar
    Thank you so much!

    It worked fine ...well at the beginning i had to uninstall some stuff to get it in and when i runned any of the "movers" it didn't worked ...it just showed a load-clock for one or two secs and wiped out ...nothing changed ...so i runned into Installer.app, uninstalled some more stuff, re-installed BSD Subsystem, went again to BossTool.app and it worked.

    Now i have a question ...what happens if i delete the original /Applications folder? (and ringtones as well)

    EDIT: I almost forgot ...i also re-installed the BSD Subsystem 2.0 Termfix
    Last edited by VJ1111; 2008-02-17 at 03:08 AM.
    2008-02-17 03:01 AM
  6. hgill's Avatar
    Hi Bigboss,
    i am new and have 1.1.2otb 48 week iphone.what i did like this:

    1. first downgrade to 1.1.1

    2.then jailbroken and then upgraded to 1.1.2 with soft key try to unlock did,t work.

    3.then i downloded zibri Zphone 5.0 and did activation,jailbroken and unlock in one shot very easy and i got UNLOCKED IPHONE with every thing working on it,tjhen i install 3 apps 1 fish game does't work though 2.call id 3. voice dial.

    But now i can,t see the INSTALLER atall, i am not able to delete any of those applications,PLEASE HELP how i can get the INSTALLER BACK.Much appreciated.
    2008-02-17 04:07 AM
  7. yoyomomo's Avatar
    im not very good at these tech stuff so i really need your help.
    i have otb 1.1.2 running with installer 3...lately ive been trying to download some new apps but everytime i go about, it says it cant find the host? whats wrong...is it something to do with the BSD subsystem thing?
    i also see that the new installer has the "add to queue" function... was is that?
    2008-02-19 06:09 AM
  8. covington5000's Avatar
    I have tried removing apps and installer still will not open. Do you have any other suggestions. I have a jailbroken 1.1.3. I used Ziphone to jailbreak. I have been using scpwin to add to springboard and remove apps. Installer opens for a second then shuts down.
    2008-03-19 01:45 AM
  9. Krivo666's Avatar
    I used BossTool...it worked for wallpapers and ringtones, but after relocating applications..I can see only half my apps...SSHed to my iPhone...all are there in var/Applications, but not in /Applications...
    i have the same problem ... can you help me please ???
    2008-03-29 12:12 AM
  10. Hutt90's Avatar
    I moved my fonts fine, and when I went to move my apps it only moved some. I re-moved my apps again and it moved everything. I restarted my phone and all of my apps are not being shown on the springboard. I know I still have them because ANTS is activated and now I can't turn it off since none of my icons (in categories) are showing.

    What do I do?

    2008-03-31 12:15 AM
  11. clay's Avatar
    Boss - my problem is that I tried to install bosstool via installer but I get the error "package download failed" (I get this message on everything I try to install). The sources all update properly. My iphone is jailbroken and unlocked via ziphone and is 1.1.4. All the core apps work fine. I just can't install anything else. I'm afraid to uninstall installer and try re-installing it because it might give me the same error. Have you seen this problem and know how to fix it? Thanks Clay.
    2008-03-31 04:59 PM
  12. Marius15BC's Avatar
    Hi, I've followed your instructions above on the bosstool. After I moved the apps, I notice I wasn't able to use any of the applications. So I decided to reboot my phone and now I can't even get my phone to turn on. Please help.
    2008-04-09 03:05 AM
  13. addybgrilla's Avatar
    I have the same problem now, used bosstool due to installer saying not enough free space, now i have the spinning wheel of death

    Not good, wish I would have just uninstalled some apps now rather than using bosstool, I suppose I will have to do a restore now unless anyone has a way out of this? I'm on 1.1.4 if that helps

    Any help would be great to save my semi-bricked phone
    2008-05-16 03:38 PM
  14. msb2008's Avatar
    There are numerous threads now with people having problems with installer. The most common cause of the problem is that people have used up all the disk space. Most people don't realize that the iPhone has two hard disk partitions. So deleting music, having 7gb free for music has nothing to do with how much disk space you have to install applications.

    To help solve this issue, I have stripped the undeveloped features from BossTool and sent v0.34 off to MMi to host. This tool will allow you to move your Applications, Ringtones, and Wallpaper from the smaller disk to the bigger disk partition. There should be *no* ill side effects from this move. Everything will work the same before and after assuming all went well. The tool also make sure your fstab has noexec properly removed from the larger partition so the move of applications will work. Many of the manual methods posted leave out this crucial step.

    I have also removed a lot of the dependency files in the app to make it as small as possible. It now requires only a few kb so hopefully you can free up enough disk space to install it if you are already in trouble.

    I suggest everyone, especially 1.1.1 and 1.1.2 users moves their applications before they run into problems. A clean 1.1.1 install only gives about 50mb for apps. 1.0.2 gave about 130mb. So there is not much free space.

    To use bosstool, just load the app, go the the disk space screen, and you can see your free space on both partitions. The tool currently does not check that the larger partition has enough free space. Make sure you have at least 100 mb free on the big partition before moving apps! If not, you can delete some music, photos etc to get there. Now, before you move apps, move something like wallpaper or ringtones first. Make sure that the free disk space increased. If it did not, don't move apps. Something is not working on your phone. If it did, (which it should for everyone), then move the applications next.

    It is always a good idea to have open SSH installed prior to doing anything like this. That way if anything goes wrong you have a way into your phone to fix it without having to restore. This app does move system files. In doing this, there is always a risk that something can go wrong. So be prepared.

    If you are already into a situation where you cannot install anything without installer crashing (just going to springboard without completing install), then you probably need to free disk space before you can even install bosstool and fix the problem. If installer will load, load it and uninstall a few things. Install bosstool, move the apps, then reinstall the things you uninstalled back on afterwards.

    If you are totally out of disk space and installer won't even load to uninstall stuff, you may need to manually delete something. If you have openssh, termvt100, or mobile finder installed, you can do this. Just remote in or load finder, and wipe out your most unused third party app in /Applications. You can uninstall or reinstall it later after you solve the problem. After this, installer should be healthy enough to refresh sources and allow you to uninstall some stuff. Uninstall a couple things to be safe then install bosstool and move your applications.

    If you have any questions or concerns feel free to contact me. Remember, I only do this to help you people. If you're worried that the tool will mess up your phone or plan to send me hate mail over it, just move on..

    Common questions:
    1) After doing this, will I need to redo it for future apps? No. It is a one-time deal. Once this is done you never need to do it again. All future apps install to the new location.

    2) I freed disk space but I still have only 50mb free. Why not 300mb? This is because the operating system requires disk space, too. That extra space is being used by the OS that runs your phone.

    3) Is this method compatible with application {insert app name here}? Yes, this is an OS level change. All applications are accessed from /Applications. The path /Applications still works and no application will even know its been changed.

    4) I want to undo the move, what do I do? I don't recommend undoing the change. I do this move to all my phones when I first set them up even before installing apps. But if you do anyway, here you go. SSH into the phone, remove /Applications and then move /var/Applications back to /. Here are the commands:
    rm -f /Applications
    cp -r /var/Applications /Applications
    rm -rf /var/Applications
    Remember you will need BSD subsystem installed for this to work *and* enough free space on your hard drive to hold the apps.

    Just jused it on 1.1.3 iphone 16gb and it worked like a charm. it took only 5 minutes and now every thing is fine. i had only 10mb/300mb free space but now i have 10gb. i recommned this for everyone.
    2008-05-22 08:30 PM
  15. Ikemann888's Avatar
    Thanks a lot BigBoss.

    I used Bosstool v0.35 to relocate Fonts & Ringtone successfully on my iPhone 1.1.4 16GB (acitvate, unlock & jailbreak with ZiPhone 3.0 GUI) and got a free space of 104 MB on the 300 MB partition.

    But Bosstool not be able to relocate my Application, any advice?
    2008-07-03 06:43 AM
  16. Classik777's Avatar
    help plz...i upgraded my iphone from 1.1.3 to 1.1.4 and it erased my ziphone installer app thing...so now my phone looks stock....but in the syce other is 500mb of stuff i cant erase so i unstall the ziphone app again and im good but all the apps i had dont show up
    and are not in the uninstall list........how do i delete them etc...

    thank for any help
    2008-07-17 10:44 AM
  17. hatriq's Avatar
    When I try to download boss tool from cydia it says it can't because of a non comply. I have a iPhone 3G unlocked and jailbroken at 4.21
    2011-05-16 03:17 AM
  18. Rasmussener's Avatar
    You know what guys, I spent a week with my installer had problems until I got to this page. I came by the user "boss" to save space and Sisk have plenty of space to download applications. I downloaded "BOSS tool. Thanks soooo much to big boss theough there to guide me. This program is not to believe that it is amazing if you download tons of more stuff.
    2012-04-10 09:10 AM
  19. Rhy84's Avatar
    Is it compatible with ios 5.1.1?
    2012-08-26 03:17 PM
  20. H4CK3R's Avatar
    Is it compatible with ios 5.1.1?
    Unfortunately, no. It requires iOS 3.0 or lower, it hasn't been updated in ages.
    2012-08-26 04:40 PM
43 123