1. Pupkus's Avatar
    Pau: You're welcome.

    Kanies: I have a couple of questions and suggestions:

    1) Where did you have your iPhone jailbroken & unlocked?
    2) What is the firmware version? Is it 1.1.1 or 1.1.2? You will see it when you connect it to iTunes when you click on your iPhone under devices.
    3) Try to get a program for windows that will allow you to access the iPhone. You can use something like CuteFTP:

    http://www.globalscape.com/downloads/cuteftp.aspx

    I'm not sure how comfortable you are in using. It is a program that will give you access to your iPhone kind of like a USB key or a hard-drive that you plug into your computer. You will also need to have a wireless internet (router) connection at home.

    I'll wait for your answer on this to know how to further answer you back.

    If you are really not comfortable with it, see if anyone you know with an iPhone has copied files into it. If so, then just give them the link to the file I posted and have them replace it on your iPhone.

    It is the only way to get your installer up and running again (there may be other ways but they risk to be more complicated involving you to re-jailbreak your phone and other stuff....)
    2008-01-23 06:44 AM
  2. meagain's Avatar
    This is a disaster for me. I had a BAD feeling about updating Installer. Put it off for a bit. Then I thought "It's installer, it should be trustable". Nope. My phone is screwed.

    I installed it. When I tap on Installer icon, a blank page starts to come up then the springboard icons fly back in and I'm back on my home screen.

    I can't install/uninstall anything. My phone is 100% dead in the water. I've no clue how to fix it. The most I know how to do with the phone is Jailbreak, use installer, add sources. No clue how to move files, etc. into the phone.

    Is there any site that explains how to fix this in lay terms? I have 1.1.2 working with a mac.
    2008-01-23 06:59 AM
  3. Kanies's Avatar
    pupkus i had my iphone unlocked specially done dont know where ... my phone tho is not locked its all in working order but its 1.1.3 big boss worked perfect but nullriver screwed me like many others but i have downloaded that cuteftp so help would be a blessing please matey ....my iphone without installer sux plz help Kanies
    2008-01-23 12:24 PM
  4. meagain's Avatar
    I have the Installer file on my mac (I think), but cannot figure out how to get it from my Mac into the iPhone.

    Does ANYone know of any site/guide/tutorial on how to do this that's written for a newbie? I can't find anything with FULL instructions. Thanks.

    Lisa
    2008-01-23 06:02 PM
  5. Pupkus's Avatar
    Kanies & Meagain:

    Meagain: For Mac, I did a quick search on Youtube and found a kid that does a decent job showing you exactly how to get into your iPhone using Cyberduck. ( [ame="http://www.youtube.com/watch?v=-TUByq9HTbs"]YouTube - How To SSH File-Share On Your Iphone/ iPod Touch (mac)[/ame] ) Follow his instructions until you manage to see the files on your iPhone. From there, open Finder on your Mac and simply drag the (uncompressed) file you got from my site and drag it over the "/Applications" folder so that it replaces the installer folder in it. You will get a prompt asking you to replace, just say Yes. If you don't get a prompt, then you may have dragged it somewhere else by mistake. Give it a shot and let me know.

    Kanies: Here is another video from youtube ( [ame="http://www.youtube.com/watch?v=tqSCRUpeD_Y"]YouTube - TUTORIAL how to download, install and use cuteftp pro[/ame] )that I find best shows how to use CuteFTP. If you already have it, then the process will be similar to the link I put for Meagain. For the video of CuteFTP, ignore the part where he guides you to the installer on the iphone.

    I'm assuming that you both have SSH already installed on your iphones. Whoever unlocked them for you should have done that.

    Good luck for both. I hope this helps and don't forget to restart your iphone when you are both done. Hold down the sleep + home button until the iphone shuts off. The wait a couple of seconds and press the sleep button again to turn it on.
    Last edited by Pupkus; 2008-01-23 at 08:07 PM.
    2008-01-23 08:05 PM
  6. meagain's Avatar
    Pupkus - thanks so much for trying to help. Unfortunately, I tried both cyberduck and Fugo and neither will connect. For Cyberduck the message is: i/o error: connection failed
    sftp://[email protected](my ip):22
    There was a problem connecting to (my ip):22

    Maybe I don't have OpenSSH on my phone? Nope. I can't find it anywhere. Is that my problem? And, does that mean I have to restore & revert back my firmware to 1.1.1 and start from scratch? Is there a way to install OpenSSH to the phone without using Installer (which is dead?). Oh I'll just die. LOL Seriously.
    Last edited by meagain; 2008-01-23 at 08:17 PM.
    2008-01-23 08:15 PM
  7. Pupkus's Avatar
    meagain, I sent you a message to your inbox.
    Last edited by Pupkus; 2008-01-23 at 08:24 PM. Reason: Automerged Doublepost
    2008-01-23 08:23 PM
  8. meagain's Avatar
    Much thanks to Pupkus for IM'ing with me to help.

    Amazingly, I didn't have OpenSSH in the phone. This didn't help matters.
    I fixed it by loading the older version of Installer directly into the phone via using Independence to add only SSH into the phone, then using this instruction here
    http://www.hackthatphone.com/112/iph...stall_mac.html
    using Fugu (which didn't work at first cuz SSH wasn't on my phone).... Actually, this didn't work right either at first - what DID work was uninstalling Installer - then reloading the old version via Fugu & SSH. LOL

    No, I won't be upgrading to the new Installer.
    2008-01-24 01:03 AM
  9. Mtaveras's Avatar
    So I downloaded the file from ur site and i replaced it. but now instead of immeadiately going back to the home screen when i open installer, it opens it and acts like its going to work but then ends up going back to the home screen...installer is completely not working for me...if anyone could help me out, it would be much appreaciated.
    2008-01-24 03:45 AM
  10. meagain's Avatar
    mtaveras - That's what happened to me after I moved the file manually into the phone. The installer page (blank page) came up, stayed there for a long while, then home screen again.

    What I did was on my mac - totally deleted installer 100%... then reinstalled installer manually. This worked for me.

    I used the instructions from here
    http://www.hackthatphone.com/112/iphone_step2_mac.html
    and
    http://www.hackthatphone.com/112/iph...stall_mac.html
    2008-01-24 03:53 AM
  11. Mtaveras's Avatar
    thanks a bunch....u helped me out in a different way than i expected...on the link it show them changing the octal to 0755...which is apperantely what i forgot to do...so it is working now!! yay. thanks
    Last edited by Mtaveras; 2008-01-24 at 04:23 AM. Reason: Automerged Doublepost
    2008-01-24 04:15 AM
  12. slvrf150fx405's Avatar
    im so lost im having the same problem with my installer. im trying to login to winscp and it will not connect. I have been trying to get this to work for like 5 hours now and im about ready to give up . Any help would be great. Im running windows also. Thanks
    2008-01-24 04:53 AM
  13. Pupkus's Avatar
    slvrf150fx405: if you are not able to connect to your iphone using an FTP software, then maybe you don't have SSH installed on your phone.

    You should get it installed using the links that meagain provided to get SSH on your iphone. From there, try deleting some apps to make some space and then use the file that I put on my site to replace the one currently on your iphone.

    You can use one of the two Youtube references that I posted earlier on this post to help guide you on copying the files.

    Good Luck!

    Meagain: I want to thank for taking the risks with me on your iPhone and trying all the different suggestions. I'm glad it worked out! Hopefully this will provide solutions to anyone else having problems.
    2008-01-24 05:59 AM
  14. Dil999's Avatar
    I've tried every method described in this thread and still my touch does not work..
    It goes to the white screen for around 20 seconds and then goes right back to the home screen. Any other suggestions?
    2008-01-24 07:59 AM
  15. Kanies's Avatar
    ohhhhhhhhhhhhhhh man i tried the ssh connecting but its not working and on my cuteftp there is no fstp option on new .... and when i try to connect using others aswell it says cannot open?? please help!!! or does anyone know if nullriver!!!!! is gunna fix the problem they have caused!!! please please help and thanks pupkus for trying any other ideas please?? Kanies!!! damn you nullriver and ur update of destroyng my installer!!

    ok ok please im really needing help here!!!... i got a p.c not mac and really need help getting my installer back ...i had the 1.1.2 version then downloaded a big boss 1.1.3 ad everything was fine but then.... THIS IS WHERE IT GETS LETHAL!!!...i tried ti update a nullriver 3.0b sumet and that was the end of installer for me!!! just loads to blank page then switches off!! gutted ..so please someone out there help me please!!!.. Oh and if i need to do this ssh thingy what parts of winscp do i download to access my phone?? theres loads im really getting muddled up ..plz help! thanks waiting for reply Kanie.
    Last edited by Kanies; 2008-01-24 at 09:50 PM. Reason: Automerged Doublepost
    2008-01-24 09:50 PM
  16. slvrf150fx405's Avatar
    im still lost nothing is working for me i have ssh on my phone. and winscp is still not working. Im so mad right now. Im thinking about restoreing my phone and jailbreaking again. Any help would be great.
    2008-01-25 05:08 AM
36 12
LINK TO POST COPIED TO CLIPBOARD