User Tag List

  1. starscapes's Avatar
    I've got an iPod Touch, bought 2.0 firmware upgrade via iTunes. Jailbreaked with these instructions (had to find the 2.0 iPod Touch firmwire via torrent since I couldn't find the ipsw on my machine).

    After the jailbreak, my Touch rebooted and I had Cydia (yay!), installed NES (yay again!). Wanted to add NES rom source repos. Tried adding No warez "Updating Sources...downloading...." and I get this error:

    Source Error
    Sub-process bzip2 returned an error code (2)
    <Okay button>

    I found this thread. Tried to add, same error.

    I found this cryptic (to a newbie) ticket. Except I have no idea what is meant by "Cydia Source Set".

    And there's talk about an "" that seems to refer to something other than Cydia. But it's not clear to me what. All I know is, I did the jailbreak, Cydia icon appeared. No Installer icon.

    If anyone has any advice or (even better) a fix, please let me know!


    Last edited by Broomhead; 2008-12-09 at 04:30 PM.
    2008-08-02 09:12 PM
  2. ggab's Avatar
    Did you ever get a resolution to this? I'm getting the same error.
    2008-08-07 12:52 AM
  3. philbowden78's Avatar
    same problem, installed NES no problem, but unable to find the right source to download via Cydia
    2008-08-11 09:56 PM
  4. starscapes's Avatar
    I never resolved this issue - I think the issue is the 2.0 fireware. It just doesn't work with 2.0. I went with the manual install method, install openSSH, scp the ROM files into the device (you can Google for the instructions).

    I also just found this: - iPhone Apps, iPhone 3G apps and iPod touch Applications Gallery
    Dunno if it works though.
    2008-08-19 06:02 PM
  5. kurufen's Avatar
    try this as a source in cydia... No warez
    Last edited by Broomhead; 2008-12-09 at 04:31 PM. Reason: link didn't was showing as *******
    2008-08-31 12:53 PM
  6. infusion2k7's Avatar
    I'm having the same issue with Cydia with regards to the error code, but I can still install stuff so it;s not relaly affecting me. It's probably just a dodgey source I;ve added or something.

    Anyway. If yu want to get the ROM's onto your iPhone with minimum ball ache you need a piece of software called DiskAid 1.5

    Now the latest version requires you install something on your iPhone/iPod first which costs money. The 1.5 version just works from your PC over your data cable.
    (If you can't find it available on the web anymore, drop me a message and I'll email it to you)

    So, if you have the NES emulator installed, load up DiskAid 1.5 and plug in your device. You'll see a directory tree:

    Click on ROMs on the left hand pane, then double click on NES in the right hand pane.

    Go to any ROM site that lets you get roms for free, download them, unzip them and drop them in the NES folder.

    Jobs a good un. Now just fire up the app and away you go.

    ** NOTE: I've never installed the NES app on my iPhone 3G, but the genesis and MAME ones work fine.
    If you're having trouble, screw the NES, go for the GENESIS emulator. Pretty much every game works on there
    2008-12-09 04:27 PM
  7. Broomhead's Avatar
    Please don't post links or sources to warez

    How to SFTP NES ROMs

    1. install OpenSSH
    (from list of apps available from Cydia)

    2. install NES
    (from list of apps available from Cydia)

    3. Get a SFTP program to SSH to your iphone from your computer
    (MAC FuGu--Wiki Guide / PC WinSCP--Wiki Guide)

    4. SFTP settings: Server will be your IP address of your iphone, User = root, password = alpine.
    (get your iphones IP address from Settings->Wifi->click the arrow next to the wifi network you are connected to. you'll then see your IP address)

    5. var/mobile/media/ROMs/NES , You will need to create the ROMs and NES folders. This is the directory you'll place your NES ROMs.
    2008-12-09 04:32 PM
  8. infusion2k7's Avatar
    Hi again.
    My previous post doesn't contain links to warez or any other type of dodgey software. It's certainly more user friendly and way less dangerous for the average iPhone user to use.
    In fact it's SO legitimate that Apple have it on their AppStore.

    I don't mean to question your almighty power as a super mod but you should have really had a quick look. You might have learned something
    2008-12-15 10:13 AM
  9. feinhorn's Avatar
    2009-09-09 10:50 PM
  10. curez's Avatar
    had the same problem after installing cydia and adding a few repos after restoring my phone from a crash.

    so i decided to restore and just kind of thought maybe it had to do with rock or cydia working together.

    so to make it short...

    restored to new, installed blackra1n, installed cydia and rock at the same time, loaded rock and kept on running it til no more updates and whatever (installed complete updates instead of essentials). then loaded cydia and it did it's things, added repos with no problems. hope this helped.
    2010-01-12 12:48 AM
  11. ggab's Avatar
    Wow, holy thread revival!
    2010-01-12 12:50 AM
  12. curez's Avatar
    haha. only been doing the jailbreak stuff for a month or so. thought i'd start posting some stuff.
    2010-01-12 12:52 AM
  13. ggab's Avatar
    haha. only been doing the jailbreak stuff for a month or so. thought i'd start posting some stuff.
    Right on bro...welcome to the scene.
    2010-01-12 01:58 AM
  14. hyperkinesis's Avatar

    I need some help with Cydia. My 3gs 3.1.2 My cydia do not update
    some errors like error message would be Bzip2 error then The following signatures were invalid: NODATA 1 NOTDATA 2

    I ask because I alresdy do all the option hee erase the partial folder, modify de cydia list modify the metdata.plist

    but still recived the error and cydia do not update
    What Can I do for this situation please someone help me
    Last edited by hyperkinesis; 2010-02-28 at 05:16 PM.
    2010-02-28 04:59 PM
  15. ggab's Avatar
    You're not going to get a whole lot of help around here when you start throwing out things like
    2010-02-28 05:02 PM
  16. hyperkinesis's Avatar
    Thanks.... I mew here and I read all I can find about this theme...Bu I still cant resolve my cydia problem

    Thanks.... I mew here and I read all I can find about this theme...Bu I still cant resolve my cydia problem
    some problems no 1. sources are update
    Error refreshing data:
    GPG error:
    Release: the following signatures
    were invalid: NODATA 1 NODATA 2

    error message would be Bzip2 error

    I follow the tutorial to fix this situation
    I mod de cydia.list metadata.plist and partial folder

    and now I get this message
    Type_ deb is not known on line 1 in source list /etc/apt/sources.list.d/cydia.list

    What I do know
    Last edited by hyperkinesis; 2010-02-28 at 07:21 PM. Reason: Automerged Doublepost
    2010-02-28 07:18 PM
  17. Legonro's Avatar is an alternative package downloader to, as is Installer is no longer being used, so it is no solution. I really have no solution; I'm getting the same error.
    2011-09-03 08:33 PM