1. inazuma's Avatar
    I upgraded to 1.1.3 with this tutorial
    http://www.iphoneatlas.com/2008/01/2...cwindows#step8

    Now i have a working Jailbroken 1.1.3 (with phone, wi-fi, etc working)

    I have Installer v3.0b4 installed.

    Problem:
    I get this error (Main Script Execution Failed!) when i try to do any of the below:

    - Trying to upgrade to the latest Installer v3.0b10 (get Main Script Execution Failed!)
    - Cannot install any third party apps (get Main Script Execution Failed!)
    - Try to reinstall BSD 2.0 (getMain Script Execution Failed!)

    Did i skip something in the jailbreak tutorial?

    Please help

    Thank you in advance
    2008-01-28 05:52 PM
  2. ericidle's Avatar
    Your problem is you did not update installer to the latest version v3.0b10 before you upgraded to 1.1.3. You have no option now but to go back to 1.1.1 and start the whole process again, this time make sure you have updated installer and BSD subsystem to the latest version before you soft update to 1.1.3
    Eric's iPhone 4 4.01 offically unlocked
    2008-01-28 07:35 PM
  3. mmmhshiney's Avatar
    You needed to be at the latest installer before doing the upgrade. Unfortunately, this info was not made clear until later tutorials. It sounds like you're going to need to start again at 1.1.1. Then go to 1.1.2, make sure installer and BSd are up to date and then soft upgrade to 1.1.3.
    2008-01-28 07:40 PM
  4. inazuma's Avatar
    Thanks for the help. I was afraid of that, but...

    This tutorial says NOT to upgrade Installer at all. (it says to skip upgrading)
    http://www.modmyi.com/forums/showthr...ecution+failed



    Unless there is another way to fix this.....
    Since there are so many tutorials now for 1.1.3

    What is the best way to go from jailbroken 1.1.3 > Downgrade > back to jailbroken 1.1.3 (DEV TEAM's Version) ?

    Thank for the help.
    2008-01-28 08:20 PM
  5. mmmhshiney's Avatar
    That guide seems ok to use, just make sure you have the latest versions of Installer and BSD. It may take a bit more time but it is safer and is better than starting again. I didn't perform the lockdownd change at the end and my AnySIM unlocked phone works fine. At no point have I needed to perform any SIM unlocking or changing for the upgrade.

    Restore to 1.1.1.
    Jailbeak / Activate using jailbreakme.com
    Put BSD and OpenSSH on
    Install Oktoprep
    Update to 1.1.2
    Run 1.1.2 Jailbeak jar
    Ensure you have updated Installer and BSD installed
    Then do Dev teams 1.1.3 Jailbreak
    Check Installer and BSD are up-to-date. If not, update them.
    install / reinstall OpenSSH and you should be good to go
    2008-01-28 10:57 PM
  6. inazuma's Avatar
    Thanks for your help!
    2008-01-29 12:14 AM
  7. touche's Avatar
    I upgraded to 1.1.3 with this tutorial
    http://www.iphoneatlas.com/2008/01/2...cwindows#step8

    Now i have a working Jailbroken 1.1.3 (with phone, wi-fi, etc working)

    I have Installer v3.0b4 installed.

    Problem:
    I get this error (Main Script Execution Failed!) when i try to do any of the below:

    - Trying to upgrade to the latest Installer v3.0b10 (get Main Script Execution Failed!)
    - Cannot install any third party apps (get Main Script Execution Failed!)
    - Try to reinstall BSD 2.0 (getMain Script Execution Failed!)

    Did i skip something in the jailbreak tutorial?

    Please help

    Thank you in advance
    You don't need dowgrade to fix it, simply do it:

    First of all you need to downgrade your installer. so go to this website “http://rapidshare.com/files/77732205...er_v3.0b8.zip”

    Save this to your desktop.

    Now you must Ftp into your iphone with “wifi” using a program such as “Winscp” or "transmit" to mac. Username is “root” password is “alpine.

    Delete /Applications/Installer.app Folder and then copy the 3.0b8 file you downloaded in the same directory. Once this is done you will right click the new “installer.app” on winscp/transmit and select Properties. Set the permissions.to "777″. Reboot your phone and now you will have “3.08b Installer” on your phone and it should be working fine. Now do the upgrade to "Installer v3.0b10". I'll got a script error, don't worry, go to you terminal and ssh you iphone:

    $ ssh [email protected].x (change to your iphone ip)
    [email protected].x's password: (i think is "alpine"
    # cd /Applications
    # chmod +s Installer.app/Installer
    # chown -R root:wheel Installer.app

    restart you iphone and installer should be working fine!

    good luck!

    Thanks Paulie B for part of this explanation!

    Touché
    2008-01-29 06:35 PM
  8. iPhoneWriter's Avatar
    Restore to 1.1.1.
    Jailbeak / Activate using jailbreakme.com
    Put BSD and OpenSSH on
    Install Oktoprep
    Update to 1.1.2
    Run 1.1.2 Jailbeak jar
    Ensure you have updated Installer and BSD installed
    Then do Dev teams 1.1.3 Jailbreak
    Check Installer and BSD are up-to-date. If not, update them.
    install / reinstall OpenSSH and you should be good to go
    My steps exactly... repeated twice now, with complete success.
    - iPhoneWriter.com
    2008-02-01 06:34 AM
LINK TO POST COPIED TO CLIPBOARD