1. cheesecakezz's Avatar
    Hey guys, I have this problem where I open installer and it goes to a white screen for 1-2 seconds then it crashes back to spring board. I have looked extensively for other threads about this problem and I have tried everything. I have permissions already set to 755, I already have used bosstools to move my applications for memory purposes, I have even deleted the oversource file in case installer refreshed too many sources it can't handle(yes there was a thread touching this issue). I haven't however reached to the final solution of re-doing everything, i'm tired of that. I am willing to manually re-install installer though via SSH. But if anybody knows how to pinpoint the problem for a quick fix that is always best. Thanks
    Last edited by cheesecakezz; 2008-03-16 at 08:39 PM.
    2008-03-16 08:35 PM
  2. jmeds1's Avatar
    I have the same problem. Any solutions? I really don't want to restore again.
    2008-03-26 06:42 AM
  3. jporgy's Avatar
    me too. ive already deleted the remote packages.plist and trustsources.plist and restarted the iphone (1.1.1) and its still not working. it goes to a white screen for 1 sec and then goes back to the main menu. need help badly.
    2008-04-04 04:15 PM
  4. cfkiphone4's Avatar
    hey ive had my installer crashing for the past 2 months so i found an easy fix
    step1:reboot iphone
    2pen installer
    3:while installer is loading hold down the lock button until it says slide to turn off hit cancel
    but still hold the button waiit till the sources are done refreshing then let go
    4:while the installer is up and running delete some apps/addons then if updatable dont wait update it
    2008-06-25 06:21 PM
  5. Viel's Avatar
    Well, I did have that problem too ... I tried the cfkiphone4's solution ... but works a little bit, atleast the app doesnt back to the desktop ...

    Well ... I just find by myself the solution ... I notify that the Installer.app was into /Applications/ ... It's just like my mac.

    I find the user's conf folder. In my iPhone 3G (fw 2.2 with jailbreak) i found it into

    /User/Media/Application Support/

    I found the Installer directory into it.

    (if u can't find it there ... just use 'cd /User/; find . -name Installer' and you will get the right path.)

    I just move the Installer dir to Installer.old dir ... then, I start again de Installer.app from my shortcut on my iPhone's desktop ... and Voila! Works again.

    btw, a new Installer dir was created ... after that, i remove my 'backup dir' called 'Installer.old'

    I hope this can help somebody :P

    rgds,
    Vielinko
    2009-01-28 07:15 PM
  6. ondiron's Avatar
    Wait what do you mean by 'i found it into" ?
    2009-03-27 04:51 AM
  7. Broomhead's Avatar
    old thread... installer is all but dead, just use cydia
    2009-03-27 04:55 AM
  8. Viel's Avatar
    Wait what do you mean by 'i found it into" ?
    i mean, "I found it into" that dir /User/Media/Application Support/
    2009-03-31 07:23 PM
  9. mr.sparky's Avatar
    simple fix rejailbreak and ONLY install cydia...now thats a thought...why even waste your time with that JUNK?
    http://i122.photobucket.com/albums/o260/cpjr1979/dc5274181cd827585d4bb6d16bedb210cop.png
    Steroids are yummy
    2009-03-31 08:16 PM
  10. devorama's Avatar
    Hey, I tried Viel's suggestion and it worked! I had the same problem. I have firmware 2.2 and Installer just crashes a second after startup.

    I SSHed into my phone and renamed the

    /User/Library/Application Support/Installer

    to

    /User/Library/Application Support/Installer.old

    Then I restarted Installer from the springboard icon. And it worked!
    2009-03-31 10:47 PM
  11. Viel's Avatar
    nice.

    simple fix rejailbreak and ONLY install cydia...now thats a thought...why even waste your time with that JUNK?
    I really know that ... But some apps from installers still works in new iPhones ... a few games too ...

    I just found a solution, i think that can help other ppls :P ... that's the way i shared it
    Last edited by Viel; 2009-04-03 at 12:20 AM. Reason: Automerged Doublepost
    2009-04-03 12:19 AM
LINK TO POST COPIED TO CLIPBOARD