User Tag List

  1. ibr4ke4iph0nz's Avatar

    Hello Everyone! I am a new member to this community and I want to introduce myself as well as my purpose. I am an IT consultant who focuses on business apps (think SAP, legacy apps etc..). I am also in the process of studying for my CEH and penetration testing license.

    I have been jailbreaking, repairing, and tinkering with iphones for a little less than a year. Before christmas I was not an iphone user myself because I didn't like the texting and preferred BB. However, Christmas brought me a new iphone as my family insisted. We had around 16 iphone users at our annual christmas gathering, and as I am the developer/tech guy of the family, it was natural that I began to mod everyone's iphones.


    This went without a hitch until I started my mom's. Her's was purchased in May of 09. I had her upgrade from 3.1 to 3.1.2 in order to prepare for a jailbreak with blackra1n. I am not sure if her wifi stopped working before or after the update or the jailbreak attempt but it does not work now. Being a tech guy, I proceeded to google for 2 days and tried everything that I found to no avail.
    1. Try to connect to a basic unsecured router
    2. Reset Network Settings
    3. Restore to new phone
    4. Use Wififofum

    5. So now I am trying to manually configure her iphone for usage through mobileterminal.

    I am a daily linux Backtrack and Ubuntu user so I am quite familiar with manually configuring wifi from the terminal. My purpose is to find a fix for this problem if Apple refuses to.

    Some people point the finger at blackra1n, and others say that iphones are notorious for wifi problems after baseband and firmware updates. I do not care personally. My opinion is it can be repaired.


    So far I have verified that a MAC address is being assigned to the device. I have also manually assigned an IP address by using the following in terminal:
    (enter your password)
    ifconfig en0 broadcast
    This registers an IP address for the device. I am now trying to figure out how that I can set the ESSID, WEP KEY, and MODE to be managed. In linux I would use IWCONFIG.


    1. Is there an equivilent to IWCONFIG in linux for the iphone?
    2. Can I add WGET and APT-GET to my phone?
    3. I also would use:
    modprobe "rtl8187"
    to install the wifi driver module for my wifi card in linux. What is the name of the module driver for our wifi device on the iphone, and how can I make sure it is loading ?

    So that is it. I am determined to find the answers I need to solve this problem and provide a fix for the tens of thousands of iphone users who have my problem. Please help if you can by answering one or more of the questions I have and I will do my best in return to solve this problem.

    ========================================UPDATE #1================================================ =
    I haven't solved the issue but I have managed to get a few things in preparation for the fix. I first installed wget, and then I install aptitude. For those of you linux users out there using an iphone 3g(s) with 3.x software, you should note that apt-get is not available anymore. You can install "APTITUDE", and then you can use the following:
    aptitude install "some program"
    instead of the old method using apt-get:
    sudo apt-get install "some program"
    I am determined to solve this issue. I really need to understand more about the wifi hardware in this phone. I am wondering if just reinstalling the baseband firmware can help?

    Oh well, looks like those of us with wifi problems are on our own...
    ========================================UPDATE #2================================================ =
    So I have gotten a little further into the problem, or at least I should say I have been further familiarized with it. I have two iphones in my hands and when I ifile to the following location:
    /var/preferences/system configuration/
    I find a file called
    I compaired the two files paying specific attention to the key:
    I found a difference in the two phones:

    The currently working device had 5 keys for this category:
    (in that order)

    While the non-wifi having phone had the following keys:

    (in this order)

    What is concerning me is the addition of an extra device (en1). If this is actually one device registering twice, then there would obviously be a conflict of resources. I could really use some help from someone who knows what each of these device names stand for so I don't have to figure it out on my own, which will be quite time consuming. It is obvious that ip1, ip2, ip3, and ip4 have to do with 3g, edge, and other things. I know that en0 is for sure the wifi because of the information I learned earlier. But I want to be sure.

    People, I am determined to solve this problem, I would love your feedback or comments as I feel a little alone on this post.

    Thanks Jason
    ========================================UPDATE #3================================================ =
    Ok I have found out the two differences in the devices en0 and en1

    <string>Ethernet Adapter (en1)</string>

    Correct me if I am wrong, but I am sure that the Airport Device correct as it is on my other phone that works, but having an ethernet adapter is not right! So I am on to something there, but it does not pertain to duplicate devices with conflicts. I have two ideas to pour into now:

    1. Disable through mobileterminal (I will try this both before and after resetting network settings)
    2. There is a key called <ServiceOrder> at the bottom of the preferences.plist file. I am going to make sure that en0's key and string values are above that of en1.

    I will of course post what I find out!

    ========================================UPDATE #4================================================ =
    Well I have good and bad news. The bad news is that the simple fix of turning off device en1 with:

    $ifconfig en1 down

    did nothing to fix the problem. The good news is that the <key>ServiceOrder</key> is as I expected. en1, our mysterious ethernet adapter is listed above our Airport adapter (en0) in the list. This is obviously wrong and I confirmed this by looking at my wifi functional phone. It's first "ServiceOrder" device is obviously the Airport (en0). So now I am going to try to flip the devices in the preferred service order. If that doesn't work, I decided to back up the preferences.plist file and rename it. Hoping that the system will replace the file. If it does not, I am going to try and figure out a way to use my good phone's preferences.plist file as a template and copy it to my bad iphone, then update the keys so that they will pass security scrutiny on networks. I am getting closer to the root of the problem people!
    Last edited by ibr4ke4iph0nz; 2009-12-29 at 10:00 AM. Reason: Automerged Doublepost
    "Computers are one of the most dangerous technological inventions - Well, next to handguns and tequilla!"
    2009-12-29 08:59 AM
  2. confucious's Avatar
    The problem is caused by BlackRa1n.
    Try emailing Geo.
    Most people do not have the technical knowledge to help (I certainly don't) and those that do (eg the Dev Team) are not going to spend time fixing bugs in George's programs.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-12-29 09:22 AM
  3. nora47's Avatar
    good luck if you can fix it, didnt use blackra1n in fear of losing wifi, dont need 5.26 anyway or whatever it is
    2010-01-01 11:52 PM
  4. ibr4ke4iph0nz's Avatar
    Thanks for the feeble incouragement. I haven't had much time to work on this because my mom is so addicted to her phone that she will not let me mess with it. She will change her mind the first time she needs wifi. We have a great network backbone here and she doesn't see much of a difference, especially since she is a noob.

    I have narrowed this down to the fact that the driver is present but is either not allowing the signal send, or is set to a level that is way too low to pick up even touching the router's ant.

    Either way, I am most certain that if someone would point me in the direction of a driver that I can manually set this up to work through mobileterminal.

    I am also still leaning at the fact that the preferred network is always en1 before en0. I really need someone with experience and a current wifi problem that meets the criteria to verify this. If that is the case then it would explain why the device refuses to send a strong signal, because it is not preferred.

    This is not a hopeless venture. If people would contribute to the effort I am sure that I have additional resources that will help us solve the problem. I know guys that have QCAT type for them and can work circles around embedded systems of any type. I am sure this is simpleton to them but I have to interest them in the venture with a proper challenge...

    Hopefully one of you readers will find the time to verify your file and post your findings here. Progress is painful but inevitable...

    "Computers are one of the most dangerous technological inventions - Well, next to handguns and tequilla!"
    2010-01-02 06:54 AM
  5. confucious's Avatar
    Have you contacted George?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-01-02 10:02 AM
  6. g0sbv's Avatar
    I think you can get apt from cydia..
    2010-01-02 11:52 AM
  7. ibr4ke4iph0nz's Avatar
    Sorry Confucious, yeah, I forgot about emailing George. I did so a few minutes ago. I am about to sit down and pour into this some more tonight as my mom has the flu and I am taking care of her this evening.

    Thanks for the heads up on apt. I actually picked it up the other day as well as many other good things. Starting to feel like I have a mini *nix box that is portable now! Thanks again everyone...

    "Computers are one of the most dangerous technological inventions - Well, next to handguns and tequilla!"
    2010-01-03 03:07 AM
  8. nk_twister's Avatar
    Hey jb,

    I too have issues with my iphone 2g wifi since my upgrade to 3.1.2.. I was previously on 3.0 and was having frequent wifi drops and unable to join networks issue..

    After upgrade to 3.1.2 wifi is totally dead.. wifi settings has only long time spinning wheel when i turn it on and sometimes wifitrak would show the access point (when phone is cold) but would not be able to join and lose it again..

    From my preferences.plist, the wifi part was set first in the ServiceOrder variable and there were two others pertaining to my service provider...I did not have an en1 as you have mentioned in ur problem plist..

    the catch was that at the beginning of preferences.plist, there is a currentSet variable the value of which does not match that of the wifi or the 2 service providers in the networkservices list..

    Can you please check both your working and non-working ones to confirm the same??

    Edit: I think I have the en1 in the networkinterfaces.plist and it seems to be for USB Ethernet Sharing which can be seen in the folder \System\Library\SystemConfiguration .. I have not enabled tethering so it may not come in the preferences.plist...
    Last edited by nk_twister; 2010-01-03 at 01:31 PM. Reason: addl info.
    2010-01-03 01:22 PM
  9. awesomeSlayer's Avatar
    This is not news.
    Asking for help is different from being stupid. Fanboys can rot in @#$%!
    2010-01-03 04:36 PM
  10. 1hihum's Avatar
    I think that the fact that someone is actually working on a fix for this problem IS news, at least to me. I look forward to seeing how this turns out. My WIFI is almost useless these days, so I would really love to see a fix. Oh and I'm still on 3.1 right now, so it's not just a 3.2 issue. I've had problems ever since I JB mine. Good just sir, and your efforts are very much appreciated!!!!
    2010-01-04 01:30 PM
  11. josantvp's Avatar
    This is a very interesting post, even thou i don't understand most of it i am also suffering from the same problem

    I Also don't remember when did the wifi got f*ck up in my phone but i have tried almost all solutions.

    I don't think it is related to Blackra1n because when you restore the phone to a prior fw (such as 1.1.4) you are able to erase baseband and then put a new one using ilibery or via a itunes restore. neither way helped me at all.

    The funny thing is that my iphone has wifi and bluetooth but the signal is very very low. I need to place it right next to my router (which has been updated, fw upgraded, rebooted with and without any security). also i tried to pair my new bluetooth headset and it only works for a few seconds at most but when i separate it less than a feet away from the phone it disconnects.

    I never actually lost wifi neither bt, Mac Address, IMEI or anything.

    My best guess here is that 3.x moves some settings (in some phones only) that aren't repaired when you try to restore it by any fw, loosing reception at all time.

    I will try this weekend to restore to 1.1.4 again as a new phone, delete the baseband and reinstall 2.2 or 3.0 hoping to get some luck.

    I will also try to unassemble my phone and see if there is any loose cables. I will let you know how it went...



    Just by writing this down i realized that a few months ago i had to replace my screen because it went dead in the upper part (i tried everything with my old one but i couldn't make it work.

    It i just remembered that one antenna conector was a bit loose and i had some trouble placing it correctly so an idea just crossed my mind that maybe that connector got disconnected with time, so i dissasembled my phone again right now and there it was a loosen end of the antenna cable.

    This may not help other users but at least it helped me instantly.

    My wifi works perfectly and my bluetooth also works so i am very very happy with a fully functional iphone again!!!!
    Last edited by josantvp; 2010-01-06 at 04:14 AM. Reason: Automerged Doublepost
    2010-01-06 04:13 AM
  12. confucious's Avatar
    Geo is on IRC trying to solve this now his twitter posts:


    looking for several intelligent people affected by the wifi bug, please run dmesg and post output, think I've pinpointed the race condition


    the best would be a comparison between dmesg of a bootup thats affected and one thats not on the same phone


    k, it's apparent I shouldn't have come back to twitter, i'm on osx86 irc if you actually want to solve the wifi bug
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-01-07 08:43 PM
  13. nk_twister's Avatar
    after a couple of freezing my iphone (which i obviously dont like).. the phone is able to detect the acces point now n then.. but goes to unable to join network.... from the iphone config utility console log i saw that some SDIO gets timed out during this issue after the phone gets connected.. sometimes i saw it got connected but would drop off before i see the wifi icon on status bar ! wifitrak also does not help much !!.. i had also tried comparing the log with my dads working phone (pwned 2g os 3.0 and mine is 2g pwned 3.1.2 and i also blackra1ned it again) some logs have been attached for reference.. the wifi chip would have got hotter someday i left my phone to charge fully overnight and was causing some wifi dropping in 3.0 .. so i updated to 3.1.2 hoping it would resolve it.. but since then no luck on wifi .. the problems are both in software and hardware i guess !!

    some key info:
    timeout to authentication causes unable to join networks
    SDIO timeout also causes unable to join networks after a delay
    scan failure causes the continuous spinning wheel

    i've been able to create the could not scan for wireless networks by going to other -> network as "NK" and click join.. it searches and goes into a bad loop ...

    Attached Files
    2010-01-10 05:49 PM
  14. Kadiblov's Avatar
    I dont know if there is something related, but follows my testimony.
    During a quick hicups of my Wifi, I was able to login through SSH (WinSCP).
    I was trying to fix Cydia by removing, update package and install using apt-get/aptitude.
    After Ive done that, even though Cydia install was interrupted and I was kicked out from SSH, my Wi-Fi remaining working properly for more than 24 hours ! straight ! One thing became clear to me: Is is definitely a software problem, not hardware. My iPhone was hot, environment was hot (sunny day outside - 34C around 100F), and Wifi running properly.
    2010-01-19 07:02 PM
  15. Kadiblov's Avatar
    Folks, Ive found my way out to fix Wifi issue and posted my experience here. I was really concerned to be a hardware issue.
    It might be worthwhile giving a try...

    In addition, for those running Windows, redsn0w 0.9b3 is available ( ). For those facing issues, it also can be an alternative, I just dont want to mess with that now everything is working fine on my phone :S
    2010-01-21 04:22 PM
  16. nk_twister's Avatar
    Thanks Kadiblov.. I do not have any problems with Cydia.. I have also restored with 3.1.2 .. no luck yet..

    @ibr4ke4iph0n any luck on the process ? have you got yours working ??

    i am stuck with "WifiManagerScanCallback Scan failure 35" .. This causes continuous wifi spinning wheel .. Dmesg shows the same SDIO CMD Timeouts..

    I would appreciate it if anyone can explain if this is a software/hardware issue ??
    2010-01-30 03:36 PM
  17. Kadiblov's Avatar
    As far as I can tell, this IS NOT a hardware issue as long are you're able to see your access Point when you put iPhone in Airplane mode and activate only WiFi manually. It usually works, indicating a potencial bug in the algorhythm which priorizes the routing over 3G/Edge or WiFi. These are my two cents.
    2010-01-30 10:54 PM
  18. -vis0-'s Avatar
    I am also stuck at the spinning wheel while looking for a network. Networks dont even appear. (I know its not a network error @ home) I'm not sure when these issues occured as I just recieved a second hand iphone. I've tried doin network settings reset, to no avial. I've done a restore (I dont think that the iphone was 3.1.3) None the less, I am on 3.1.2. My iphone isnt even jailbroken just yet.
    But from what im gathering,

    Blackra1n potentially causes wi-fi issues.

    The FW potentially causes wi-fi issues.

    I've jailbroken and unlocked numerous iphones & ipod (To the thanks of this forum, ode to you all) And havent had an issue like this before. And after gathering information off the internet, things dont seem to make much more sense. I dont know much about dev, but im just looking for a bit of clarity. I'm hoping that it's not a hardware issue, but could somebody point me in the direction of a possible guide as to how to fix this (Just in case)
    2010-03-07 12:31 PM
  19. Kadiblov's Avatar
    Have you tried Activate manually WiFi switch while in Airplane mode ? Please advise.
    2010-03-07 03:32 PM
  20. -vis0-'s Avatar
    Yes, but all I get is the rotating wheel, with no hint of access points, or wifi in my future.
    2010-03-08 01:35 AM
32 12