1. bsdbluz's Avatar
    I am attempting to lock down the sshd on my iPad so that it can only be accessed via the iPad itself. My logic here is I am using iSSH to ssh to the localhost sshd as explained in Musclenerd's demo, but I don't want the sshd to be accessible via the wifi network for obvious security reasons. I added the the below statement to the /private/etc/ssh/sshd_config file and rebooted the iPad:


    Although the above text is intact after the reboot, sshd still accepts connections from the wifi network. This is how to generally lock down sshd on any Unix box I have ever worked on. Has anyone else noticed that sshd_config seems to be ignored by sshd during start-up? Any suggestions on a workaround are much appreciated.
    2010-05-08 04:26 AM
  2. tekwiz's Avatar
    Not sure but I swear I uninstalled OpenSSH to fix the location services issue but when I tested connectivity via wifi afterwards it still worked, AND location services did as well so maybe something else is handling the connection?
    2010-05-08 05:38 PM