1. ROm222's Avatar
    Which iPhone SDK version is compatible with the Firware v1.1.4?

    Tks!
    2008-05-08 05:23 AM
  2. cpjr's Avatar
    ??? What do you mean compatible? The SDK must be used with beta 2.0
    2008-05-08 05:32 AM
  3. ROm222's Avatar
    Ho! sorry, maybe I wasn't clear enough...

    Im interested in developing apps. for the iPhone, and while browsing I saw that the 2.0 (1.2) firmware is not out yet, and only beta are available (and none of them can be easily jailbreak/unlock). What I want to develop is a OpenGL ES app. so I need to test on the device. So I want to know with version of the SDK I can download that fit of the version of my firmware that is 1.1.4. So I can create apps and debug them on the iPhone.

    I also read that the SDK will expire... is it true? or is still possible to create application using the SDK compatible with 1.1.4?

    Cheers!
    Last edited by ROm222; 2008-05-08 at 10:57 AM. Reason: typo...
    2008-05-08 10:51 AM
  4. Pyrofer's Avatar
    The SDK works with OpenGL in the simulator now.
    Download the latest beta 5 and test in the simulator.
    2008-05-08 02:18 PM
  5. ROm222's Avatar
    Im running on beta 4 now... but the simulator does not mirror the performance on the device (since it's just a software renderer), it only emulates the behaviors (OpenGL ES) and some functionalities are also missing (such as texture compression, antialias etc...)

    I would definetly prefer to test on the device... cuz in the simulator the performance seems to be too good to be true
    2008-05-08 02:41 PM
  6. Niiro13's Avatar
    Im running on beta 4 now... but the simulator does not mirror the performance on the device (since it's just a software renderer), it only emulates the behaviors (OpenGL ES) and some functionalities are also missing (such as texture compression, antialias etc...)

    I would definetly prefer to test on the device... cuz in the simulator the performance seems to be too good to be true
    There's no way for the SDK to build 2.0 applications that run on 1.1.4, because of the different frameworks and the fact that developers pay $99 to get the beta firmware.

    Well, actually, there's a way to use the SDK to build 1.1.4 applications, but obviously those are 1.1.4 applications. And require a modded SDK...
    2008-05-08 05:23 PM
  7. abi786's Avatar
    help

    how to kick out of recovery mode?
    Last edited by abi786; 2008-05-17 at 09:38 PM. Reason: Automerged Doublepost
    2008-05-17 09:38 PM
LINK TO POST COPIED TO CLIPBOARD