1. the_bay_mafia's Avatar
    So I have an iPhone 3g I had 3.0 beta 3 on the phone I clicked update to install beta 4 (perhaps that was my first mistake) I got an error.... so then I tried to restore it with the beta 4 file.... now I keep getting error 1607, 10, and one other... I have tried the "1607 fix" to no avail... i have tried restoring with 2.2.1 nothing will work I always get an error... im using windows vista 64 bit

    I BEG FOR YOUR HELP!
    Please thank me if I helped you! ---------------------------------->
    2009-05-04 06:07 AM
  2. StealthBravo's Avatar
    Are you registered with a dev? Are you running iTunes 8.2?
    2009-05-04 06:21 AM
  3. the_bay_mafia's Avatar
    yes, I am registered with a dev... and no... I am not running itunes 8.2... perhaps that is my problem! lol i shall try this.....
    Please thank me if I helped you! ---------------------------------->
    2009-05-04 06:28 AM
  4. Zwayne's Avatar
    8.2....should do the trick.
    2009-05-04 06:37 AM
  5. StealthBravo's Avatar
    PM Sent
    2009-05-04 06:39 AM
  6. the_bay_mafia's Avatar
    THANK YOU THANK YOU THANK YOU THANK YOU! that did the trick! ahhh I thought I was going to die without my iPhone :[ xD
    Please thank me if I helped you! ---------------------------------->
    2009-05-04 01:46 PM
LINK TO POST COPIED TO CLIPBOARD