1. tC_Crazy's Avatar
    Is it possible to use a 3.0 iPhone to test apps made in the 2.2.1 SDK? I recently upgraded my 2G iPhone to 3.0, not realizing that the 3.0 SDK required 10.5.7.

    Some background: Running OSx86 (iDeneb) 10.5.5 on an XNU kernel. This runs the 2.2.1 SDK perfectly, including instruments and the simulator. However, when I used the recommended combo update to 10.5.7, I have problems. In both the 2.2.1 and the 3.0 SDKs, the debugger does not function, breakpoints do not work, and the simulator causes a kernel panic on the OSx86 system. Not to mention Apple fixed the loophole for non-ADC members to skip provisioning.

    Basically, I've been learning Cocoa touch for the past month and a half and now I can't do any device testing. The only development I can do is on 10.5.5 with the 2.2.1 SDK on the sim. Is there any way to deploy 2.2.1 apps to a 3.0 device? XCode tells me there aren't any compatible devices connected if I try...
    2009-07-08 10:57 PM
  2. boxxa's Avatar
    No. The SDK must equal the device version.
    2009-07-09 09:02 PM
  3. sefnap's Avatar
    Hi - I don't know if you're still trying to figure this out - the post is a couple months old. Still I thought I'd let you know that it's totally possible to use the 2.2.1 SDK to develop for 3.0 devices. Of course, you can't use the OS 3 features (core data, etc.) There is a trick to getting it to work. You have to actually install the 3.0 SDK to a custom location (we'll call it <SDK3>) - then copy the folder "<SDK3>/Platforms/iPhoneOS.platform/DeviceSupport/3.0 (7A341)" to "/Developer/Platforms/iPhoneOS.platform/DeviceSupport/" assuming that your 2.2.1 SDK is installed in /Developer. Once you've got the DeviceSupport folder, you can trash the 3.0 SDK to free up space. Your device should now show up in Xcode's Organizer, and it will ask you if you want to use it for development.

    I'm using this to develop for a 3.0 device on my PPC mac, which can't run the newer SDK.

    cheers.
    2009-10-26 12:55 PM
  4. tC_Crazy's Avatar
    I had actually worked around the problem by changing a plist file in osx which defines the os version. I just upped it to 10.5.7. Nothing broke and the SDK worked. Since then that computer has died (mobo failure) and I have a new Latitude with much better support in OSX that easily installs 10.5.7.
    2009-11-02 07:44 AM
LINK TO POST COPIED TO CLIPBOARD