1. JLA's Avatar
    I'm trying to build some C++ with the toolchain, and I keep getting a linking error that says arm-apple-darwin-ld can't locate -lstdc++. Is this a known issue for anyone?
    2008-03-16 01:11 AM
  2. NetMage's Avatar
    I am using Objective-C++ with no problem.

    What do you get if you type in arm-apple-darwin-g++ at the command prompt?

    Are you trying to use straight C++ or Objective-C++? Can you post your Makefile CFLAGS and LDFLAGS lines?
    Last edited by NetMage; 2008-03-16 at 01:22 PM.
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage
    2008-03-16 01:16 PM
  3. JLA's Avatar
    These classes are straight C++ at this point...

    I've actually butchered my Makefile in a desperate attempt to get this error resolved...the LDFlags are currently: -lobjc -framework CoreAudio (etc), although I did have a -lstdc++ at one point. And now even without it, even after I delete the *.o files, I still get this -lstdc++ error.


    The C flags are currently blank, the CPP flags are just the -I/usr/local/arm-apple-darwin/include/CoreAudio type flags.

    So at one point, I had incorporated all the things that people said to incorporate to compile these things, but I've been cutting it down, so now it's pretty much like the standard makefile I use to compile ObjC, except for:
    Code:
    CXX=arm-apple-darwin-g++
    LD=$(CXX)
    When I run arm-apple-darwin-g++ on an individual file, I get the same "Can't locate file for -lstdc++" error.

    I seem to remember that when this trip began, I was getting an error about being unable to find method for std::(such and such)...

    I'm not familiar with the land outside of Java, to this makefile stuff is new to me...

    Thanks
    2008-03-17 12:02 AM
LINK TO POST COPIED TO CLIPBOARD