1. DMI187's Avatar
    GeoHot
    Is The
    MAN

    It Work's I Got My JB Back
    Sign by Danasoft - Get Your Free Sign

    The Family iPhone 2G , iPhone 3G ,Iphone 3Gs , Iphone 4
    13" MacBook ( Black )


    2009-10-11 01:36 PM
  2. mokeiko's Avatar
    So back to my problem...Has anyone had the same issue???

    ...I have updated and restored my iphone to 3.1.2 and followed the very simple instructions for installing blackra1n, but when I try to 'make it rain' itunes pop's up when its in recovery mode and says...'itunes has detected that an iphone is currently in recovery mode...' etc, and requires me to fully restore again using itunes. The phone appears to be wiped of data at that point. I have done this several times and it is time consuming. Arrrrrrrrrrrrrrrrrrgh! Please HELP!
    click the x to close out/quit iTunes and continue with blackra1n

    mokeiko
    2009-10-11 01:40 PM
  3. RobberBoy's Avatar
    It seems to be something with the 3g, Myself and others seem to be having the same issues. If you go back a few pages someone managed to do it by restoring, and he gave some directions for doing that. Post up what your workin with so that anyone that anyone that can help has a better idea of what to help with.
    i tried
    restore and use blackrain = not working
    DFUmode and go itunes to restore then use blackrain = not working
    dled the 3.1.2 restore file and restore and use blackrain = not working
    restore and restore the backup as well then use blackrain = not working

    anymore ways that i can try?

    btw my iphone is 3G 8gb and im on XP SP3
    Last edited by RobberBoy; 2009-10-11 at 01:43 PM.
    2009-10-11 01:40 PM
  4. mkedge's Avatar
    i dont understand!
    all worked like a charm, but nothing appears on my iphone desktop!
    2009-10-11 01:42 PM
  5. slbburr's Avatar
    Can this be done on Vista or does it have to be XP? Ive tried a few times and it keeps getting stuck on the connect to itunes screen, Please help?

    BTW This isnt the first time ive jailbroken but its the first time ive needed help!! lolol
    2009-10-11 01:43 PM
  6. triphop718's Avatar
    I had to DFU restore to get my phone back. Once I did that I used blackra1n and all is fine now. reboots every time.
    2009-10-11 01:44 PM
  7. 3xChamp's Avatar
    Thanks, but I tried closing itunes like you suggested, plenty of times, but it doesnt work. I even tried running blackra1n again and again, but the same problem??? Please any other suggestions??
    2009-10-11 01:45 PM
  8. mikerlx's Avatar
    Is this the land of the 3G and 3GS jailbreaking? I have read nothing on how its going for the 2G.
    2009-10-11 01:55 PM
  9. RobberBoy's Avatar
    cant even JB my 3G.. help anyone.. been fiddling with it for over 5hours and still not JBed... T_T
    2009-10-11 01:56 PM
  10. MikePA's Avatar
    It seems to be something with the 3g,
    I was jb'd running 3.01. I upgraded to 3.1.2, ran blackra1n (run as XP under Windows7, 32 bit), reinstalled Cydia, biteSMS (beta), 3G Unrestrictor (purchased version), MyWi, RockApp, Intelliscreen, etc. All seems to be working well. VonAgent, another RockApp, nevers comes back after an upgrade like this.

    The only 'issue' I've seen is with RockApp. Every time I start it, it keeps telling me it's detected an inconsistency with installed packages and asks if I'd like to reinstall all apps. I did this once and it reinstalls all the same apps Cydia did. Plus Cydia thinks MyWi is at a backlevel release.

    My guess is RockApp and MyWi need upgraded to support 3.1.2 correctly. I uninstalled MyWi until they get this straightened out.

    EDIT 1: Just noticed when I go into App Store, Updates it reports it can't connect to iTunes store yet I can search the store and installed DropBox.

    EDIT 2: I think letting RockApp reinstall all the Cydia apps screwed Cydia up. Cydia now thinks everything it installed needs to be uninstalled. Since everything seems to be working. I will let well enough alone for now.

    Edit 3: Uninstalling MyWi resolved the Cydia issue.
    Last edited by MikePA; 2009-10-11 at 02:55 PM.
    2009-10-11 02:01 PM
  11. c1mermaid's Avatar
    Yeah, i know, But i click the "download here" and it takes me to his site/blog. Which is fine but where is it on his blog. I get the blogs and the donate button.
    click the windows logo button to start the download
    Don't hate the NooB...it's how we learn
    2009-10-11 02:04 PM
  12. Gimmicks's Avatar
    My first JB!! Done in less than a minute!

    Laptop is - Windows 7 64bit

    Iphone is - 3G 16GB on 3.1.2 Never been JB

    Procedure
    restarted laptop and once it was at desktop I closed every program I could that opens in background

    then I right clicked the balckra1n icon and properties>compatibility>run in xp sp3

    then I ran the program as administrator just to be on safe side.

    Let it rain!!

    Job done!

    I will now donate to geohot and keep using these forums.

    cheers
    2009-10-11 02:04 PM
  13. eremeya's Avatar
    does this cause issues with the internet connection like purplera1n (I've had to restart both edge and wifi many times to get internet working but only after jailbreaking with Purplera1n )?
    2009-10-11 02:06 PM
  14. 3xChamp's Avatar
    Okay, I have tried the other suggestions of closing down everything running other than blackra1n, but no rain is coming. I have 3G iphone, so I guess that's the problem right there! I have restored my phone after it crashes several times via itunes and it takes ages! Is there a quicker way? Please make it simple!
    2009-10-11 02:07 PM
  15. Gimmicks's Avatar
    does this cause issues with the internet connection like purplera1n (I've had to restart both edge and wifi many times to get internet working but only after jailbreaking with Purplera1n )?
    Just tested mine, wifi and 3g working fine...
    2009-10-11 02:11 PM
  16. shaldi's Avatar
    hi, i have 3gs version 3.1(7c144) do i have to restore to 3.1.2 than run blackrain?
    Last edited by Broomhead; 2009-10-11 at 02:37 PM.
    2009-10-11 02:11 PM
  17. confucious's Avatar
    Please stop posting links to con men!
    |There is no unlock.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-10-11 02:13 PM
  18. sakhund's Avatar
    i am running windows 7 updated my 3gs to 3.1.2 ran blackra1n in all possible ways i.e. as an administrator, xp compactability etc but it fails .. i click make it rain...itnues detects the phone in recovrey mode... i get the msg from blackrain saying its done wait for reboot...reboots doesnt jailbreak ... screen is stuck on itunes+usb cable screen please help


    INFO: welcome to blackra1n for windows
    INFO: loaded dll at CProgram Files\Common Files\Apple\Mobile Device Support\bin\iTunesMobileDevice.dll
    INFO: button clicked
    INFO: internal device callback called
    INFO: callbacks registered
    INFO: sent enter recovery command
    INFO: internal recovery callback called
    INFO: unregistered normal mode callback
    INFO: go go gadget ra1n
    INFO: send command started
    INFO: file opened
    ioctl: 1
    INFO: command setenv auto-boot true sent
    INFO: send command started
    INFO: file opened
    ioctl: 0
    INFO: command saveenv sent
    send payload: 0
    INFO: start sending exploit
    ioctl: 0
    INFO: exploit closed 0
    sent exploit
    INFO: send command started
    INFO: file opened
    ioctl: 0
    INFO: command geohot sent
    send picture: 0
    INFO: send command started
    INFO: file opened
    ioctl: 0
    INFO: command setpicture 0 sent
    INFO: send command started
    INFO: file opened
    ioctl: 0
    INFO: command bgcolor 1 1 1 sent
    send ramdisk: 0
    INFO: send command started
    INFO: file opened
    ioctl: 0
    INFO: command geohot sent
    INFO: I JUST DROPPED IT LIKE ITS HOT
    WARN: wtf who called this?
    INFO: global callback finished
    INFO: unused callback called
    2009-10-11 02:18 PM
  19. RobberBoy's Avatar
    FOUND the best solution for all have trouble.. found a new way to do it..
    1. update ur iphone to 3.1.2
    2. off the itunes or quit it
    3. right click the blackrain icon and click "run as..."
    4. untick the box where it says "protect my computer..."
    5. Enjoy!


    hope it help for all people who stuck at running, or DFU mode. at last my fiddling of 5hours pays off.. ^^ thx Blackrain altho it takes my 5hrs but it worth it..
    Last edited by RobberBoy; 2009-10-11 at 03:19 PM.
    2009-10-11 02:19 PM
  20. Raptors's Avatar
    i think mine took less then 30 seconds! lol wohho
    2009-10-11 02:19 PM
1,308 ... 567891757 ...
LINK TO POST COPIED TO CLIPBOARD