1. saji84's Avatar
    --------------------------------------------------------------------------------
    Dear All!
    Hi there

    i have an iphone with 3.1.3 OS
    Jailbroken with Snowbreeze
    Model MB489B
    Modem Firmware 04.26.08

    Simple Question!

    can i upgrade to iOS 4.0 using snowbreeze 1.6?

    plz guys help


    cmon guys help me out

    i have asked it several times now plz plz plz
    2010-06-24 05:34 PM
  2. Jon3s's Avatar
    Amaaaazing.

    Took me a couple of hours because I didn't download anything to begin with really. It's kind of frustrating to not have my old theme be compatible yet. Anyway, here was my process.

    1. Had 3GS old bootrom unlocked with ultrasn0w and jailbroken with spirit.

    *Upgraded to iTunes 9.2 and Backed up iPhone in iTunes first*

    2. Used the SHSH for 3.1.2 and "host" trick to restore to 3.1.2.
    3. Had to use ireb to get it out of the restore loop.
    4. Newest redsn0w wouldn't work, didn't recognize 3.1.2 ipsw (on vista?) and blackra1n kept crashing too (vista issue also?) so I used 0.9.3 beta of redsn0w which recognized the 3.1.2 firmware.
    5. Unlocked with newest ultrasn0w by adding the 666 repo.
    6. Did the carrier settings update from 3.1.2 for mms and tether and then installed the peacefulinsanity mobileconfig file.
    7. Downloaded the 4.0 ipsw and used sn0wbreeze to make my custom ipsw.

    Jailbroken, tethered, unlocked (haven't tested w/ another sim yet).

    Thank you modmyi.com and everyone's hard work. I am content.

    Now there's the touch decision to get sell this phone and get the iphone 4...
    !!!3Gs OLD BOOTROM, 3.1.3 JB with SPIRIT->SOLUTION TO UPGRADE iOS4.0 with JB Sn0wbreeze 1.6.1!!!

    Hi guys, i red the whole thread, and I found a step by step tutorial "how to uprgade to 4.0 who 3.1.3 spirit JB 3Gs old bootrom have".

    But I have actually one problem on the start already

    I know I need to downgrade my FW to 3.1.2 (becouse I need the older baseband for the new Custom FW Snowbreeze)

    When I try to SHIFT+Restore to the original/general 3.1.2 fw(iPhone2,1_3.1.2_7D11_Restore.ipsw), the iTunes wrote an error message:
    "The iPhone could not be restored. This device isn't eligible for the requested build"

    It seems that the iTunes check from the Apple server and not from saurik's server.

    I wrote the line in the host file already some months ago, in my cydia I can read on the top in green colour: "The device has SHSHs on file for iPhone OS: 3.1.3" but before I upgraded to 3.1.3 in the Cydia was: "The device has SHSHs on file for iPhone OS: 3.1.2". So I think I saved correctly my shshs to saurik

    Please mr proffesionals helf me to solve this problem! MrDmias i see you know everything, say me what do I wrong. It seems like I dont put the "74.208.10.249 gs.apple.com" line in my hosts file, but I did.

    I waiting your opinion

    thanks
    Last edited by Jon3s; 2010-06-24 at 05:36 PM.
    2010-06-24 05:34 PM
  3. hayess164's Avatar
    Basically does anyone know this:

    1.) I am running a 3GS with Spirit Jailbreak on 3.1.3, what needs to take place for me to upgrade to iOS4 and re-jailbreak? Is there a clear cut solution at this point in time?
    2010-06-24 05:35 PM
  4. xxhorseriderxxx's Avatar
    The old 3GS bootrom has an exploit that (with current public methods) allows custom firmware on an already pwned device (which is why it requires you to be jailbroken on 3.1.2). Already pwned devices have their kernel patched to allow custom firmware to be installed through the use of the USB exploit in 3.1.2 . Since the USB exploit was patched, you'd need to rejailbreak 3.1.2 to patch the kernel allowing you to restore to a custom 4.0 (custom firmware is custom firmware, it doesn't really make a difference what version it is). By restoring/updating with iTunes, your kernel gets overwritten by the stock one which disallows custom firmware.
    2010-06-24 05:37 PM
  5. CZroe's Avatar
    I have a refurb that came with 3.1.3 and no way to downgrade and check for tethered/untethered abilities. Because it's a refurb, I can't verify anything by the serial number. If I try something that only works on a old bootrom model without the ability to try something older/safer and it turns out that mine is a newer bootrom model, will I be at risk or locking the device up or getting it stuck in a boot loop or anything I can't recover from?
    Last edited by CZroe; 2010-06-28 at 01:23 AM.
    2010-06-24 05:46 PM
  6. SevenThirteen's Avatar
    I'm sure this has been asked but I have an MB model 3gS with old bootrom. I used spirit on my 3.1.3, then restored and updated to 4.0. Can I JB?? I don't understand why spirit is a problem.. 4.0 has been working perfect with no problems at all
    2010-06-24 05:47 PM
  7. FORDIE's Avatar
    I've used this to jailbreak the 3GS on the old bootrom firmware 3.1.2, worked like a charm.

    A note of warning, there's a problem with the tweak on cydia called "Five Column Springboard", if you're a fan of that tweak, wait until they've fixed the bugs in it. I installed the tweak, but the phone got locked in a continuous crash mode, so the choice was either stay in "safe mode", or re-jailbreak. I've re-jailbroke and tried it again, to only discover the same thing. So stay clear of it for now.

    But, this jailbreak is excellent, thanks a lot to whom it may concern.
    2010-06-24 05:48 PM
  8. rmathew_99's Avatar
    Thank you thank you thank you.... Can you point me to a link on how to restore to custom 3.1.3? Appreciate it!!!!
    Guys,
    I stuck at error 1600. Can someone help?
    2010-06-24 06:00 PM
  9. Lister 0f Smeg's Avatar
    Guys,
    I stuck at error 1600. Can someone help?
    I got that error in DFU mode. In recovery mode it get a little further but still errors with (2)

    Are there any super cleaver people on here that can help?
    2010-06-24 06:03 PM
  10. finalfantasy's Avatar
    Thx drmias I'll try that after work
    2010-06-24 06:05 PM
  11. dazzer1983's Avatar
    iPhone 3GS with blobs saved for 3.1.2 and 3.1.3
    Model mc131b
    I downgraded from official 4.0 to 3.1.2 and jailbroke with blackrain then install snowbreeze ipsw 4.0. Works great thou I did have a problem getting error 1600. Problem solved by putting into recovery by
    Turning off iPhone completely
    Holding down home button while connecting to USB.
    Release home button when iTunes detects retore.

    No more 1600 error.
    2010-06-24 06:05 PM
  12. High_Voltage's Avatar
    I have Itouch 2G But i jailbroke with Spirit with old bootroom, 7D11. Cant i just restore in itunes then use the Snowbreeze? One more question, is this version for snowbreeze tehered?
    2010-06-24 06:14 PM
  13. mj0470's Avatar
    Ok, so I'm still confuse as to what bootrom I have.... I have a 3gs, iOS4, Model MB716LL, S# 880022743, modem 05.13.04... F0recast says bootloader 6.4, when I go to DFU, I don't have a "Device Instance Path" and nowhere in there does it say anything about bootID...

    I really want to JB but can't figure out if I can or not.....
    2010-06-24 06:14 PM
  14. Jerzdre's Avatar
    i need a 3.1.3 firmware...where can i get it???cuz i understand that i need to downgrade in order to use this JB right?
    2010-06-24 06:32 PM
  15. rmathew_99's Avatar
    I tied your method. Still getting 1600. Anyone else? I also tried iH8sn0w 3.1.3. It does not seem to support 3GS.

    I was able to restore with my backup (non custom) ipsw file. Now what? Do you think it wipe off Spirit? Can I start over and try Sn0Breeze?
    Last edited by rmathew_99; 2010-06-24 at 06:44 PM. Reason: Automerged Doublepost
    2010-06-24 06:44 PM
  16. Jerzdre's Avatar
    HEY DR.......can u the 3.1.3 didnt work on my MAC... now im on windows........whats the website i can go to find 3.1.3?
    2010-06-24 06:45 PM
  17. jayman5446's Avatar
    Keep getting "Sn0wbreeze has Failed, cannot find file: Cusers\<name>\AppData\Local\temp\sn0wbreeze\Resourc es.zip"

    Anyone else getting this, or know why?


    * Found fix I believe, Sn0wbreeze 1.6.1 I'm using 1.6. Havent tried it yet
    Last edited by jayman5446; 2010-06-24 at 06:52 PM. Reason: Found fix
    2010-06-24 06:47 PM
  18. dazzer1983's Avatar
    I had that error from the mirror download. Try snowbreeze site
    2010-06-24 06:54 PM
  19. Eddy_Mt7's Avatar
    I can't get my phone to downgrade from 4 to 3.1.2 to do this new thing. I keep trying to restore it but when it has about a quarter left to finish restoring, a box comes up saying "iPhone could not be restored, an error occurred (1015) I downloaded the firmware from the firmware page on this website. I'm using windows, if that has anything to do with this.
    2010-06-24 07:02 PM
  20. ismail26's Avatar
    hey i have a 3Gs and im trying to jailbreak it. when i open sn0wbreeze i keep getting this warning from norton.
    2010-06-24 07:03 PM
574 ... 8161718192028 ...
LINK TO POST COPIED TO CLIPBOARD