1. Anthony Bouchard's Avatar

    Download 'yer update 'ye landlubbers!

    iOS 5.1 Beta 2 has been released to Apple developers today from the developers page of Apple's Web Site. The build number of his iOS version is 9B5127c and it supports every iOS 5 device.

    The update doesn't appear to come with any amazing new features however it carries over some updates from iOS 5.1 Beta 1 (found and reported by 9to5Mac) such as:
    • A "geofencing" setting that can help stop battery drain with the Reminders app when you're not using it.
    • There is now a 'Use Cellular Data' option to sync iTunes Match music in the iTunes Match settings.


    Nothing out of the ordinary just some minor bug fixes and tweaks. If we find anything else in iOS 5.1 Beta 2 we will keep you posted!

    One thing to note is that iOS 5.1 is coming and its right on the horizon. The Chronic Dev Team's untethered jailbreak will work for iOS 5.0 and iOS 5.0.1 users but iOS 5.1 will likely not be included. We recommend that the Chronic Dev Team holds off until iOS 5.1 is released to see if it will work on iOS 5.1 and if it does not then just release it for the older firmwares. iFaith provides a viable option for ALL users to get back on iOS 5.0 or iOS 5.0.1 if they need to so there are no excuses.

    Are you downloading iOS 5.1 Beta 2? Share in the comments below!

    Sources: 9to5Mac
    2011-12-12 08:11 PM
  2. mlee19841's Avatar
    Apple keeps pushing out that exploit fix. Not really worth downloading.
    2011-12-12 08:26 PM
  3. Twimfy's Avatar
    Also has the option to delete photos individually from Photo Stream...quite a significant step.
    2011-12-12 08:27 PM
  4. mlee19841's Avatar
    Also has the option to delete photos individually from Photo Stream...quite a significant step.
    Their might even be a hack on cydia for this. Not 100 percent sure tho.
    2011-12-12 08:30 PM
  5. scatman10's Avatar
    iFaith doesn't work with iPhone 4S though so its not a viable solution for everyone
    2011-12-12 08:32 PM
  6. Twimfy's Avatar
    iFaith doesn't work with iPhone 4S though so its not a viable solution for everyone
    Erm, what I meant was in this new update YOU CAN delete photos individually from Photo Stream. It wasn't a request. It's there.
    2011-12-12 08:38 PM
  7. FinalBillybong's Avatar
    I've just tried iFaith on my mates 4S and got a 'Device not supported' error. How can I save his APTicket so his deivce is protected for 5.0.1 restores?
    2011-12-12 09:03 PM
  8. Simon's Avatar
    I've just tried iFaith on my mates 4S and got a 'Device not supported' error. How can I save his APTicket so his deivce is protected for 5.0.1 restores?
    iFaith wont work on a 4S. Only option for that is the latest tiny umbrella.
    2011-12-12 09:05 PM
  9. Zokunei's Avatar
    So basically they're releasing it for the iPod for no reason other than jailbreak stopping? I'm curious what it says is new when you update.
    2011-12-12 09:13 PM
  10. theroyalwe's Avatar
    I've just tried iFaith on my mates 4S and got a 'Device not supported' error. How can I save his APTicket so his deivce is protected for 5.0.1 restores?
    You can't use it on his 4s. I would recommend trying TinyUmbrella (I believe it works for the new A5 chips but it will only pull in SHSH for active signings, as opposed to iFaith that takes what is on the device.
    2011-12-12 09:13 PM
  11. KraXik's Avatar
    Not sure about waiting until after the drop to release the untethered. I say let everyone upgrade to 5.0.1 and release the untethered then.

    Otherwise we could end up waiting for a fresh restore only to find the untethered won't work on 5.1.
    2011-12-12 09:39 PM
  12. iYeow's Avatar
    Iphone 4s and ipad 2 can't use ifaith to save blobs as there isn't any bootrom exploit. So all iphone 4s owner should update to 5.0.1 and wait for jailbreak if the jailbreak is an Userland Exploit which can be easily patched with new updates.
    2011-12-12 09:49 PM
  13. lunercrab's Avatar
    iFaith wont work on a 4S. Only option for that is the latest tiny umbrella.
    Can we save blobs on the iPhone 4s with tiny? I just tried the other day it said I can't get my blobs for 5.0.1 cause I'm too late. I'll try again tonight but I was under the impression u can't save anything on the ip4s.
    2011-12-12 10:06 PM
  14. excaliburlives's Avatar
    I have a 3GS with 4.3.3 do i have to use ifaith for 5.0.1? or just update and jailbreak when it's out?
    2011-12-12 10:30 PM
  15. Cellular's Avatar
    So no untethered jb till after 5.1 release?
    And yes I read the article...
    2011-12-13 12:05 AM
  16. teej1410's Avatar
    I don't have Windows software so I can't use iFaith. Does tiny umbrella save APtickets? Or even a cydia app?
    2011-12-13 12:34 AM
  17. Anthony Bouchard's Avatar
    So no untethered jb till after 5.1 release?
    And yes I read the article...
    Who said that?
    2011-12-13 12:42 AM
  18. mlee19841's Avatar
    So no untethered jb till after 5.1 release?
    And yes I read the article...
    I read the article too. Its says we recommend holding off until said software is released. As in the writers of the articles on modmyi. Hope it's not the case. But if so it will suck a tiny bit. Well all in all they do the foot work for free. Thanks for all the hard work.
    Last edited by mlee19841; 2011-12-13 at 12:49 AM.
    2011-12-13 12:47 AM
  19. Richard's Avatar
    Iphone 4s and ipad 2 can't use ifaith to save blobs as there isn't any bootrom exploit. So all iphone 4s owner should update to 5.0.1 and wait for jailbreak if the jailbreak is an Userland Exploit which can be easily patched with new updates.
    I thought all iPhone 4S users were advised to stay on 5.0 ???
    Can somebody please clarify should we stay on 5.0 or update to 5.01 before 5.1 is released.

    Thanks
    . I Am the Random Thanks Collector So Please Press the Thanks Button
    2011-12-13 02:21 AM
  20. Zokunei's Avatar
    I thought all iPhone 4S users were advised to stay on 5.0 ???
    Can somebody please clarify should we stay on 5.0 or update to 5.01 before 5.1 is released.

    Thanks
    This untether will work on 5.0 and 5.0.1 . Do whatever you want.

    Considering getting working exploits to fully bundled software usually takes about a month, I don't think they will necessarily have it ready before 5.1
    2011-12-13 03:08 AM
25 12
LINK TO POST COPIED TO CLIPBOARD