1. latino129j's Avatar
    Yes i have an iphone 4 on 5.0.1 and it works, 4.11.08 SUCCESS!!!!
    2012-04-22 05:26 PM
  2. ewokcwalk's Avatar
    i wonder if this would unlock the sim slot in the Sprint and Verizon versions to work with Straight Talk in US.
    2012-04-22 05:42 PM
  3. willryan42's Avatar
    Hey T-Mobile US users, what SIM ID did you choose? I'm running through the whole list, and iTunes says "sim card not supported" after every one I've chosen so far.

    EDIT: scratch that, I changed the carrier settings to "auto detect" and then continued with the copying/pasting etc., now it's working!


    So does this function like a factory unlock? Or does this process need to be repeated after a restore?
    Last edited by willryan42; 2012-04-22 at 06:01 PM.
    2012-04-22 05:50 PM
  4. Mrteacup's Avatar
    Already unlocked 3 iPhones and made $30 ))
    2012-04-22 05:54 PM
  5. Kevin8677's Avatar
    I have a 3GS 5.0.1 with BB 5.16.05 jb untethered with redsn0w running on straight talk. My phone is NOT unlocked & straight talk was able to activate mine over the phone once I have them the sim info from the sim card they mailed me. I guess the only reason an unlock wasn't required is because they use AT&T for their service. The only thing I had to get extra was tetherme in cydia from xsellize to get the mms working. It's working flawlessly.
    2012-04-22 06:27 PM
  6. xero87's Avatar
    Guys make sure when you're copying the IMSI, you are copying the IMSI under "SAM" and NOT "SIM".
    I mistakenly copied the IMSI SIM and not the SAM. I think it all went downhill after that for me...
    2012-04-22 06:46 PM
  7. Spiru's Avatar
    Hey T-Mobile US users, what SIM ID did you choose? I'm running through the whole list, and iTunes says "sim card not supported" after every one I've chosen so far.

    EDIT: scratch that, I changed the carrier settings to "auto detect" and then continued with the copying/pasting etc., now it's working!


    So does this function like a factory unlock? Or does this process need to be repeated after a restore?
    Thanks bro for that little tip! No more gevey and furiousmod for me!!!
    2012-04-22 07:20 PM
  8. willryan42's Avatar
    I mistakenly copied the IMSI SIM and not the SAM. I think it all went downhill after that for me...
    I did the same thing a few times, no adverse effects for me.
    2012-04-22 07:42 PM
  9. givemeagain's Avatar
    tried 3 times. didnt work....dont know what i've missing. iphone 4 5.0.1 jailbroke

    can u explain for me how did u make it work? thanx
    [email protected]
    2012-04-22 07:49 PM
  10. vhicke's Avatar
    I also have iphone 4 on 5.0.1 and baseband is 2.10.0.......Just wondering if that is the problem....The lower baseband....Should i update my phone...to 5.1...Anyone do this on 5.1 for iphone4 and did it work...Thanks

    tried 3 times. didnt work....dont know what i've missing. iphone 4 5.0.1 jailbroke

    can u explain for me how did u make it work? thanx
    [email protected]
    2012-04-22 08:10 PM
  11. maaaslo's Avatar
    and the 3gs?
    2012-04-22 08:17 PM
  12. confucious's Avatar
    It worked fine on a 3GS on 5.01 for me, just thought I'd try it, don't need an unlock on that phone so mow back to its original SIM.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2012-04-22 08:17 PM
  13. mihajmis's Avatar
    Succes- confirmed! Working for me 2

    Success! Confirmed! Working here (Telenor Serbia- BB 04.10.01)
    2012-04-22 08:24 PM
  14. 2k1's Avatar
    What doesn't this unlock?
    2012-04-22 08:26 PM
  15. confucious's Avatar
    I believe it is only for iOS5+ but I could be wrong.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2012-04-22 08:28 PM
  16. 2k1's Avatar
    Ah ok thanx
    2012-04-22 08:38 PM
  17. ruslan120's Avatar
    Created a video tutorial for Sprint / Verizon iPhone 4S !



    To alleviate some confusion, you DO need your original sim, OR a valid IMSI code!
    2012-04-22 09:09 PM
  18. Serg38461's Avatar
    Is anyone else getting Factory Activated in the "activation state" after hitting deactivate phone?
    2012-04-22 09:15 PM
  19. ruslan120's Avatar
    Is anyone else getting Factory Activated in the "activation state" after hitting deactivate phone?
    See video above for clear instructions
    2012-04-22 09:16 PM
  20. TheiPhone911's Avatar
    For those struggling with this; try Auto-Detect when doing "STEP 4". I just did this on one of my phones, iPhone 4, 5.1, with 4.10 and was getting the "Wrong sim card installed", than started the steps again, but changed step 4 to "auto-detect", than it activated through iTunes. Went through the rest of the steps, and its working great!! Will try 5.1 with 4.12 later along with a 4s 5.0.1, don't see why it wouldn't work.
    2012-04-22 09:23 PM
209 12345 ...
LINK TO POST COPIED TO CLIPBOARD