1. mzkaye729's Avatar
    Hi there. Does anyone here use the Jabra JX-10 II headset ? Because I bought one, worked great for a few hours. Then suddenly it just stopped working. I tested it again just now. Called my home number and I could not hear the ringing in my headset. I had someone call me too and I picked up the call using the headset but I could not hear them and they could not hear me (yes, the volume was turned all the way up). Currently, the only way for me to fix it is by power-cycling the headset.

    Has anyone else experienced this with the JX-10 ? I'm going back to my Motorola H300 even though it's so huge and "uncool-looking". I have since returned the JX-10 and gotten my money back. Now I'm thinking I must have just got a defective unit and I'm looking to buy another one. But I'm wondering if maybe there are some compatibility issues with the iPhone and the JX-10.
    2007-12-15 06:29 AM
  2. spam_artist's Avatar
    i use the jx-10, works fine for me....?
    2007-12-15 07:57 AM
  3. Michael415's Avatar
    i use the jx-10, works fine for me....?
    x2 mine works just fine as well.
    2007-12-15 08:30 AM
  4. mzkaye729's Avatar
    Thanks guys. Maybe i just got sold a bad one. I'm off to buy another one but it might not be a Jabra.ight decide to go for a Jawbone or an H9 or a Z9. We shall see!
    2007-12-18 01:33 PM
  5. Girlwerks's Avatar
    Yes! I do.. been using it since it came out with my razr..then switched to iPhone worked for about a day and same problem NO AUDIO.
    It will switch off a call but no audio no matter what I do.

    Does anyone here use the Jabra JX-10 II headset ? Because I bought one, worked great for a few hours. Then suddenly it just stopped working.
    2007-12-22 03:22 AM
LINK TO POST COPIED TO CLIPBOARD