1. RazzMcTazz's Avatar
    I've spent hours searching the web and trying different solutions. Can anybody please help me or confirm it's impossible to fix?

    My son had a perfectly working, unmodified iPod Touch 2G (MC revision I think). We bought him a newer 4G model and so the old 2G model went unused for a few months. When I tried to use the 2G, it wouldn't start up. My son said that he didn't try to jailbreak it, and I actually believe him. (He had me jailbreak his 4G.)

    Attempted fixes and symptoms:
    • Charged it overnight on a known good charger & cable.
    • Battery is OK because I can get a blank white screen.
    • I've tried rebooting many times (home & sleep) buttons. It won't boot. Black screen. No apple logo.
    • Turned off PC antivirus software for any communication with the iPod Touch.
    • I've put it into DFU mode (home & sleep button procedure) but get restore errors on iTunes. (See details below.)
    • I've attempted jailbreaks (Redsn0w, Greenpois0n, sn0wbreeze, etc.) many times, but it just won't boot up or jailbreak.
    • TinyUmbrella & iRecovery can communicate with it, but I can't do anything useful.


    If I use iRecovery and issue the standard sequence of recovery commands (see details below), after issuing the saveenv command, iRecovery responds:
    "nvram_save: no oldest bank previously saved, cannot continue".

    So I'm thinking that maybe the boot ROM or NVRAM (hardware or data contained therein) is corrupted or missing, but I have no idea how to restore it. (I'm an electronics engineer but not a developer so I can follow directions with some common sense, but that's about it.)

    Can anybody please help me get this thing restored?


    More boring details follow in case it helps.
    -------------------------------------------------------------------------------
    Whenever connecting to iTunes I get the following error:
    iTunes has detected an iPod in recovery mode. You must restore this iPod before it can be used with iTunes.

    Initially when I restored via iTunes I got the following error:
    The iPod "iPod" could not be restored. An unknown error occured (21).

    After trying to jailbreaking with Greenpois0n, I got the iTunes restoration error:
    The iPod "iPod" could not be restored. An unknown error occured (3194).

    Mostly the iPod Touch fails to do just about anything. Mostly it's either in a white or black screen.
    It seems to fail to boot. It seems to fail to jailbreak. Apparently Redsn0w won't work on the iTouch 2G version MC.

    If I try jailbreaking with Greenpois0n, it starts but then fails.
    (I've tried maybe 50 times.) The screen goes black and then flashes and then goes white. On a rare occassion, (perhaps after overnight cooling) the iPod touch will display the following but then it will hang and progress no further in the jailbreaking process:

    greenpois0n
    Greenpois0n.com
    ==================
    Unable to find gBdevList
    Unable to find fs_mount
    Unable to find fs_unmount
    Unable to find fs_load_file
    Greenpois0n initialized
    .
    If I simply try to use iRecovery (irecovery.exe -s), iRecovery will report:
    "Got USB No iPhone/iPod found"
    .
    But if I launch iRecovery (irecovery.exe -s) repeatedly while Greenpois0n is trying to jailbreak it, I can consistently get iRecovery to access the iTouch. And if I then immediately quit Greenpois0n, I can keep the iRecovery session going (otherwise iRecovery quickly terminates.)

    iRecovery reports the following upon connection.
    Got USB
    [FIL:INF] Found chip id 0x3294d798 on CS0

    [FIL:INF] Found chip id 0x3294d798 on CS1

    iBSS fro n72ap, Copyright 2010, Apple Inc.
    BUID_TAG: iBoot-931.71.16
    BUID_STYLE: RELEASE
    USB_SERIAL_NUMBER: CPID:8720 CPRV:13 CPFM: 03 SCEP: 04 BDID:00 ECID:000000B13A163D4C IBFL:00

    Entering recovery mode, starting command prompt
    (Recovery) iPhone$
    .
    I try to invoke the following commands that everyone on the web says to use:
    printenv
    setenv auto-boot true
    saveenv
    reboot
    .
    But upon issuing the "saveenv" command iRecovery responds:
    "nvram_save: no oldest bank previously saved, cannot continue".
    .
    Then when I issue reboot, nothing useful happens.

    It seems that maybe the NVRAM or boot ROM is broken or corrupted. I'm wondering if I could use iRecovery or something to restore the NVRAM or a boot image or something?

    Somebody else who had this problem reported that unsoldering didn't help, so I won't bother trying that.

    As a side note, I can communicate with the iPod touch using iTunes with with either a WinXP PC or a a Vista PC, but I can only communicate via Greenpois0n using a WinXP PC.
    Last edited by RazzMcTazz; 2012-01-08 at 04:13 AM.
    2012-01-08 04:02 AM
  2. cookingboy3's Avatar
    WOAHWOAHWOAH. Just noticed error 21. I'm not sure, but I keep encountering this error on my iPod Touch 4g.
    2012-05-04 03:56 AM
LINK TO POST COPIED TO CLIPBOARD