1. SioThaMan's Avatar
    Hello! My ipod touch 2nd gen 4.2.1 firmware is stuck in DFU mode and I've tried to use a couple of programs to exit recovery mode but nothing works (I think I know why) But here's a pretty big piece in this puzzle, my ipod won't get recognized by iTunes or any other program I've tried to use (where you are available to see if it is connected or not) but I can hear the "connect" sound from windows when I plug it in. Please help me : ) Thanks in advance (and yes this is my first post on this forum)

    I am using windows 7 64 bit.
    2012-08-19 02:53 AM
  2. H4CK3R's Avatar
    Try switching USB ports or trying another computer. It can make a big difference.
    2012-08-19 05:29 AM
  3. SioThaMan's Avatar
    I already tried that :/ I got the problem with itunes not recognizing my ipod like 2 months ago but then 1 week ago I tried again and it worked so I think that waiting may solve the problem but I want to make it work now :P
    2012-08-19 01:25 PM
  4. angel.tdw's Avatar
    same problem with me 2...
    same device, same firmware,,, and same win 7 x64.
    stuck.... in dfu mode....

    help needed!

    2012-11-22 08:47 PM
  5. burnt01's Avatar
    OK i think i had the same problem.
    2g itouch dont think os was my problem.. but it appeared dead, black screen although computer recognized it when plugged in told me it was in recovery mode although i now know it was in DFU mode. Got error 1600, 1601, 1602, 1604, 2005 and 1374 (not sure on that last one) after many recovery attempts, with different firmware, using tinyumbrella, ireb, ifaith and any other apps i could find!
    Also did the hold home and power trick and did nothing
    Anyway after hours...and i mean hours of messing around, turns out to be simple!
    It was a dead battery!!! i thought it would boot without one ( i had seen it done on youtube) must be different boot or firmware.
    I tested it with a multi meter and only 1.4v disconnected but getting charge of 4.20v connected, it must cut usb power when it restarts but with no battery power to remember what mode it was booting to, it loads into a dfu mode to be safe! and it cant restore because it needs to be in recovery mode after restart.
    Anyway i tested this with a 3.7v lith-ion bat from an old Sony Ericsson phone that was hiding in my missus draw (after a charge) soldered it in and recovered no probs , i was amazed. Dont worry i ordered a propper battery for it once i knew it was alive again
    2013-07-26 02:52 AM