User Tag List

  1. ZeroInfiniti's Avatar
    Hi everyone,

    So I got a 64GB iPod Touch for Christmas, jailbroke it with blackra1n and overall i've had no issues until I came across this one. Whenever I play a song the sound is outputting though both the internal speaker and my headphones. I've spent several days trying to resolve this issue, and so far no luck.

    One fix I found is that if I go into an app that requires sound, i.e. a game, the issue is resolved and the sound only outputs though the headphones. Although this doesn't last long, for some reason the issue resurfaces after a while.

    Another fix I found was rebooting the device but again the fix isn't permanent, this is also annoying due to the fact that my device is a 3rd generation so its a tethered jailbreak.

    My first solution was to find a toggle for SBSettings that would allow me to completely disable the internal speaker temporarily, so far no luck, not even a addon to the settings app that would allow me to disable it there. Truth be told, I would write my own toggle, but I don't know how to code in C. If someone could write me one with the SBSettings SDK, I would be very grateful.

    Anyone else got any other ideas, as to what could be causing this issue, or a possible resolution ??

    Thanks In Advance
    2009-12-29 12:22 PM
  2. Frostbite's Avatar
    Did you have the problem before the JB?
    If you wanna thank me hit "Thanks" in the lower left of my post. If you would like to follow me on twitter click here
    2009-12-31 11:21 PM
  3. ZeroInfiniti's Avatar
    Yes, but it didn't happen quite as often. FYI, to dispell any further confusion, yes my headphones Jack is in all the way.
    2010-01-01 06:00 AM
  4. Frostbite's Avatar
    Than its probably a problem with the ipod hardware, I would back up all JBd data using cybackup or aptbackup and restore than take it to the apple store and tell them that they sold you a broken ipod.
    If you wanna thank me hit "Thanks" in the lower left of my post. If you would like to follow me on twitter click here
    2010-01-01 05:54 PM
  5. ZeroInfiniti's Avatar
    Um... I think the word your looking for is faulty and well I really can't be bothered doing that. I would be able to solve the issue if I were able to toggle the speaker on and off. Honestly, I would code a toggle with the SBSettings SDK if I knew how to code in C.

    I know for a fact it's possible because I've seen a video on YouTube displaying the speaker toggle in the Skype app when in a call in the options, the video then went on to display that the toggle in that app is global over the whole OS.

    Since there is nothing else wrong do you think that if I backed up all the JB data and then restored and JB again then restored the data may fix the problem?

    EDIT: Now the first fix that I explained in the first post doesn't work and when this issue happens the headphones volume is fixed and only the speaker volume can be adjusted. However, rebooting it seems to still be a quick fix, but I'm uncertain as to whether its permanent or not. This is just getting really painful now.

    I'm beginning to wonder if AppSync is the culprit behind this friggin annoying issue. You might be able to sense my frustration a little more now.
    Last edited by ZeroInfiniti; 2010-01-02 at 05:31 PM. Reason: Automerged Doublepost
    2010-01-02 05:31 PM
  6. lutonant's Avatar
    Hi, I have the same problem :-(

    My nephew gave me his old Itouch as he thought it was broken. He thought there was no sound coming throught he left earpiece, It turns out the eapphones work fine. The problem I have is the sound from the internal speaker is constantly loud. What I have found is that if i turn the volume to 0+1 the speaker is a lot quieter but the earphone volume stays at what I believe to be max. Not an ideal solution...

    I believe this to be a hardware issue as I have hard reset and changed firmware a few times, problem exists throughout.

    An internal speaker toggle would be a fantastic solution if anyone could find the time.

    TIA
    The Ant
    2010-04-20 04:48 PM
  7. Timka21105's Avatar
    yeah, I have the same exact problem
    Tima Kudinov
    2010-04-23 12:36 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD